MS1 full-scan filtering: missing one highly abundant peptide?

support
MS1 full-scan filtering: missing one highly abundant peptide? miruppen  2014-04-09
 
Hi,
 we are having some trouble with the MS1 full-scan filtering procedure. In the lab we would like to start using Skyline to assess the DDA data quality from our Orbitrap Velos, based on ID-free metrics for 21 peptides of BSA.
We have created the spectral library from 8 .msf files and the corresponding .raw files for chromatogram extraction.
However, a highly abundant peptide of BSA we always identify (YLYEIAR; m/z 464.250++) is missing in the Spectral library explorer, and we cannot figure out why.

Please find the compressed .sky document attached.

This peptide elutes at Rt 28 min aprox.

Could anyone help us to find out why is this happening?
Thanks!
 
 
Brendan MacLean responded:  2014-04-09
Hi Isabel,
Can you send us at least one .msf file in which you feel this peptide was identified, and which you built into your library? This will allow us to debug why the peptide is not ending up in the library.

If the file is larger than a couple meg, I can provide a FTP site where you can post it. Just let me know.

Thanks.

--Brendan
 
damon barbacci responded:  2019-02-22
I am having a similar problem. Was there a resolution to this support request?
 
Nick Shulman responded:  2019-02-22
Hi, Damon,

It sounds like your saying that there is a peptide in your search results that is not ending up in the spectral library that you build.
If you send us your files we can take a look.
Files which are smaller than 50MB can be attached to this support request.
You can upload larger files here:
https://skyline.ms/files.url

-- Nick
 
damon barbacci responded:  2019-02-22
See the attached powerpoint showing Mascot and Skyline screen captures. I have highly abundant peptide(s) found in Mascot with great scores that are also in the SkyLine library but don't get associated with the protein and subsequently no MS1 extraction.

I will send other files by upload.
 
Nick Shulman responded:  2019-02-22
Damon,

In your settings at:
Settings > Peptide Settings > Library
you have "Pick peptides matching Library and Filter".
This means that Skyline will give you the subset of peptides that can be found in your spectral library, and also which pass your filter criteria.

In your filter settings:
Settings > Peptide Settings > Filter
you have "Max Length" set to 25 (which is the default). Because of this, Skyline excludes your peptide of interest "GDNQLQVQHTYFTGSEVENVSVNVHNPTGR", because it has too many amino acids in it.

It might be that you should change your filter settings so that peptides up to length 40 are allowed. Or, maybe you should change "Pick peptides matching" to just "Library", so that Skyline will ignore your filter criteria when deciding which peptides to give you.

There are also many ways to tell Skyline to give you even those peptides that do not match your filter criteria.
In the Spectral Library Viewer, when you press "Add All", Skyline may tell you that some peptides you are trying to add do not match the filter settings, and you can choose to override that.
Also, in the Targets tree, you can right-click on a protein and choose "Pick Children". The window that comes up shows you a filtered list of peptides, but if you press the button that looks like a funnel, Skyline will show you all the tryptic peptides.
-- Nick
 
damon barbacci responded:  2019-02-25
Thanks! By changing the maximum length my peptides are now associating correctly as far as I can tell. I was hoping there was just a setting I was missing somewhere and it was. Funny thing is that I had to set to minimum of 6 before for a couple shorter peptides I knew were in the data set but totally missed the max length. One of those "duh" moments.
 
damon barbacci responded:  2019-02-25
Thanks as well for the tip about the spectral library adding.