Table of Contents

guest
2019-10-13
Tips
   Audit Logging
   Import OpenSWATH Results
   DIA (Data Independent Acquisition)
     Generating an Overlapping Window Isolation List using Skyline
     Full Spectrum Demultiplexing of Overlapped DIA Windows using MSConvert
     Slides Explaining Data Independent Acquisition
     DIA Methods for Thermo Q Exactive
   Pivot Editor
   Document Grid Number and Date Formats
   UI Modes
   Skyline Lists
   Batch Calibration
   New in Skyline 4.1
   Adduct Descriptions and Small Molecule Labels
   Surrogate Standards
   Calibrated Quantification Support in Skyline 3.5
   Parallel Import Performance
   Skyline System Requirements
   Vendor-Specific Instrument Tuning Parameters
   Ion Mobility Separation (IMS) Data
   Chorus Cloud Chromatogram Extraction
   Working with Other Quantitative Tools
   How to Display Multiple Peptides
   Terminology Cheat Sheet
   How Skyline Builds Spectral Libraries
   ID Annotations Missing with Mascot Search Results
   How Skyline Calculates Peak Areas and Heights
   Support for Bruker TOF Instruments
   AB SCIEX Instrument Settings
   Recovering From a Broken Installation
     Recovering the .sky File Extension Association
   Sharing MS/MS Spectra with Manuscripts
   Share Skyline Documents in Manuscripts
   Export SRM Methods for a Thermo LTQ
   Skyline Source Code

Tips





Audit Logging


(This tip applies to Skyline-Daily 4.1.1.18257 and later.)

When enabled, the audit log will keep track of all changes that are made to the current document. The audit log is stored as a separate file (.skyl), alongside with the skyline document.

The audit log can be accessed from the View menu. The audit log is displayed in a grid, similar to the document grid. In the top right corner audit logging can be enabled or disabled.

For new documents, audit logging is enabled by default.

Reasons to enable Audit Logging

•Reproducibility: The audit log makes it easy to see what changes were made to a document and can be used to reproduce a document step-by-step. 
•Collaboration: If multiple people are working on the same document it can be helpful to have a record of what each person has done to the document. 
•Troubleshooting: If the user encounters an error in Skyline, the audit log can be helpful for the Skyline team to diagnose and fix the issue.

 

Full details can be found here (PDF).




Import OpenSWATH Results


NEW! in Skyline 4.2: You can now import OpenSWATH results either from TSV or OSW file into Skyline for data visualization and beginning the targeted method refinement process.

See the PowerPoint slides attached below and watch the video from the ETH DIA/SWATH course:




DIA (Data Independent Acquisition)





Generating an Overlapping Window Isolation List using Skyline


(This tip relates to Skyline v 4.2 or later.)

This is a quick demonstration on how to use Skyline to generate an overlapping-window isolation window list suitable for acquisition using the approach described in this manuscript and downstream computational demultiplexing.

To begin this demo, start with a blank Skyline document: 

  • From the Skyline landing page, click Blank Document

  • On the Settings menu, click Transition Settings and in the Transition Settings dialog box, click the Full Scan tab.

SkylineFullScan 

  • Under MS/MS filtering, click the Acquisition method dropdown and select DIA. 
  • For the Isolation scheme, select Add ...

 SkylineAddIsolation

  • In the Edit Isolation Scheme dialog, enter a name for the Isolation scheme such as '20mz_overlap' and then click the Prespecified isolation windows radio button.  

SkylineIsolationScheme 

  • Click the Calculate ... option and enter parameters for the method.  
  • Enter '500' for Start m/z.
  • End m/z is '500'.
  • Window width should be '20'.
  • Be sure that Deconvolution is set to Operlap and that Optimize Window Placement is checked.

SkylineCalculationIsolation

  • Click OK to close the Calculate Isolation Scheme dialog and OK to close the Edit Islation Scheme window.
  • Click OK once again to close the Transition Settings dialog.
  • From the main Skyline menu, select File and then Export.  From the flyout menu, click the Isolation List ... option. 

SkylineExport1

  • In the Export Isolation List window, select the appropriate instrument (for this example, 'Thermo Q Exactive') and choose a file location in which to save the list of isolation windows.

SkylineExport2 

The resulting isolation list contains the isolation centers of each isolation window in the order that they should be acquired. NOTE: the isolation centers will need to be regenerated using this approach if any of the other acquisition parameters such as isolation width or m/z range covered are changed.





Full Spectrum Demultiplexing of Overlapped DIA Windows using MSConvert


(This tip relates to Skyline 4.2 and later.)

This is a quick demonstration on how to use MSConvert to generate a demultiplexed dataset from an input datafile(s) containing spectra with overlapping data independent acquisition windows. In the case of the overlapped window approach described in this manuscript, the output from MSConvert will contain twice as many spectra as the input (two demultiplexed spectra are generated from each acquired MS/MS spectrum). This tutorial uses MSConvert distributed with ProteoWizard version 3.0.18328 with vendor libraries downloadable here: http://proteowizard.sourceforge.net/download.html

 

  • Open MSConvert and select the Browse option to select the input overlap-multiplexed files.  
  • Select the SIM as spectra option.

msconvert1

 

  • OPTIONAL: Change the output format for the file using the Output format drop-down menu. This tutorial outputs mzML.
  • Add a Peak Picking filter to the data by selecting the options indicated below and clicking the Add button below the Filters section:

msconvert2

This causes the MS2 data to be centroided prior to demultiplexing, which is currently a requirement for full-spectrum demultiplexing using MSConvert. If the data were acquired with centroiding enabled, this step will have no effect and demultiplexing will proceed as expected.

 

  • In the Filters section, add a Demultiplex filter with optimization set to Overlap Only  with the settings shown below. 
  • Click the Add button.

msconvert3

 

Note that the mass error may need to be adjusted depending on instrument platform. The mass error should be set to the maximum error expected in m/z measurement of the same analyte in subsequent spectra. Note that this measurement is of expected deviation of a measurement from spectrum to spectrum, not its deviation from the correct theoretical m/z (mass accuracy).

  • Click Start to output demultiplexed files.





Slides Explaining Data Independent Acquisition


Powerpoint slides with useful information on the fundamentals of Data Independent Acquisition (DIA) are provided below.

Introduction to Data Independent Acquisition

DIA Method Design

DIA Data Analysis

Future Directions of DIA

Please note that these slide decks are incomplete because slides containing unpublished data have been removed.  If you would like the full slide deck for your personal use, or would like to use some of these slides in your own presentation, please contact the MacCoss Lab at: info@maccosslab.org

Additional material on DIA:

DIA Tutorial

DIA Methods for Thermo Q Exactive

DIA Webinar




DIA Methods for Thermo Q Exactive


The attached mini-tutorials explain how to set up DIA methods for the Thermo Q Exactive instrument:




Pivot Editor


The pivot editor lets you combine rows in the Document Grid, and perform aggregate operations on them such as "Mean" or "StdDev".

 

Here are some examples of how to use the Pivot Editor.




Document Grid Number and Date Formats


The Document Grid allows you to specify formats for columns that contain numbers or dates, or other formattable data types.

To set the format of a column, right-click on it and choose "Number Format...".

The "Choose Format" dialog allows you to specify a custom format string.

Microsoft provides documentation for custom number format strings and date format strings.

If you want to save your formatting choices with your custom report, you can use the "Remember Current Layout..." menu item, which is on the Group/Total button next to the Reports dropdown on the toolbar at the top of the Document Grid.

 

When a report is exported for external tools, the format used for all numeric columns is always the round-trip format ("R"), which provides the full precision possible for the numeric values. This is the format that is used if you choose "Invariant" as the language when exporting a report at "File > Export > Report".




UI Modes


Skyline was built from the ground up as a proteomics targeted mass spec research tool. By popular demand, Skyline’s support for more general biomolecular mass spectrometry research has steadily increased over the past several years.

Unfortunately until the Skyline 19.1 release the user interface remained proteomics-centric. Non-proteomics researchers had to think “molecule” while seeing “peptide”, and it wasn’t always easy knowing which parts of the UI didn’t apply to your work. This was especially true for new users.

But now, Skyline adjusts its user interface according to the kind of molecules you're working with.

For full details continue reading the attached PDF.




Skyline Lists


Skyline 19.1 added new feature "Lists" which allows you to add arbitrary lists of data to a Skyline document.




Batch Calibration


Skyline 19.1 allows you to specify the "Batch Name" on replicates so that different replicates will use a different set of external standards.

See the attached PowerPoint to see how to use this feature.




New in Skyline 4.1


Attached are a collection of slides created by the developers as they added new features in Skyline 4.1 which required a bit of explanation:

  • Small molecule spectral libraries, improved adducts, and identifier (InChiKey, InChi, CAS, and HMDB)
  • Document Grid and Live Report pivot and layout support
  • Group comparison volcano plot with formatting
  • Peak Area CV histogram plots
  • Quantitative property for transitions
  • Points across the peak visualization in chromatogram plots



Adduct Descriptions and Small Molecule Labels


(This tip applies to Skyline-Daily 3.7.1.11357 and later)

Ionization in Peptides vs Ionization in Small Molecules

Skyline assumes protonation for peptides so we can simply speak about "charge" or "charge states". For generalized molecules, we have to think about all kinds of ionization so we speak in terms of "adducts". Adduct descriptions may also specify isotope labels applied to the neutral molecule description. As such, "adducts" are similar to the idea of "modifications" in the peptide regime. 

Describing Ionizing Adducts

Skyline uses the defacto standard notation for ionizing adduct descriptions, as found at the Fiehn Lab's MS Adduct Caclulator and the GNPS Spectral Library. This notation has a few major parts:

Usually beginning with a left brace "[",

then an optional  dimer/trimer/etc specification,

then an "M"

then an optional isotope label specification,

then the chemical formula of the adduct,

then a closing right brace "]".

Describing Labeled Versions of Molecules for Quantification

For quantification of heavy/light pairs, Skyline expects to see a single molecule with heavy and light adduct descriptions. For example you might describe the light ion as having adduct [M+2H] and its heavy counterpart as having adduct [M4D+2H] (double protonated, and four H replaced by D). Here is a transition list describing that scenario:

Molecule,Precursor Formula,Precursor Adduct
Caffeine,C8H10N4O2,[M+H]
Caffeine,C8H10N4O2,[M4D+H]

The important point is that it describes a common molecule with distinct adduct descriptions, one of which includes labeling information.

Simple Examples

Singly protonated: [M+H]

Doubly deprotonated: [M-2H]

Sodiated: [M+Na]

N-Mer Examples:

Sodiated dimer: [2M+Na]

Deprotonated trimer: [3M-H]

Isotopic Label Examples

Sodiated, and two carbons per molecule replaced with C13: [M2C13+Na]

Sodiated, and two carbons per molecule replaced with C13, and three nitrogens replaced with N15: [M2C133N15+Na]

Charge-Only Examples:

Often transition lists are presented as m/z values with integer charges only, and the actual mode of ionization can not be inferred. In these cases we just give an integer charge value.

Unknown ionization mode, charge = 1: [M+] or [M+1]

Unknown ionization mode, charge = -2: [M-2]

Charge-Only Examples with Isotope Labels Described Only by Mass:

Sometimes a transition list indicated different precursor m/z values for the same named molecule, Skyline reads this as an isotope label of unknown formula, and expresses the mass shift as a number.

Unknown ionization mode, charge = 1, and mass shift due to unknown isotopes of total mass 5: [M5.0+]

 

 

 




Surrogate Standards


Sometimes you want to normalize a particular analyte against a different molecule. Skyline supports this with the "Surrogate Standard" feature.

To designate that a molecule can be used as a surrogate standard, right click on the molecule in the Targets tree and choose "Set Standard Type > Surrogate Standard".

You have to use the Document Grid to change the normalization method of the analyte. The "Normalization Method" column is not shown by default, so you need to customize a view in the Document Grid and add that column. You can start by choosing "Peptides" from the Views dropdown on the Document Grid. Then, choose "Customize View" and add the "Normalization Method" to the view. The Normalization Method column is under "Proteins > Peptides". (also note the button at the top with the binoculars icon can be used to find columns by name)

If you have surrogate standards in your document, then the "Normalization Method" column will have options of the form "Ratio to surrogate..."




Calibrated Quantification Support in Skyline 3.5


Calibrated quantification (a.k.a. absolute quantification) has been added to Skyline in version 3.5. We plan on extending documentation of this feature in the future in a number of ways:

  1. Updating the existing Absolute Quantification tutorial
  2. Writing a new tutorial on calibrated quantification that covers all of the available applications
  3. Including a detailed demonstration of the functionality in a future webinar

Until this work can be completed, however, you can find attached to this page a set of PowerPoint slides which hopefully provide enough of a rough overview of what is now possible that anyone interested can at least get started with the new functionality.

Also, the Skyline Tutorial Webinar #12 gives some initial coverage on this feature near the end of the recording (and in presentation slides).




Parallel Import Performance


Attached to this page you will find a thorough study of how Skyline scales importing large scale DIA data with parallel file import of various file types on either a standard Intel i7 comptuer with 16 GB of RAM versus a Dell PowerEdge with 48 logical processors 196 GB of RAM, using either multiple threads or multiple processes.

General findings include:

  • Multiple process import can scale past mutiple threads in the same process (which we think is related to garbage collection)
  • Only multi-process import can take advantage of the true potential of a NUMA system with 24+ logical cores
  • The difference is much less pronounce on an i7 an may not be worth the effort to go multi-process
  • Many formats pay only a percentage increment for spinning disk versus SSD
  • The mz5 format, otherwise the fastest format to import, has serious problems scaling with parallel file import on a spinning drive

At the time of this writing, only the Skyline command-line interface (presented by SkylineRunner or SkylineCmd) can take advantage of multi-process import by using the --import-process-count argument.




Skyline System Requirements


OPERATING SYSTEM:

Skyline runs on Windows 7 or later. 

Skyline is tested nightly on 64-bit Windows 7 and 64-bit Windows 10. Most of our development is on Windows 10 (and 7), but we know of no reason Windows 8 and 8.1 shouldn't work. 

We test the 32-bit Skyline build, but not regularly on a 32-bit OS, and < 10% of Skyline use is now 32-bit. We are likely to phase out 32-bit builds sometime in 2019.

Skyline 2.6 was the last version to support Windows XP. (All versions of Skyline since 1.4 can be downloaded from "Unplugged" installation pages by clicking "I Agree" and then the "Archive" link.)

 

PROCESSOR, MEMORY AND DISK:

There is no minimum requirement, but for performance reasons a large fast hard drive is desirable.  The amount of memory needed depends on the size of your experiments, but 4GB is a good start. Skyline is frequently taught on relatively average modern laptops. But, for larger-scale processing we recommend a more powerful desktop system with dual 24-inch monitors to take full advantage of Skyline display capabilities.

We recommend modern i7 quad-core processors, running at 3.5 to 4.0 Ghz work well, with 16 to 64 GB of RAM and a fast SSD (e.g. 500 GB) + a spinning HD with more room (e.g. 2 TB).

Recent orders for Skyline developers have been the following configuration for $1829 USD:

Dell XPS 8900 Desktop - Intel Core i7-6700 6th Generation Quad-Core Skylake up to 4.0 GHz, 64GB DDR4 Memory, 1TB SSD + 4TB SATA Hard Drive, 2GB Nvidia GeForce GT 730, DVD Burner, Windows 10

https://amzn.com/B01DUVEZ6K

For really large-scale projects, like hundreds of DIA or DDA files with many hundreds of thousands of transitions, Skyline now makes effective use of highly multi-processor (NUMA) servers with 192+ GB of RAM. We have been using Dell PowerEdge R630 with 48 logical processors and 192 GB (spec attached - purchased for under $10,000 USD). For best import performance, use SkylineRunner command-line interface with --import-process-count=12 (or similar). Be sure to run tests. Mileage may vary depending on the import file format and disk drive type and speed.

With a large server like this, make sure the power profile is configured for "maximum performance", both in Windows and UEFI/BIOS. (Check Power Options and make sure this is not set to "Balanced", but "High performance" and check with your IT about BIOS settings.)



Vendor-Specific Instrument Tuning Parameters


As of release 3.5, Skyline's small molecule support includes the ability to explicitly set many vendor-specific instrument tuning parameters on a per-precursor basis.

The "Insert Transition List" dialog for small molecules now has columns for importing various vendor-specific values such as "S-Lens", "Cone Voltage", "Declustering Potential" and "Compensation Voltage", along with the previously implemented ability to explicitly set "Collision Energy", "Retention Time" "Retention Time Window", "Drift Time", and "Drift Time High Energy Offset". These values can also be modified in the Document Grid.

These values can also be modified in the document grid for peptides (formerly this was only possible for small molecules).

By default S-Lens values are not written: a new checkbox in the Export Method dialog enables this for appropriate Thermo outputs. On the commandline side, there is a new argument "exp-use-s-lens" for this.




Ion Mobility Separation (IMS) Data


Skyline supports IMS data for Waters, Agilent and Bruker instruments.  Using an ion mobility predictor can help Skyline ignore unwanted signals and improve data quality.  By specifying the predicted ion mobility for each molecule of interest you can tell Skyline to ignore other scans that might contribute noise.

To add or change an ion mobility predictor, use the Settings|Peptide Settings menu item and select the Prediction tab, then the Ion Mobility Predictor button to bring up the Ion Mobility Predictor table editor.  

The easiest way to set up an ion mobility predictor table is to start with a Skyline document with imported results, then use the "Use Results" button in the Ion Mobility Predictor editor.  This simply scans the existing imported results and determines the ion mobility value of the scan containing the most intense peak.  Once you have that, you can reimport the data and Skyline can ignore scans at the proper retention time but wrong ion mobility.

There is a risk, of course, that the most intense peak at a given retention time isn't actually that of the precursor you are interested in, in which case you will be making the noise situation worse instead of better.  The ideal way to use this training feature is with simple training sets that elute one precursor at a time.  If you do not have that capability then you should go through and verify the ion mobility selections manually using the chromatogram viewer's intensity heat map of mz vs ion mobility.




Chorus Cloud Chromatogram Extraction


Skyline 3.1 introduces the ability to query raw data files stored in the Chorus raw data repository for chromatograms and spectra. Hopefully we will have a more detailed tutorial on this soon, but in the meantime you can download and watch this video comparison of extracting chromatograms from raw DIA on a local hard-drive and the same data on Chorus.

You can also consult the slides from Brendan's ASMS 2014 presentation:

Start a project on Chorus and upload your full-scan (DIA, PRM or DDA) data to get started today.

NOTE: Remote chromatogram access not yet supported for SRM data or MSX data.
NOTE: We are currently working on supporting Agilent and Waters full-scan IMS data.




Working with Other Quantitative Tools


The Skyline project has implemented integration with many tools and instrument platforms.  Skyline supports building spectral libraries from the outputs of nearly 20 different peptide spectrum matching pipelines.  It exports methods to and imports data from the instruments of 6 different vendors.  And, Skyline integrates with a number of external tools and the Panorama targeted proteomics knowledge base.

Here are two brief tutorials describing how Skyline also integrates with other chromatography-based quantitative tools and information they may produce:

Importing Integration Boundaries from Other Tools
This tutorial covers Skyline support for importing the start and end integration times determined for peptide elution by tools other than Skyline.  You can use this feature to benchmark or visualize the performance of other tools, or simply to incorporate their results into a Skyline-based workflow.

Importing Assay Libraries
Several tools have begun to use enhanced transition lists (with added relative product ion abundance and normalized retention times - iRTs) called "assay libraries".  To better support this format, Skyline will now suggest creating an iRT calculator and a minimal spectral library during transition list import when these extra columns are detected.  Learn what to expect and what to watch out for when using this feature. 




How to Display Multiple Peptides


Skyline allows you to compare chromatograms of different peptides by selecting them in the Targets  panel shown by default on the left side of the Skyline window.

For example, to see all the peptides belonging to a particular protein, click on the protein name in the Targets panel:

Skyline generates a color for each peptide based on the peptide sequence and modifications.  This provides a quick way to identify the matching chromatogram in the graph.  A peptide will always have the same color, even in different Skyline documents, unless there is another peptide within the same protein that generates the same color.  That doesn’t happen too often, but when it does, Skyline picks one of the conflicting peptides and assigns it a new color that is easier to differentiate.

Color swatches are shown in the Targets panel next to only those peptides which are shown in the graph.  In the example above, only the peptides under the selected protein are shown in the graph.

The peptides are also labeled in the graph with a unique abbreviation.  If the first three letters of the peptide’s name are unique (among the peptides being graphed), then only three letters will be used in the abbreviation.  If the first three and last three letters together are unique, the abbreviation will use those (see ASL…KGK in the example above).  More complicated abbreviation schemes are used if the first and last three letters are not unique.  Note that a peptide’s abbreviation can change depending on what other peptides are being displayed at the same time.

Graphing peptide subsets

The Targets panel allows you to select any subset of peptides you want.  You can select just a few peptides (from one protein, or across different proteins) by clicking on the first, and then holding the CTRL key down while clicking on additional peptides.  You can toggle a peptide by clicking on it multiple times with the CTRL key depressed.

You can select individual peptides by clicking on their names, or you can select all the peptides belonging to a protein by clicking on the protein name.

 

 

All peptides

To see every peptide in the document graphed, click somewhere in the Targets panel to transfer focus there, then type CTRL-A (or choose Select All from the Edit menu):

Note that this can take some time to display if your document contains a large number of peptides.

Displaying all the peptides will produce a graph that looks similar to the progress displayed during data import:

But you can see differences between this graph and the one above.  Peptide colors will usually match, but occasionally they don’t if a different color is needed to disambiguate two peptides in the same protein.  Peak values can also differ, because different summation criteria are used during import than later when more processing has been done on the raw data.




Terminology Cheat Sheet


At the recent Targeted Proteomics Course at UW 2014, participants claimed that the many terms we have in mass spec proteomics with exactly the same meaning made the course much more difficult to follow.  They requested a glossary or cheat sheet that might help them translate between these various terms.  Here it is:

SRM - Selected Reaction Monitoring (sometime confused as Single Reaction Monitoring - no such thing).  Common synonym MRM (Multiple Reaction Monitoring).  Performed on triple-quadrupole instruments, where the instrument cycles through a pre-specified set of precursor m/z (Q1), product m/z (Q3) pairs called 'transitions', using the quadrupoles as filters (usually 0.5 to 1.0 m/z range).  Cycle time is determined by the sum of the dwell times of all transitions in the set.
MRM - Multiple Reaction Monitoring, a synonym for SRM created and trademarked by AB SCIEX, but extremely popular because of early popularity of AB Q TRAP instruments for performing this method.
scheduled-SRM = scheduled-MRM = dMRM = dynamic-MRM - In order to allow measuring a greater number of transitions in a run, transitions are specified with start and end times (or retention times and windows) to allow the instrument to measure each transition for only a fraction of the entire gradient.  Cycle time at any given time is determined by the sum of the dwell times of all transitions being measured at that time.
iSRM = intelligent-SRM = triggered-SRM = triggered-MRM = tMRM - In order to gain more confidence in the correct identification of a chromatogram peak in SRM without overly sacrificing quantitative throughput, the instrument measures a set of primary transitions, as in normal SRM/MRM until the intensity on those transitions exceeds some threshold.  When the threshold is exceeded, the instrument takes one or more measurements of a secondary set of transitions usually used only for peak identity confirmation, and not quantification. 

Targeted MS/MS = tMSMS = PRM = MRM-HR - Like SRM, but performed on a full-scan instrument (ion-trap or Q-TOF).  The instrument cycles through a pre-specified set of precursor m/z values, using quadrupole or ion trap isolation as a filter (usually 1.0 to 2.0 m/z range) and collects a full MS/MS fragment ion spectrum for each.  Cycle time is determined by the sum of the dwell/accumulation or scan times of all scans in the set.  Software is used to extract chromatograms from the resulting MS/MS spectra.  If the spectra are high-resolution, then extraction can be done using 50-100pm range, making it more selective than SRM.  Common synonyms PRM (Parallel Reaction Monitoring), MRM-HR (HR = High Resolution), pSRM (Pseudo Selected Reaction Monitoring).

MS1 [Full-Scan] Filtering - Chromatograms are extracted from the MS1 scans of normal DDA (Data Dependent Acquisition) data.  Because of the semi-random sampling approach, for MS/MS, of DDA, it is not possible to extract product ion chromatrams (time, intensity) with meaningful peaks for quantification.  Chromatogram-based quantification from DDA runs is limited to extracted ion chromatograms from the MS1 survey scans of such runs.  Common synonym Label Free Quant.

DIA = SWATH = HRM - Data Independent Acquisition is a technique where ranges of precursor m/z are isolated and subjected to fragmentation in a consistent pattern over cycles of time.  In this way a mass spectrometer can be set up to gather fragment ion spectra for large regions of precursor m/z space, independent of the actual precursor ions being fragmented, which may include fragments for multiple precrusors in any given scan.  Software can be used to extract product ion chromatograms from the acquired MS/MS spectra.  Cycle time is determined by the sum of the dwell/accumulation or scan times of all scans in the set.  (e.g. 20 ranges x 10 m/z = 200 m/z total range, 30 ranges x 20 m/z = 600 m/z total range)
SWATH - Popular synonym for DIA coined in Gillet, et al. MCP 2012, but also trademarked by AB SCIEX, originally specified as 32 x 25 m/z ranges covering 400 - 1200 m/z.
HRM - Hyper Reaction Monitoring, less common synonym for DIA/SWATH.
MSe - Type of DIA where ions are collected without prior filtering in alternating low- and high-energy scans (all precursors and fragments of all precursors respectively), coined and trademarked by Waters.  Common synonym All-Ions DIA.




How Skyline Builds Spectral Libraries


Skyline builds spectral libraries using a separate program called BiblioSpec, which has two main components. BlibBuild is called to build the redundant library, which is then filtered by BlibFilter to create the non-redundant library. The BlibBuild page contains information on the various search engines that are supported, along with information about their respective file formats and the scores used with the cut-off value specified in Skyline.

BlibFilter chooses the best spectrum within a group by simply using the one with the best score. If there are multiple spectra tied for the best score, the one with the highest TIC is selected. In the past, BlibFilter chose the spectrum with the highest average dot product when compared to all other spectra within the same group, but this method occasionally produced poor results. A similar method, computing a consensus spectrum and its dot product against the related spectra, also produced inferior results as it sometimes resulted in high-noise spectra being chosen.

Skyline with BiblioSpec supports building libraries from the following peptide spectrum matching pipeline outputs:

  • Mascot (DAT)
  • ByOnic (mzIdentML / MGF)
  • Comet (sqt / ms2, pepXML / mzXML)
  • Myrimatch / IDPicker (mzIdentML / mzML)
  • MaxQuant Andromeda (msms.txt with modifications.xml)
  • Morpheus (pepXML / mzXML)
  • MSGF+ (mzIdentML / mzML)
  • OMSSA (pepXML / mzXML)
  • Peaks (pepXML / mzXML)
  • PeptideShaker (mzIdentML)
  • PRIDE XML
  • Protein Pilot (group or group.xml)
  • Protein Prospector (pepXML / mzXML)
  • Proteome Discoverer (MSF / pdResult)
  • Scaffold (mzIdentML / MGF)
  • Spectrum Mill (pepXML / mzXML)
  • TPP (pepXML / mzXML)
  • X! Tandem (xml output)
  • PLGS - Waters MSe (final_fragment.csv)
  • Custom (SSL)

 

Importing Existing Spectral Libraries

Skyline can also read existing spectral libraries including:

  • SpectraST (.sptxt) 
  • theGPM  X! Hunter (.hlf) 
  • Shimadzu (.mlb)
  • NIST (.msp)

Working with NIST files

If your library contains spectra for multiple instruments and conditions (e.g. various CE values) it is important to use the NIST-supplied filtering tools to produce a subset of spectra appropriate to your experimental conditions. Each molecule+adduct (or peptide+charge) pair can appear in a .blib file only once, and without thoughtful filtering you will almost certainly produce a .msp file that can't be used by Skyline because it contains more than one instance of a molecule+adduct (or peptide+charge) pair.




ID Annotations Missing with Mascot Search Results


Skyline supports several workflows where the retention time of peptide search identified MS/MS spectra are used to help it pick chromatogram peaks, and for subsequent visual inspection.  The most visible effect of when this extra information is present and usable by Skyline is the addition of ID annotations to the chromatogram graphs, as shown below:

If you build a spectral library or use the Import Peptide Search wizard to import Mascot search results for use with full-scan chromatogram extraction, and find that you do not see ID annotations in your chromatograms as you would expect, the problem most likely originates with the MGF converter you used to create MGF files as input to Mascot.

For Skyline to be able to place an identified spectrum on an extracted chromatogram, it needs two things, beyond the peptide identification itself:

  1. A spectrum source file name that Skyline can match with the data file used to extract chromatograms.
  2. A retention time at which the spectrum was measured.

The spectrum source file name does not need to match exactly with the file specified in the Import Results form.  Skyline uses base name matching, which counts all of the following files as matching:

  • spectrum_source.raw
  • spectrum_source.mzXML
  • spectrum_source.c.mzXML
  • spectrum_source.ms2
  • spectrum_source.mzML

Note also that Skyline completely ignores any path information included with the spectrum source file name. Many converters will include a full path, but this is not necessary, and Skyline will match chromatogram data imported from any path, as long as the file basenames match.

The first place to look for clues on contents of any library is the Skyline Spectral Library Explorer (View > Spectral Libraries).  A library built from search results that contain the necessary information will look like this:

If you click the button beside the Library drop down list, Skyline will display the Library Details form with a list of the spectrum source files from which there are identified spectra in the library:

The most common issue you will see with a Mascot DAT file is that it does not contain spectrum source file information in a format that Skyline can understand.  That format can be traced back to the TITLE lines in your original MGF file.  Thanks to a lack of standardization in this area, a long stream of bug reports has lead to Skyline handling a number of different TITLE line formats, but the most flexible and robust format are:

TITLE=...File: "path/to/file.raw"...

or slightly less robust:

TITLE=...File: path/to/file.raw ...
TITLE=...[path/to/file.raw]

Since the first does not allow spaces in the path, and the second does not allow brackets in the path.  Note again that the path information will be ignored by Skyline in matching with imported chromatogram files, though characters in the path can have a negative impact on parsing of some formats (e.g. spaces in format that relies on a space as a terminal character).

The retention times are provided by RTINSECONDS lines in the MGF like:

RTINSECONDS=3006.0281

Problems in either of these can cause issues that show up like the following Spectral Library Explorer figures:

Issue 1: The TITLE line in the MGF file did not contain a recognizable format (described above) from which the spectrum source file can be parsed, causing the DAT file name to be used instead.  If your DAT file contains the search results for a single file, this can be corrected by simply renaming the DAT file to have the same base name as the data file you will import for chromatogram extraction (e.g. spectrum_source.dat).

Issue 2: The RTINSECONDS line in the MGF file was missing, causing the spectrum RT value to be set to zero.

Issue 3: A time outside the gradient length is shown.  Something has gone wrong with the library builder parsing this file.  You should report something like this to the Skyline team.

Issue 4: Every spectrum has a different source file not representative of files on disk.  Something has gone wrong with the library builder parsing this file.  You should report something like this to the Skyline team.

If you run into any problems like this, we always recommend installing ProteoWizard and using MSConvertGUI to create your MGF files, as shown below:

Note that you must make sure the TPP compatibility check box is checked.

If the MGF converter you used comes from an instrument vendor or professional software company, and you want help communicating with them what is required for full integration with a workflow that includes Skyline, either point them to this page, or post your issue to the Skyline support board.




How Skyline Calculates Peak Areas and Heights


Definition:

  1. Background height: minimum intensity at peak boundaries
  2. Background area (named Background):
    • rectangular area of background height times the length between peak boundaries (pre-v1.4 patch 1)
    • total integrated area of the minimum of background height and intensity at each point (v1.4 patch 1 and later)
      (Note: the unit of RT time is second for this calculation)
  3. Peak height (named Height): maximum intensity between peak boundaries minus background height
  4. Peak area (named Area): total integrated area within peak boundaries minus background area (Note: the unit of RT time is second for this calculation)
    • area can be zero and background greater than total raw area (pre-v1.4 patch 1)
    • area plus background always equals raw area (v1.4 patch 1 and later)

NOTE: Skyline uses points that have been linear interpolated from the raw data onto a uniform interval over the duration of the chromatogram in detecting its peak boundaries and calculating its peak areas. These are also the points Skyline displays in its chromatogram graphs. Skyline uses several types of smoothing (1st derivative, 2nd derivative and Savitzky-Golay) in order to place its automatically calculated peak boundaries. These smoothed curves are available for display in the Skyline chromatogram graphs. Skyline does not, however, use smoothed data in calculating peak areas (or area under the curve - AUC). It always uses the raw interpolated points presented in the unsmoothed graphs.

Example of calculation of peak height and background area:

 

Note: with v1.4 patch 1 and higher the light blue areas are not included in the background area.





Support for Bruker TOF Instruments


Skyline v2.1 introduces fully integrated support for Bruker micrOTOF-Q and maXis series instruments.  The Skyline support for working with full-scan mass spectra has been extended to Bruker TOF instruments, and data acquired with them in several modes:

  • MS1 Filtering - chromatogram extraction from MS1 scans in data dependent acquisition (DDA) experiments
  • Targeted MS/MS (PRM) - chromatogram extraction from MS/MS scans in pseudo-SRM experiments
  • Data Independent Acquisition (DIA) - chromatogram extraction from MS/MS scans acquired in various isolation schemes
    • Consecutive wide windows
    • All Ions - alternating low energy and high energy scans of the entire instrument range

For more information on working with Skyline and Bruker TOF instruments, consult the following resources:

  • HUPO 2012 Bruker Lunch Seminar [PowerPoint][PDF]
  • Targeted Proteomics with Bruker TOF Instruments tutorial [PDF]

The following supporting files may also be useful:

  • Skyline template documents for Bruker TOF data analysis [ZIP]
  • Script for adding retention times to MGF files for peptide searches [Script]



AB SCIEX Instrument Settings


Attached to this page you will find Skyline settings files created by AB SCIEX as helpful defaults for the QTRAP and TripleTOF instruments.

To load these settings files into Skyline, perform the following steps:

  • On the Settings menu, click Import.
  • Select one of the .skys files.
  • Click the Open button.

This will add a new menu item to the Skyline Settings menu, either QQQ_QTRAP_Environment or TripleTOF_Environment depending on which file you imported.  To change the settings on your current document, simply choose one of these menu items.  This will change the document settings to the defaults that AB SCIEX has created for their instruments.




Recovering From a Broken Installation


If you know your current release is out of date, but Skyline has not asked to upgrade after two restarts, you should first try simply manually installing again from the web page over the top of your existing installation. If this does not work, read on.

At times a Skyline installation may become so broken that you cannot install a new release over the top of your existing installation.  In this case, you will need to find the Skyline installation files on your computer, save your Skyline settings, and then either uninstall or potentially even delete the Skyline files before you can re-install and subsequently restore your settings.  This tip will walk you through doing just that.

Finding and Saving Your Settings

First, you need to find your Skyline installation.  On Windows 7 or Windows Vista, you first want to find the folder:

C:\Users\brendan\AppData\Local\Apps\2.0

On Windows XP, it will be something like:

C:\Documents and Settings\brendan\Local Settings\Apps\2.0

If you are unable to find either the AppData (Windows 7 and Vista) or the Local Settings (Windows XP) folder, you may need to do the following in Windows Explorer:

  • Press Alt+T, O to open the Folder Options form.
  • Click the View tab.
  • Under the Hidden files and folders item, click the Show hidden files and folders option.
  • Click the OK button.

You should now be able to see the necessary folder in Windows Explorer.

To save your Skyline settings before removing the Skyline files, do the following:

  • Use Windows Explorer to search within the Apps\2.0 folder for the file 'user.config'. (Starting at C:\ will be a very long search!)
  • If you find more than one, look at the Date Modified and In Folder fields to determine which is the most recent under a folder beginning with 'skyl..'.
  • Hold down the Ctrl key on your keyboard, click the mouse cursor on the file and drag it to your desktop.

Now you have a copy of your Skyline settings on your computer desktop.

Removing Skyline From Your System

The next thing you should try is to simply uninstall Skyline, using the Control Panel ("Uninstall a program" in Windows 7 & Vista, and "Add/Remove Programs" in Windows XP).  If the uninstall fails, then you have no option but to clean up manually.

Before attempting to delete your Skyline installation, you should expand the folders below the '2.0' folder, so that you seem something like the folder tree shown in the image below:

Skyline installation folders

If your '2.0' folder looks much the same as the one above, then you can simply delete the entire '2.0' folder now, but be very careful with this option, as you may have other software in here.  If you see any differences, delete only the folders beginning in 'skyl..'.

Re-installing Skyline and Restoring Settings

You have removed Skyline from your system.  After restarting the system, try again to install Skyline from the Skyline web site or stand-alone installers.

After you have installed successfully, close the Skyline window.  Then again find the 'user.config' under '2.0', belonging to a folder beginning with 'skyl..' and copy the user.config you saved to your desktop over the top of the new user.config, which will contain only the default settings.

You should now be able to start Skyline and see that your settings have been preserved, and continue working with Skyline as normal.




Recovering the .sky File Extension Association


If you end up in a state where you can no longer double-click in the Windows Explorer on .sky or .skyd files and have Skyline open the files for you, do the following:

  • Run regedit.exe and delete the following keys if any are present (they may not all be)
  • Delete the keys HKEY_CLASSES_ROOT\.sky and HKEY_CLASSES_ROOT\.skyd
  • Delete the keys HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.sky and .skyd
  • Delete the keys HKEY_CLASSES_ROOT\Skyline.Data.0 and HKEY_CLASSES_ROOT\Skyline.Document.0
  • Reboot your computer
  • Wait for an update or reinstall Skyline (see also Recovering From a Broken Installation)

Thanks to Stack Overflow for this entry:

https://stackoverflow.com/questions/6489112/clickonce-deployment-file-association-not-registering




Sharing MS/MS Spectra with Manuscripts


If you are looking for a MS/MS spectrum viewer, you may not be familiar with Skyline, a tool developed primarily to aid targeted proteomics investigation.  Skyline does, however, provide features that make it ideal for sharing MS/MS spectra with manuscripts before and after publication.  Skyline displays fully annotated spectra for peptides with post translational modifications (PTMs) and neutral losses extremely quickly, and the Skyline software itself is freely available and easy to install. [Install Now]

If you already have a Skyline document that was submitted as part of a manuscript follow the steps below to use Skyline to view these spectra:

  • On the File menu, click Open (ctrl-O).
  • Select the shared file you are working with (usually .sky.zip).
  • Click Open.

Once the file is open in Skyline, it should look something like this:

If you do not see the MS/MS spectrum graph:

  • On the View menu, click MS/MS Spectra.

If you want to see different precursor charge states for the peptides in the document:

  • On the Edit menu, choose Expand All and click Peptides.

Select peptides or precursors in the Peptide View on the left to see the corresponding MS/MS spectrum.

For PTMs in the Peptide View, any modified amino acid is bold and underlined.

If you hover over a protein name, the positions of the peptides it contains are highlighted in bold colored text.  If a peptide is selected in the Peptide View, it is highlighted in red.

 If a peptide of interest contains post translational modifications (as in this case Ser-348 phosphorylation) you can see the modified amino acid bold and underlined in the Peptide view.  You can also hover over the peptide and Skyline will present more information in a tip, including the delta-mass of each modification specified in brackets in a field labeled “Modified”.

The MS/MS spectrum is interactive and one can zoom into the spectrum, using the mouse scroll wheel or by clicking and dragging a box around a region of interest, to see further fragmentation details.

In the above case of MS/MS for GSLAS348LDSLR [344, 353], zooming in clearly shows that Ser-348 is phoshorylated, and that there is no site ambiguity as the y5 ion and the y6/y6-98 ions clearly determine the position of the phospho group on Ser-348.

If there is phosphorylation site ambiguity, and the PTM site is indistinguishable, Skyline can be used to simulate both peptide isoforms and to easily indicate site ambiguity:

Such as the peptide

R.GEPNVSYICSR.Y [272, 282], phosphorylation simulated at Ser-277  

and the isoform

R.GEPNVSYICSR.Y [272, 282], phosphorylation simulated at Ser-281

In the Skyline document shown below, both isoforms have a pink triangle in the upper right corner of the peptide label.  This triangle indicates an annotation on the peptide.

To view the peptide annotation, right-click on the peptide sequence in the Peptide View and click Edit Node to view a form like the one displayed below.  (In version 1.2 and later, these annotations are shown in the peptide details tip mentioned above, and also by themselves if you hover the mouse over the colored triangle.)

Skyline Custom Annotation can be used to indicate the site ambiguity as demonstrated above with the “TRUE/FALSE” check mark within the peptide note.  These Annotations can easily be exported into custom Skyline reports (csv files).  For more information on annotations and reports, consult the Skyline Custom Reports & Results Grid tutorial.

Publishing a Skyline document for MS/MS spectrum viewing as part of manuscript submission allows the reader to interactively view MS/MS spectra.  Skyline can help with assessment of site ambiguity and allow you to indicate, using custom annotation, cases where site ambiguity of PTMs exists.

These Skyline spectral libraries can be further used to design targeted assays and may provide a valuable resource for researchers interested in a certain data set.

For manuscript submission, Skyline spectral libraries can easily be generated from many common peptide identification search engine outputs, for further details see the Skyline Spectral Library Explorer tutorial. 




Share Skyline Documents in Manuscripts


Skyline documents provide the ideal way to share targeted proteomics methods and results as supplementary material in your manuscripts.

Skyline has the following advantages available in no other targeted proteomics software:

  • Open source
  • Freely available and easy to install
  • Able to produce transition lists for and import results from the triple quadrupole instruments of
    • AB Sciex
    • Agilent Techonologies
    • Thermo Scientific
    • Waters
  • Human readable XML document format
  • Compact, high-performance, easily shared data cache file format

Once you have created a Skyline document (.sky) and its companion data cache file (.skyd), your entire method and acquired results can be easily shared with the proteomics community.  You are guaranteed that others will have freely available and rich access to your method design and results data.

To create a sharable ZIP file that includes:

  • Skyline document (.sky)
  • Skyline data cache file (.skyd)
  • Skyline display information (.sky.view)
  • Either all used spectral libraries or the fraction used by the document (.blib & .redundant.blib)
  • The backgound proteome file (.protdb - optional)

Simply perform the following steps in Skyline:

  • On the File menu, click Share.
  • If the document uses spectral libraries or a background proteome:
    • Click the Minimal button to share only the library spectra used in your document.
    • Click the Complete button to share the libraries and background proteome files as they exist on your system.
  • Enter the file name of your choice in the File name field (or accept the default).
  • Click the Save button.

You now have a compact file that can be shared publicly or upon request with any manuscript in which your methods and data are included.

Your readers will have open access to:

  • View your methods and data in Skyline's rich visual environment
  • Export transition lists for their own instruments
  • Export custom reports for deeper analysis of your data

You can also share the report template(s) you found most useful in analyzing your data by doing the following:

  • On the File menu, choose Export, and click Report.
  • Click the Share button.
  • Check the checkboxes beside the names of the reports you wish to share.
  • Click the OK button.
  • Enter the file name of your choice in the File name field.
  • Click the Save button.

The resulting Skyline report template file (.skyr) can also be shared with your manuscript along with R scripts to make it easy for readers to repeat your analysis on the systems in their labs, with their own samples.

Skyline helps you give the proteomics cummunity full, open access to your methods and results.




Export SRM Methods for a Thermo LTQ


You may know that Skyline documents can be exported to MRM/SRM transition lists for all of the major triple quadrupole instruments available today.  You may even know that Skyline documents can be exported directly to native methods for some of these instruments.  But, Skyline can also export SRM method files for the Thermo-Scientific LTQ.

An ion trap instrument like the LTQ may not have the sensitivity of a triple quadrupole, but you can still use one for targeted proteomics, and you can use SRM on the LTQ as a quality control measure for your liquid chromatography.

While you can export an existing Skyline document to a native LTQ method for SRM, you should be aware of a couple settings before you do.  To prepare your document for use with the LTQ, perform the following steps:

  • On the Settings menu, click Transition Settings.
  • Click the Instrument tab.
  • Check Dynamic min product m/z.
  • Enter the correct value (e.g. 2000) for your instrument into the Max m/z field.
  • Click the OK button.

The first setting will restrict the product m/z values Skyline will allow to being greater than a dynamic minimum, based on the precursor m/z, consistent with the limits the LTQ imposes.  The second setting will restrict both the precursor and product m/z values Skyline allows to be consistent with what your LTQ is calibrated to allow.

If you have done this on an existing document, you should probably review your transitions to be sure Skyline has not removed anything important.  Small product ions may no longer be measurable on the LTQ, which could cause some precursors to contain fewer transitions than you want for your experiment.

If this is a new document, you can now enter the peptides you are interested in targeting as you would normally, understanding that some smaller product ions that you would normally see will no longer be available in the Skyline user interface.

When you are ready to export a LTQ method file for your Skyline document, you must transfer your Skyline document to the instrument control computer for your LTQ instrument, where you will also need to have Skyline installed.  If you are using a complex document involving spectral libraries, you may want to consider using the Share command on the File menu, as described in the tip on Sharing Skyline Documents in Manuscripts.

Once you have your Skyline document open on the LTQ instrument control computer, you are ready to export it to a native LTQ method or .meth file.  To do this, preform the following steps:

  • On the File menu, choose Export, and click Method.
  • Choose 'Thermo LTQ' from the Instrument type list.
  • Click the Browse button beside the Template file field.
  • Browse to a .meth file you will use as a template for all settings other than the m/z values to monitor.
  • Click the Open button in the Method Template form.
  • Choose options in the rest of the Export Method form as you would for exporting a transition list or a TSQ native method.
  • Click the OK button.
  • Enter a name for your method, or root name if creating multiple methods.
  • Click the Save button.
This will create a LTQ method or multiple methods which you can use to make SRM measurements on your LTQ.  Once these are complete, you can import the resulting Thermo .RAW files as you would .RAW files from a TSQ triple quadrupole instrument.

Using SRM for Liquid Chromotography Quality Control on the LTQ

Issues with chromatography can easily go unnoticed on systems performing predominantly shotgun data dependent analysis (DDA).  They can, however, still greatly effect performance, especially if you are hoping to use tools that analyze MS1 scan data for quantification and feature detection.  At the MacCoss lab, we are using SRM methods generated with Skyline to monitor LTQ system performance.  Every tenth run on our LTQ instruments, we inject a known standard mix and measure its abundant peptides using SRM.  We find that measured retention times and peak shapes of known peptides give us increased visibility into system performance of the LTQ.

At present we are injecting the "6 Bovine Tryptic Digest Equal Molar Mix PTD/00001/63" from Michrom Bioresources, Inc., running SRM methods generated with this Skyline document:

Bovine_Mix_QC.sky

Below are examples of Skyline displaying both failing and passing runs on our LTQ Velos. Each QC replicate displayed in Skyline was taken as every tenth injection with the other 9 injections used for normal shotgun MS/MS measurement.

Failing:
In the QC runs shown below, chromatography issues first appear between runs 9 and 12. By QC13, the system is clearly not functioning acceptably.

Passing: In the 33 QC runs shown below, both a retention time drift of about 2 minutes and decreasing intensity are visible, but measurements remain within an acceptable range throughout.




Skyline Source Code


The Skyline project is developed in open source, under Apache 2.0 License, though released under a modified Apache 2.0 License, due to the inclusion of third party libraries with licensing restrictions.

The source code for Skyline is made available through the ProteoWizard GitHub Repository. The main Skyline project can be found under:

pwiz_tools/Skyline