Table of Contents

guest
2021-09-19
   Miscellaneous
     Skyline Batch
     Skyline File Types and Extensions
     Waters SONAR Calibration
     Audit Logging
     Crosslinking in Skyline 21.1
     New in Skyline 4.1
     How to Display Multiple Peptides
     Ion Mobility Separation (IMS) Data

Miscellaneous





Skyline Batch


  Skyline Batch is an application that automates a common Skyline workflow for batch processing Skyline documents. It interacts with Skyline through the command-line, allowing it to import data into a template document, export reports, and run R scripts on those reports without bringing up the Skyline user interface.

 

Install Skyline Batch for Skyline 20.2 or later, or Skyline-daily (20.2.1 or later)

Skyline Batch Documentation

 

 

Skyline Batch Webinar

A hands-on demonstration displaying the depth of Skyline Batch as well as new features:

Webinar 20: Using Skyline Batch for Large-Scale DIA

 

Skyline Batch Tutorials

Learn how to use Skyline Batch by completing the supplementary tutorials on the Webinar 14 and 15 pages:

Webinar 14: Large Scale DIA with Skyline

Webinar 15: Optimizing Large Scale DIA with Skyline

 

 

Skyline Batch Release Notes

 

Skyline Batch 21.1.0.187 (July 6th, 2021)

  • Skyline template files, annotation files, data files, and R scripts can now be downloaded from Panorama
  • New download data files dialog that includes an interactive list of the files to be downloaded
  • Improved Skyline Batch configuration files that are more easily readable in a text editor
  • Updated run button options

 

Skyline Batch 21.1.0.146 (May 26th, 2021)

  • Added a "download files only" run option
  • Allow waiting configurations to be unchecked and removed from the current batch run
  • Log improvements
  • Data download bug fixes

 

Skyline Batch 20.2.0.475 (Apr. 20th, 2021)

  • Can download data files from an FTP server
  • Added support for different number formats

 

Skyline Batch 20.2.0.464 (Apr. 9th, 2021)

  • Import configurations by double-clicking a Skyline Batch Configuration file
  • No longer requires a Skyline report file for reports that already exist in the template document
  • Improved file detection for sharing configurations across computers 

 

Skyline Batch 20.2.0.453 (Mar. 29th, 2021)

  • New option for Skyline file refinement
  • Supports using refined files as templates for other configurations
  • Added ability to import annotations
  • Bug fixes for finding R installations, logging, and more

 

Skyline Batch 20.2.0.398 (Feb. 2nd, 2021)

  • Runs multiple Skyline workflows sequentially
  • Displays log of current run
  • Allows different configurations to use different Skyline installations
  • Supports running R scripts with any version of R

 

 




Skyline File Types and Extensions


Here is a complete list of Skyline file types:

  • .sky - the main Skyline document file
  • .sky.view - contains state information about the Skyline UI when the .sky file was last saved, e.g. selection and window layout - can be deleted
  • .skyd - contains all the chromatograms and the complete set of peak statistics (generally 10 per chromatogram) considered by Skyline
  • .skyl - the Skyline audit log file
  • .blib - a Skyline native spectral library
  • .slc - a "spectral library cache" created to improve initial spectral library load performance - can be deleted and Skyline will simply recreate it
  • .irtdb - a Skyline iRT library file
  • .optdb - a Skyline optimization library for CE and CoV optimization values
  • .protdb - a background proteome file
  • .imsdb - and ion mobility library (coming in 20.2) which stores ion mobility and CCS values
  • .midas - a spectral library file for spectra from SCIEX MIDAS runs

External library types:

  • .hlf - X! Hunter spectral library from theGPM
  • .sptxt - SpectraST spectral library from the TPP
  • .msp - NIST spectral library

But don't try to understand all of the above just to share a complete Skyline document/project with others, instead use File > Share or Upload to Panorama to create a:

  • .sky.zip - a compressed ZIP archive which contains the full set of files required to share your document/project

Exported files not associated with the .sky file:

  • .skys - a Skyline settings file which can be imported into a menu item on the Skyline Settings menu
  • .skyr - a Skyline report template file which can be imported back into Skyline to add report templates to the available set
  • .skyp - a new Skyline "pointer" file that can be downloaded from Panorama very quickly and will then initiate a full download inside Skyline when opened



Waters SONAR Calibration


Waters SONAR support has recently been improved in Skyline. SONAR users should consult this information provided by Waters:  https://support.waters.com/KB_Inf/MassLynx/WKB202040_How_to_create_post-acquisition_a_SONAR_calibration_file




Audit Logging


(This tip applies to Skyline-Daily 4.1.1.18257 and later.)

When enabled, the audit log will keep track of all changes that are made to the current document. The audit log is stored as a separate file (.skyl), alongside with the skyline document.

The audit log can be accessed from the View menu. The audit log is displayed in a grid, similar to the document grid. In the top right corner audit logging can be enabled or disabled.

For new documents, audit logging is enabled by default.

Reasons to enable Audit Logging

•Reproducibility: The audit log makes it easy to see what changes were made to a document and can be used to reproduce a document step-by-step. 
•Collaboration: If multiple people are working on the same document it can be helpful to have a record of what each person has done to the document. 
•Troubleshooting: If the user encounters an error in Skyline, the audit log can be helpful for the Skyline team to diagnose and fix the issue.

 

Full details can be found here (PDF).




Crosslinking in Skyline 21.1


Support for crosslinked peptides was first added to Skyline version 20.2.

Skyline 21.1 improved this feature by making it much easier to link more than two peptides together.




New in Skyline 4.1


Attached are a collection of slides created by the developers as they added new features in Skyline 4.1 which required a bit of explanation:

  • Small molecule spectral libraries, improved adducts, and identifier (InChiKey, InChi, CAS, and HMDB)
  • Document Grid and Live Report pivot and layout support
  • Group comparison volcano plot with formatting
  • Peak Area CV histogram plots
  • Quantitative property for transitions
  • Points across the peak visualization in chromatogram plots



How to Display Multiple Peptides


Skyline allows you to compare chromatograms of different peptides by selecting them in the Targets  panel shown by default on the left side of the Skyline window.

For example, to see all the peptides belonging to a particular protein, click on the protein name in the Targets panel:

Skyline generates a color for each peptide based on the peptide sequence and modifications.  This provides a quick way to identify the matching chromatogram in the graph.  A peptide will always have the same color, even in different Skyline documents, unless there is another peptide within the same protein that generates the same color.  That doesn’t happen too often, but when it does, Skyline picks one of the conflicting peptides and assigns it a new color that is easier to differentiate.

Color swatches are shown in the Targets panel next to only those peptides which are shown in the graph.  In the example above, only the peptides under the selected protein are shown in the graph.

The peptides are also labeled in the graph with a unique abbreviation.  If the first three letters of the peptide’s name are unique (among the peptides being graphed), then only three letters will be used in the abbreviation.  If the first three and last three letters together are unique, the abbreviation will use those (see ASL…KGK in the example above).  More complicated abbreviation schemes are used if the first and last three letters are not unique.  Note that a peptide’s abbreviation can change depending on what other peptides are being displayed at the same time.

Graphing peptide subsets

The Targets panel allows you to select any subset of peptides you want.  You can select just a few peptides (from one protein, or across different proteins) by clicking on the first, and then holding the CTRL key down while clicking on additional peptides.  You can toggle a peptide by clicking on it multiple times with the CTRL key depressed.

You can select individual peptides by clicking on their names, or you can select all the peptides belonging to a protein by clicking on the protein name.

 

 

All peptides

To see every peptide in the document graphed, click somewhere in the Targets panel to transfer focus there, then type CTRL-A (or choose Select All from the Edit menu):

Note that this can take some time to display if your document contains a large number of peptides.

Displaying all the peptides will produce a graph that looks similar to the progress displayed during data import:

But you can see differences between this graph and the one above.  Peptide colors will usually match, but occasionally they don’t if a different color is needed to disambiguate two peptides in the same protein.  Peak values can also differ, because different summation criteria are used during import than later when more processing has been done on the raw data.




Ion Mobility Separation (IMS) Data


Skyline supports IMS data for Waters, Agilent, Thermo (FAIMS) and Bruker instruments.  By specifying the ion mobility for each precursor ion of interest you can tell Skyline to ignore scans that might contribute noise, and thus improve the quality of extracted chromatograms. The Ion Mobility Spectrum Filtering tutorial provides examples and more detail.

Ion mobility values may be specified in Ion Mobility libraries, or defined explicitly in transition list imports, and may also be found in spectral libraries (for the latter, make sure to check the "Use spectral library ion mobility values when present" box in the Ion Mobility tab of the Transition Settings dialog). The order of precedence is: explicit values, Ion Mobility Library values, Spectral Library values.

You will notice that an ion mobility is commonly expressed as a Collision Cross Section (CCS) value and an ion mobility value. It's important to understand that the CCS value takes priority: different raw data files may contain different CCS->mobility calibrations, so the actual ion mobility filter value for a chromatogram extraction is always derived from the CCS value when available. Thus, if you want to experiment with adjusting ion mobility values for chromatogram extraction, it's import to either adjust CCS rather than ion mobility, or to clear the CCS setting so that your adjusted ion mobility value is the one that gets used. 

To add or modify an ion mobility library, use the Settings|Transition Settings menu item and select the Ion Mobility tab, then use the "Ion Mobility Library" drop down menu to bring up the Ion Mobility Library editor.  

The easiest way to set up an ion mobility library is to start with a Skyline document with imported results, then use the "Use Results" button in the Ion Mobility Library editor.  This simply scans the existing imported results and determines the ion mobility value of the scan containing the most intense peak.  Once you have that, you can reimport the data and Skyline can ignore scans at the proper retention time but wrong ion mobility.

There is a risk, of course, that the most intense peak at a given retention time isn't actually that of the precursor you are interested in, in which case you will be making the noise situation worse instead of better.  The ideal way to use this training feature is with simple training sets that elute one precursor at a time.  If you do not have that capability then you should go through and verify the ion mobility selections manually using the Full Scan chromatogram viewer's intensity heat map of mz vs ion mobility.

You can also set explicit ion mobility values for small molecule precursors using the right-click menu in the Targets window. This can also be done in the Document Grid, so it's possible for peptide precursors as well.