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Skyline Small Molecule Method 
Development and CE Optimization 

The Skyline Targeted Proteomics Environment provides informative visual displays of the raw mass 

spectrometer data you import into your Skyline documents.  Originally developed for proteomics use, 

Skyline has been extended to work with generalized molecules.  This tutorial explores using Skyline for 

targeted quantification of small molecules.   

In this tutorial, you will learn about development of a multiplexed method for selected energy 

metabolites on LC-MS/MS (Triple Quad). In the analysis of this dataset you will learn about: 

• Targeted Quantification Workflows based on Triple Quad MS (TQMS) 

• Starting from a published transition list of putative molecules of interest, collected on a TQMS 

from a different vendor 

• Building an unscheduled Skyline method using collision energy (CE) values from that list   

• Using that unscheduled method to create a scheduled method with optimized retention times 

• Using that scheduled method to create a final scheduled method with optimized CE values 

You may also wish to view the second half of Skyline webinar 16, on which this tutorial is based: 

https://skyline.ms/project/home/software/Skyline/events/2017%20Webinars/Webinar%2016/begin.vie

w?  

Skyline aims to provide a vendor-neutral platform for targeted quantitative mass spec research.  It can 

import raw data from the instrument vendors Agilent, SCIEX, Bruker, Shimadzu, Thermo-Scientific and 

Waters.  The ability to import data across various instrument platforms greatly facilitates cross-

instrument comparisons and large multi-site studies. This remains equally true in using it to target small 

molecules, as it has been for years in the field of proteomics. 

If you have not already looked at the “Skyline Small Molecule Targets” tutorial you should do so now, in 

order to pick up a few basics about how Skyline works with small molecule descriptions including 

chemical formulas and adducts. 

  

https://skyline.ms/project/home/software/Skyline/events/2017%20Webinars/Webinar%2016/begin.view?
https://skyline.ms/project/home/software/Skyline/events/2017%20Webinars/Webinar%2016/begin.view?
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Getting Started 

To start this tutorial, download the following ZIP file: 

https://skyline.gs.washington.edu/tutorials/SmallMoleculeMethodDevAndCEOptimization.zip 

Extract the files in it to a folder on your computer, like: 

C:\Users\bspratt\Documents 

This will create a new folder: 

C:\Users\bspratt\Documents\SmallMoleculeMethodDevAndCEOptimization 

It will contain all the files necessary for this tutorial.   

Now: 

 Start Skyline. You should see the Start page. It will look something like this: 
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 Set the user interface control in the upper right corner of the Start Page to “Molecule 

interface”. This turns off all the proteomics menus and controls that we won’t be using. 

 

Now the start page is not cluttered with proteomics-related controls that we don’t need. 

 

 Click on “Blank Document”. 
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Importing a Small Molecule Transition List into a Skyline Document 
The transition lists in this tutorial are from a high speed HILIC method, based on Guder et al, Anal Chem. 

2017 Feb 7;89(3):1624-1631.  The raw data for the tutorial itself was then collected on an Acquity UPLC 

coupled to a Waters Xevo TQ-S triple quad. 

This is the published transition list: 

 

It provides information about light (12C) and heavy (13C) precursor and fragment m/z and charge for 

each molecule. For the purposes of this tutorial, we will work only with the Negative mode entries. The 

collision energy (CE) values are from a Sciex triple quad, we will use these as a starting point even 

though we will develop our new method on Waters equipment. 

With a little effort in Excel or other spreadsheet editor, this can be reformatted so that Skyline can read 

it (the heavy and light versions of each transition are expected to be on different lines). The result of this 

reformatting can be found in the provided Energy_TransitionList.csv file in the folder you created at the 

start of this tutorial. 

https://www.ncbi.nlm.nih.gov/pubmed/28050903
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Because Energy_TransitionList.csv is formatted with column headers that Skyline recognizes, you can 

bypass the usual Insert Transition List window and simply copy everything (include the header row) into 

Skyline’s Targets window. To do this, perform the following steps: 

 Open Energy_TransitionList.csv in any text editor. 

 Select All, then Copy. Make sure you have included the header row. 

 In Skyline, click in the Targets window, then Paste (Ctrl+V). 

Your Skyline window should now look something like this (note the molecule symbol in the User 

Interface control in the upper right – Skyline has turned off all proteomics-specific menus and controls): 

  

NOTE: In this instance, the targets are described with m/z and charge values. Skyline can accept higher 

level descriptions including chemical formulas and heavy isotope labels etc. Having the chemical formula 

is especially useful when working with full scan data as it allows Skyline to calculate isotopic 

distributions, but for SRM data such as this, using m/z and charge is perfectly adequate. 
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Transition settings 
Next we have to make sure Skyline’s Transition Settings are correctly set for importing the experimental 

mass spectrometer results. To do this, perform the following steps: 

 On the Settings menu, click Transition Settings. 

 Change settings as necessary to match the following: 

 

 
  

We will perform a collision energy optimization study on a Waters Xevo as part of method 

development and optimization, since the collision energies are being used from another 

instrument (Sciex). 
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In this experiment we are interested only in negatively charged transitions, this is indicated in 

the “Precursor adducts” and “Fragment adducts” fields. Skyline’s adduct descriptions support 

any kind of ionization description (“[M-H]”, “[M+Na]” etc.), including unknown ionization modes 

(the “[M-]” used here to indicate “negative mode, charge 1, without any known chemical 

composition to explain it”).  The “f” setting in Ion Types on the Filter tab means we are only 

interested in fragment ion transitions. If you wanted to measure precursor ions as well, it would 

be “f,p”. 
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We will allow a generous match tolerance when reading SRM data and assigning 

chromatograms to our targets. 

 

Now, save the current Skyline document. To do this: 

 From the Files menu, click on Save. 

 When prompted, use the filename “EnergyMet_demo.sky”. 
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Exporting unscheduled methods 
In general, if you are running Skyline on a computer with the instrument control software for your brand 

of mass spec installed, Skyline can export native methods using templates that you specify.  

If you do not have Waters MassLynx installed, just skip ahead to the next section “Exporting a Transition 

List”. 

We will export two methods, one of 2 minutes and one of 5 minutes. To begin: 

 From the Files menu, click on Export. 

 Then click on Method to open the Export Method dialog. 

 Adjust the settings until the dialog looks like this: 

 
 Click OK and save the method as “EnergyMet_2minutes”. 

 Repeat these steps, changing Run duration to 5 and saving as “EnergyMet_5minutes”. 

Note: the VerifyETemplate.exp file is in the SmallMoleculeMethodDevAndCEOptimization folder you 

created at the start of this tutorial. 

Exporting a transition list 
The steps for exporting a transition list are very similar to that for exporting an unscheduled method, 

except that there is no template file: 
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 From the Files menu, click on Export. 

 Then click on Transition List to open the Export Transition List dialog. 

 Adjust the settings until the dialog looks like this: 

 
 Click OK and save the list as “EnergyTL_2minutes.csv”. 

 Repeat these steps, changing Run duration to 5 minutes and saving as “EnergyTL_5minutes.csv”. 

Importing mass spectrometer runs 
At this point, we would collect data for the samples using our 2 and 5 minute gradients. The samples 

used here are from a commercially available kit and are 1:1 mixes of light:heavy metabolites extracted 

from E. Coli (Credentialed E. Coli Lysate from Cambridge Isotope Laboratories).  

Results of these two sample collections are in a folder named “Unscheduled” in the folder you created 

at the start of this tutorial. “01a” is a 2 minute gradient, and “02a” is 5 minutes. We will examine them 

to decide which gradient is most effective for this experiment. 

 Perform the following steps. 

 On the File menu, click Save. (Ctrl-S) 

 On the File menu, select Import and click on Results. 



12 
 

 In the Import Results form, choose to import single-injection replicates.  For best performance, 

be sure to select “Many” in the “Files to import simultaneously” control at the bottom of the 

form.  Now click the OK button. 

 Navigate to the “Unscheduled” folder and select both files. 

The Import Results Files form should look like: 

 

 Click the Open button. 
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At this point Skyline notices that the replicate names derived from these file names are very similar - 

they only vary by a single character.   

Skyline asks: 

 

 Click OK to use the shortened replicate names “1” and “2”. 
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The files should import within 30 seconds or so, leaving your Skyline window looking something like this: 
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“1” and “2” are not very memorable replicate names, but we can change them to something more 

descriptive. 

 On the Edit menu, choose Manage Results. 

 Click on the first replicate “1” 

 Click on the Rename button 

 Change the name from “1” to “unscheduled_2min”. 

Click the OK button. 

 Repeat these steps for replicate “2”, renaming to “unscheduled_5min”. 

 Click the OK button in the Manage Results dialog. 
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Now your Skyline window should look like this: 

 

 

 

To take advantage of the Skyline summary graphs for viewing individual targets, do the following: 

 On the View menu, choose Arrange Graphs and click Tiled. 

 On the View menu, choose Peak Areas and click Replicate Comparison. 

 On the View menu, choose Retention Times and click Replicate Comparison. 

 Click and drag these views over the arrows to dock them above the chromatogram graphs. 
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The Skyline window should now look something like this: 

   

Comparing Peak Areas and Resolution 
Looking at the Peak Areas – Replicate Comparison window we can see that the 5 minute gradient has 

generally greater peak areas than the 2 minute gradient. You may choose to perform technical 

replicates to be sure this is not random variance.  In this case, the 5 minute method seems to show 

better peak areas for many analytes but not all, likely based on the better separation of the analytes and 

decreased ion suppression (also called ‘matrix effect’).  Based on this, the 5 minute gradient is the 

probably the better chromatography choice for this experiment. 

A closer examination of the chromatographic peaks is also useful: 

 Right-click on either of the chromatograms and make sure that Synchronize Zooming is enabled. 

 Click and drag within either chromatogram to select the time range from 0.8 minutes to 1.8 

minutes. 
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Skyline should look something like this, from which we can see that the 5 minute gradient provides 

much better peak separation. This is not surprising, and combined with improved signal intensity it 

justifies the choice of the longer gradient. 

 

Producing a Scheduled Method 
Having decided on the 5 minute gradient, we can now produce a scheduled method or transition list. For 

the purposes of this tutorial we will assume that you do not have the MassLynx instrument control 

software installed, and will produce a transition list rather than a native method. 

First, we want to set the retention time window for export to our transition list. 

 From the Settings menu, choose Peptide Settings 

 Select the Predictions tab 

 Make sure the “Use measured prediction times when present” box is checked 
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 Set the Time window value to 1 minute. 

 
 Click OK 

Now we can produce the transition list: 
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 From the Files menu, click on Export. 

 Then click on Transition List to open the Export Transition List dialog. 

 Adjust the settings until the dialog looks like this: 

 
 Click OK 

 You will be asked which replicate to use for timing – we want the 5 minute gradient, so use 

these settings: 

 

 
 Click OK 

 You will be prompted for a file name, save the scheduled transition list as 

“scheduled_5min.csv”. 
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Collecting Data with the Scheduled Transition List 
At this point we would use the newly generated scheduled transition list to collect new results. This has 

already been done: data was collected for three runs with different light:heavy ratios. There is a 1:1 mix, 

a 1:2 mix, and a 2:1 mix. 

 On the File menu, select Import and click on Results. 

 In the Import Results form, choose to import single-injection replicates.  For best performance, 

be sure to select “Many” in the “Files to import simultaneously” control at the bottom of the 

form.  Now click the OK button. 

 Navigate to the “Scheduled” folder and select all three files. 

 Click OK  

 This time when Skyline offers to simplify the replicate names, choose Do not remove 

 
 Click OK 

As we are done with the two minute gradient, we may remove it from the document: 

 From the Edit menu, choose Manage Results 

 Select the unscheduled_2min replicate and click the Remove button 
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While we are here, some renaming: 

 Select the unscheduled_5min replicate 

 Click the Rename button and change the name to “1:1_1” respectively (we’re using a naming 

convention to show the light: heavy mix ratio and run number – though you can use any naming 

scheme you like) 
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 Change the others to “1:1_2”, “2:1_2”, and “1:2_2” (note: this renaming can be done in the 

Document Grid as well). 

 
 Click OK 

Evaluating the Mass Spec Runs 
We can get visual confirmation of the known ratios of the samples, we looking at the Peak Areas – 

Replicate Comparison window. 

 In the Targets window, click on Acetyl-CoA. 

We can see that the peak areas have the expected ratios based on the known mix ratios. From the 

Retention Times – Replicate Comparison view we can also see that the chromatography is stable. 
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Evaluating Linearity 
We can evaluate linearity using Skyline’s calibration function. 

 From the View menu, choose Document Grid 

 In the Document Grid, click on the Reports control and select Replicates 

 Set each replicate’s Sample Type to Standard 
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 Set each replicates Analyte Concentration as appropriate. This is expressed as a number rather 

than a ratio, so set them to 1, 1, 2, 0.5 respectively. 

 

We also need to check some quantification settings: 

 On the Settings menu, click Peptide Settings. 

 Select the Quantitation Tab, and change settings as necessary to match the following: 
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Now we are ready to examine the calibration curve. 

 Close the Document Grid view. 

 From the View menu, select Calibration Curve.  You should see this: 
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The three dilution points evaluated here clearly are not as linear as we would like, therefore we would 

expect there to be some additional work to be done to obtain information on the linear dynamic range 

of this particular assay.  

Collision Energy Optimization 
At this point we want to collect collision energy optimization data in hopes of obtaining as much 

sensitivity as possible for the analytes in the assay; remember these collision energy values were from a 

completely different instrument vendor. Skyline will help generate a series of scheduled transition lists 

with collision energies automatically varied around the initial explicit collision energy we set, which we 

will use to collect new results for our samples.  Skyline will then use this data to select the optimal CE 

values. 

We begin by checking our collision energy settings: 

 From the Settings menu, choose Transition Settings 

 Select the Prediction tab, and click on the Collision Energy drop-down control 

 Select Waters Xevo 

 Click on the Collision Energy drop-down control again and select <Edit Current…> 

 This opens the Edit Collision Energy Equation window 
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 Set the Step Size to 2 and the Step Count to 5.  This will generate a series of methods (or 

transition list) where the collision energy is iterated up and down in 2 volt increments, for a total 

of 5 steps in each direction.  A generic recommendation is to start with relatively large Step Size 

(2 or 3 volts) and then potentially repeat the CE optimization with a small Step Size (1 V) in order 

to perform fine optimization. 

   
 Click OK 
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 Back in the Prediction tab, make sure the Use optimization values when present box is checked 

 We aren’t measuring precursors, so set the Optimize by control to Transitions 

 
 Click OK 

 

Now we can proceed to exporting the scheduled transition lists. Again, if you are working on a machine 

with the instrument control software installed, it is generally preferable to export native methods, but 

for the purposes of this tutorial we will export transition lists. 

 From the File menu, click on Export and choose Transition List 
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 Change settings as needed to match this: 

 

Note that we are exporting multiple methods in order to limit the number of concurrent transitions. We 

do this to ensure enough points across each chromatographic peak in Skyline. 

 Click OK 

 You should see the Scheduling Data window, set it to use the retention times from the 1:2_2 

replicate for scheduling: 

 
 Click OK 

 You will be asked for a file name. Since we are producing multiple transition lists, we actually 

just want to provide a partial name as a basis for naming the files produced. Set the name as 

TL_CE_Opt and click Save 

 This should produce five files: TL_CE_Opt_0001.csv, TL_CE_Opt_0002.csv, etc. 
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Now we take these new transition lists (five in total) and run our 1:1 sample once with each of these 

methods, and import those results. These results are available in the “CE Optimization” folder of the 

folder you created at the start of this tutorial: 

 From the File menu, click Import and select Results 

 We want to combine the five CE optimization runs into a single chromatogram. Adjust the 

settings to look like this: 

 
 Click OK 
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 Select all five files in the CE Optimization folder in your tutorial download folder: 

 
 Click OK 
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The files load as a single replicate, and now Skyline should show a new replicate “CE Optimization”. 

 

Let’s investigate the results of the CE optimization: 

 In the Peak Areas – Replicate Comparison window, right-click then choose Transitions and 

enable Single 

 In that same window, right-click again, choose Transitions, and enable Split Graph 

Skyline should look like this: 
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The Peak Areas – Replicate Comparison window now shows us the heavy and light transitions in 

separate displays. Within the CE Optimization replicate, the individual bars represent the effects of 

stepping the collision energy. Red represents the original CE value (as used with the Sciex instrument in 

the literature), the other bars show the effect of 2eV steps away from that. We can see that for Acetyl-

CoA, at least, the original value or the -2eV step both provide good peak areas. This is easier to see if we 

free up room in the graph by switching off the legend: 

 In the Peak Areas – Replicate Comparison window, right-click then disable Legend 

Skyline should look like this: 

 

 

Now we can explore the other molecules to see how well we have optimized collision energies. To do 

this, click on any molecule in the Targets window, or use the up and down arrows after the first click to 

scroll through the list. Let’s look at Pentose-P in particular: 

 In the Targets window, click on Pentose-P 
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Looking at the chromatograms for the various CE step values for Pentose-P it’s clear that the CE value 

from the literature isn’t optimal for this molecule on this equipment. As the best CE value (Step -5, the 

blue bar) is at the limit of the range we explored, and given the trend toward that end of the range, 

futher investigation may be warranted to arrive at a truly optimal CE for that compound.  For that 

reason, starting with a wider set of steps (such as 3V) may also be warranted when translating between 

instrument vendors.  

 

Even so, the Step -5 CE value (blue bar) is a clear improvement over the initial (red bar) value, and we 

should proceed to creating a new scheduled transition list that uses the most effective observed CE 

values.  

 From the File menu, click on Export and choose Transition List 
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This time we want just a single method, still scheduled but not optimizing anything this time: 

 

 Click OK 

 You should see the Scheduling Data window. Use the retention times from the CE Optimization 

replicate for scheduling.  The optimal CE values will also be taken from this replicate. 

 
 Click OK 

 You will be asked for a file name. Set the name as TL_CE_Final.csv and click Save 
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Comparing the Original CE Values with the Optimized CE Values 
At this point, it is interesting to compare where we began – using SRM transitions and CE values from 

the literature for a Sciex mass spec published as a simple flat file; to where we have arrived – a retention 

time scheduled and CE-optimized SRM method for 18 energy metabolites and their internal standards 

for the Waters Xevo TQ-S. 

 Open the original (Sciex instrument sourced) transition list Energy_TransitionList.csv and the 

final (Waters TQMS optimized) transition list TL_CE_Final.csv in Excel or any other suitable 

viewer 

 Compare the CE values for various values. A couple of points of interest: 

o Interestingly, Acetyl-CoA has the same optimal CE for both the Sciex and Waters 

instruments 

o Pentose-P has quite different values:  45eV for Sciex and 35eV for Waters.  

If we did wish to further optimize CE for Pentose-P (recall that the CE value we identified as optimal was 

at the edge of the tested range), we could repeat the process using the TL_CE_Final.csv scheduled 

transition list as the starting point for a new round of CE optimization.  

Notes: As mentioned previously, in general when performing iterative optimization, it’s good to start 

with large step values to test a broad range of CE values, then move to smaller steps in later iterations to 

narrow in on the final values.  When performing CE optimization, if the “Use Optimization Values” 

button is checked under Settings menu, Transition Settings, Prediction,  you can expect that the new 

exported method or transtion list will automatically incorporate the optimimum collision energy into the 

method.  No manual curation of the CE optimization data is required, other than examination to see if a 

wider CE optimization range needs to be explored. 

Conclusion 
In this tutorial, you have learned how to create a Skyline document that targets stable isotope labeled 

small molecules specified as only precursor m/z, product ion m/z, and collision energy values, from a 

literature citation. You performed retention time scheduling and collision energy optimization for small 

molecules by importing a multi-replicate data set from a Waters Xevo TQ-S using initial CE values from a 

Sciex triple quad.  You learned how many existing Skyline features created initially for targeted 

proteomics use can now be applied to generalized molecule data. Non-proteomic molecule support is 

still a relatively new feature area for Skyline.  As such, you can expect it to continue improving rapidly. 

 


