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Skyline Audit Logging 

Introduction 
This tutorial covers how to use the Skyline audit log. The audit logging system keeps track of all 

document modifications and displays them in an interactive grid, similar to the Document Grid. It 

benefits from all the features of the Document Grid, such as creating report templates, sorting by 

columns and editing cells, for example for adding a Reason to a log entry. One of the design goals of the 

audit log was to give anyone the ability to reconstruct the state of a document, given only the audit log 

and the original data. This makes it an invaluable tool for a Skyline user. As you will see, the audit log 

also makes the “Undo-Redo” feature more usable by providing more specific change messages and 

allowing you to undo changes in the audit log grid itself. To demonstrate important benefits of the audit 

log, this tutorial is based on the Absolute Quantification Tutorial, in which the absolute abundance of a 

target peptide is determined using Selected Reaction Monitoring (SRM) mass spectrometry by creating 

an external calibration curve with an internal standard heavy labeled reference peptide. This tutorial will 

be mostly focused on how to configure the audit log, how your actions are logged and how to read and 

work with the audit log. If you find you want to learn more about absolute quantification, you should 

refer to the Absolute Quantification Tutorial directly, which covers the topic in more detail. 

Getting Started 
To start this tutorial, download the following ZIP file: 

https://skyline.gs.washington.edu/tutorials/AbsoluteQuant.zip 

Extract the files in it to a folder on your computer, like: 

C:\Users\tobiasr\Documents 

This will create a new folder: 

C:\Users\tobiasr\Documents\AbsoluteQuant 

The folder should contain a total of 9 RAW files, which you will import into Skyline later. 

Note: In configuring Skyline for this tutorial, be sure to follow the steps below in the order presented to 

avoid creating audit logs of these initial setup steps.   

• Now open Skyline and you will land on the Start Page.  

• If you are using Skyline for the first time you will be prompted to select a default user interface. 

In the right-hand corner, ensure that the protein icon  is showing, indicating that Skyline is 

presenting the Proteomics interface. This can easily be changed in the future.  

• Now click on the Blank Document tile. 

https://skyline.gs.washington.edu/tutorials/AbsoluteQuant.zip
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• On the Settings menu, click Default. 

• On the File menu, click New. When prompted whether you want to save your changes, click No. 

 Opening the audit log 

First open the audit log by performing the following steps: 

• On the View menu, choose Other Grids and click Audit Log (Alt + 4) 

This should bring up the audit log in its default configuration as shown below: 

 

In the top right corner, you can see that audit logging is currently enabled, which is the default. By 

unchecking the box, audit logging can be disabled. Initially the audit log is showing its default column 

configuration, displaying the Time, All Info Message, and Reason columns. These columns will be 

explained in more detail and you will learn how to customize the columns in this grid. Keep this window 

open throughout the tutorial to observe how log messages appear as you interact with Skyline. 

Configuring Settings for inserting a new peptide 
Before you insert a new peptide into the document, you need to configure the transition and peptide 

settings for this experiment as follows: 

• On the Settings menu, click Transition Settings. 

• Click the Filter tab. 

• In the Product ion selection box, in the From dropdown list select ion 3 and in the To dropdown 

list ‘last ion – 1’. 

• Click the OK button. 
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After you click OK, several messages will appear in the audit log window. Before taking a closer look at 

the audit log, first configure the peptide settings as follows: 

• On the Settings menu, click Peptide Settings. 

• Click the Modifications tab. 

• Click the Edit list button next to the Isotope modifications list. 

• Click the Add button 

• From the Name dropdown list choose ‘Label:13C(6)15N(2) (C-term K)’.  

• Click the OK button. 

• Click the OK button in the Edit Isotope Modifications form. 

• In the Isotope modifications list, check the new ‘Label:13C(6)15N(2) (C-term K)’ modification. 

• Click the OK button. 

Reading the audit log 
Now the audit log should look as follows: 

 

Each dark gray message and all messages below it until the next dark gray message or the end of the 

audit log represent a single document change. The transition settings and the peptide settings were 

changed, which creates a total of two audit log entries. By default, new messages appear at the top. 

Looking at the first entry when the transition settings were changed, the gray message is a one line 

summary of the entire entry: Transition Settings – Filter changed.  This message is called the Undo-

Redo message, because it is also used in the Skyline Undo-Redo list. To see this, return to the main 

Skyline window and click the small black arrow next to the Undo button to see the previous changes 

made to the Skyline document. 
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Before audit logging was introduced into Skyline, both messages here would only say Changed settings. 

Therefore, even if you have audit logging disabled, you can still benefit from it through improved Undo-

Redo messages. 

Return to the audit log window. The next five messages under the Undo-Redo message are the All Info 

messages, which describe every change in detail. Log messages will tell you exactly where a setting 

changed. For instance, the first message reads Settings > Transition Settings – Filter > Product ion 

selection start changed from “m/z > precursor” to “ion 3”. Recall that this is exactly where we 

navigated earlier to select the collision energy. The “greater than” symbols indicate that a menu item, 

while the “--" indicates that what follows is a tab, such as the Prediction tab. Next look at the message 

above, which describes the changes you made to the peptide settings. Note that the Undo-Redo 

message is very concise, telling you about the isotope modification you added. Looking below at the All 

Info messages, you can see that the audit log contains the exact definition of the modification you 

added, despite you not having configured it manually. This is in order for others to be able to reproduce 

those changes in the future, even if they do not have this particular modification in their Skyline 

instance, in which case they would have to create it manually. 

Undoing changes through the audit log 
Again, looking at the audit log form, you should see that there is a single arrow next to the audit log 

entry at the top that describes the peptides settings changes. This is the same arrow as on the Undo 

button in the toolbar.  

• Click the arrow in the Audit Log grid 

This should make the audit log entry disappear and undo the change. 

Return to the main Skyline window and you should see the Redo button on the toolbar, the previously 

grey arrow pointing to the right, turn blue.  

• Click on the small black arrowhead to the right of it. 

To see the dropdown list of changes you can redo, as shown below. 

 

You can see the change you just undid through the Audit Log grid. 



5 
 

• Click on the change to redo.  

Now return to the Audit Log grid and you will see that the audit log entry is back. Note that next to the 

other audit log entry are two undo arrows. This indicates that if you undo this change, all changes made 

after this one will also be undone. In this case undoing the transition settings change entry will also 

undo the peptide settings change entry. This exactly how Undo works when using the Undo dropdown 

list in the toolbar. You can undo back to a certain point in the document history, but you cannot revert a 

single change in the middle of the list. Note that once you close Skyline and open the document, those 

undo arrows will disappear from the audit log, since only changes made during your current Skyline 

session can be un- or redone, again consistent with the Undo and Redo buttons and menu items. 

Inserting a peptide sequence 
Return to the Skyline window and perform the following steps: 

• On the Edit menu, choose Insert and click Peptides. 

• Copy “IEAIPQIDK” to the clipboard and paste it into the first Peptide Sequence cell. 

• Copy “GST-tag” to the clipboard and paste it into the first Protein Name cell. 

The form should look as follows: 

 

• Click the Insert button. 

The Targets window should show the newly added peptide with a light and a heavy labeled precursor 

(use the + buttons to expand the view if necessary): 
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Note that the transition groups and transitions were expanded in the above screenshot. Refer to the 

Audit Log grid and you should see a new message indicating that you inserted the peptide IEAIPQIDK. 

There are no other detailed messages about this change. The audit log entry consists of a single audit log 

messages as shown below: 

 

Note that there is a magnifying glass icon next to the new audit log entry. This appears whenever there 

is extra information associated with an audit log entry.  

• Click on the magnifying glass. 

This bring ups the Audit Log Extra Information window as shown below: 

 

The extra information window shows all the information that was pasted into the grid when inserting 

the peptide, including the column header names. The cell values are separated by tab characters, which 

means one can copy entire rows from this window and copy them into the insert peptides dialog from 

earlier.  

• Close the Audit Log Extra Information form by clicking OK and return to the audit log window. 

Before continuing, you should save the document. 
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• On the File menu in Skyline, click Save As. 

• Navigate to the AbsoluteQuant folder created earlier. 

• In the File name field, enter “AbsoluteQuantDocument”. 

• Click the Save button. 

In Window Explorer, navigate to AbsoluteQuant folder in which you just saved the document. You 

should see a file called AbsoluteQuantDocument.skyl (along with AbsoluteQuantDocument.sky and 

.sky.view). If you do not see these file extensions, you may need to show file extensions in Windows 

Explorer. This .skyl file is the audit log. If you open it in a text editor like Notepad, you will see XML 

format text. If you are interested in the format, refer to the Audit logging paper. The audit logging file 

can be safely deleted at any time without damaging the document. 

Importing RAW files into Skyline 
Next task is to import the RAW files from the SRM runs for this experiment: 

• On the File menu, choose Import and click Results. 

• Click the Add single-injection replicates in files option in the Import Results form. 

• Click the OK button. 

• In the Import Results Files form, navigate to the AbsoluteQuant folder and select all raw files. 

• Click Open to import the files. 

• Click OK to import the RAW files. 

A few moments later, the RAW files should be imported, and Skyline should have created eight new 

replicates. Navigate to the audit log, which should now look as follows: 

 

The audit log will not create copies of files that are imported, but rather just stores the paths of files that 

were imported. The first eight detailed messages are the paths of the nine raw files you imported. The 

second to last message is the option you set for importing replicates and the last message is another 

import setting that you did not set yourself, but it is still included in the log for reference.  
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Note that the primary entry again has a magnifying glass, which means it has extra information 

associated with it. This is always the case for a series of dialogs such as when importing results, where 

you configure a process that modified the document, instead of directly modifying the document like 

when changing the settings.  

• Click on the magnifying glass to view the extra information: 

 

Click OK to close the window.  

The extra information for wizards like the import results wizard does not contain any additional 

information, but rather a neatly formatted and more concise version of what is in the audit log. If you 

have any programming experience, this format might look familiar to you. 

Generating a Calibration Curve 
Configuring quantification settings: 

• On the Settings menu, click Peptide Settings. 

• Click the Quantification tab. 

• Change the Regression Fit dropdown list to Linear. 

• Change the Normalization Method dropdown list to Ratio to Heavy. 

• Type “fmol/ul” into the Units box. 

• Click the OK button. 

This generates the following audit log entry: 
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The changes made are listed under the heading Peptide Settings – Quantification changed and each 

step is captured in a detailed message describing it with enough detail that the step could be repeated. 

Specify the analyte concentrations of the external standards: 
Next, you will specify the analyte concentration for each replicate using the Document Grid as follows: 

• On the View menu, click Document Grid. 

• In the top left of the Document Grid, click the Reports dropdown list and choose Replicates. 

• In the row for FOXN1-GST, select its Sample Type: Unknown. 

• Copy the following data and paste it into the document grid to set each of the Standard 

replicates Sample Type to Standard and their Analyte Concentrations 

Standard 40 

Standard 12.5 

Standard 5 

Standard 2.5 

Standard 1 

Standard 0.5 

Standard 0.25 

Standard 0.1 

 

The Document Grid: Replicates form should look like: 
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Review the Audit Log grid to see that it shows the following: 

 

 

The Undo-Redo messages indicates that 16 values were pasted into the Document Grid. There are a 

total of 17 detailed messages. The first message tells us that the Replicates report was used. This is 

important because in order to reproduce this document grid change, you need to know what columns 

were present. The follow 16 messages describe each cell change, one for each of 8 changes in the 

Sample Type column and 8 in the Analyte Concentration column. Since you pasted data, this audit log 

entry again contains extra information.  

• Open the extra information window by clicking on the magnifying glass icon. 
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This displays a much more concise view of the data that was pasted into the document and again the 

data can be easily copied and pasted into another document. The report that was used is also indicated 

at the end of this extra information – in this case: Replicates. 

• Click OK to return from the Audit Log Extra Information window back to Skyline. 

Adjusting integration boundaries 
Next, you will look at the integration boundaries of the peptide in the FOXN1-GST sample: 

• On the View menu, choose Arrange Graphs and click Tabbed. 

• Click on the FOXN1-GST tab, or select the FOXN1-GST replicate in the box in the Targets 

window. 

• Ensure that the peptide is selected in the Targets window. 

• Now you should see the chromatogram of IEAIPQIDK in the FOXN1-GST sample. 

By selecting either the light or heavy precursor in the Targets window you can see how well the 

integration boundaries capture the peak. 

• Select the heavy precursor and zoom in on the peak by using the scroll-wheel on the x-axis.  

You should see something like the following: 
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The integration boundaries look acceptable and changing them may simply add variance to the peak 

area calculations. However, one might want to set the end boundary slightly more to the right to 

approximately 21.1. Click and hold on the right integration boundary to drag it to approximately 21.1. 

Switch to the Audit Log window and you should see that a new audit log entry appeared, as shown 

below: 

 

Note that when audit log describes a change related to an item in the Targets window, it uses a format 

similar to the one seen previously when changing document settings. Generally, the audit log will refer 

to items in the Targets windows by Protein/Peptide List > Peptide > Transition group > Transition. 

 

When an outside person reads this audit log, this integration boundary change might seem arbitrary 

without any explanation.  

• Click in the Reason cell next to the log message. 
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• Enter a Reason such as “Changed end boundary to better fit peak” and press Enter.  

The audit log should now look like this: 

 

Calibration Curve 
Next view the calibration curve configured earlier as follows: 

• On the View menu, click Calibration Curve 

The curve fits the first three points, but not for the points closer to zero. Use the scroll wheel to zoom in 

on the lower four points. 

 

You can see that the last four points fall off the line, which indicates that they below the limit of 

detection for this peptide. To create a better fit for the remaining points, you can exclude these points 

from the regression as follows: 

• For each of the lowest four points, right-click on the point and click Exclude Standard. 

If you zoom out on the other four points, you should see that the curve fits them better now, and the R-

Squared value in the top left corner of the graph should become 1. 

Review the Audit Log grid and, you should see four new audit log entries, one for each point you 

excluded from the calibration: 
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You will again add a reason to explain why the replicates were excluded. 

• Click on any of the four reason cells and enter something like “Excluded standard since it was 

below LOD” and press Enter. 

Customizing the audit log 
You now have a large audit log and it has become difficult to see all changes at once. The audit log is 

based on the document grid and can, therefore, be customized just like the document grid: 

• In the top left corner of the audit log, click on the Reports drop down list. 

There are three default reports you can select: 

 
 

• Click on the Undo Redo report to select it. 

• Adjust the column widths to make sure all cells are completely visible. 
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Now the audit log only displays the Undo Redo messages and not the detail messages, presenting a 

much better overview of what you changed in the document. Going from bottom to top, your changes 

can be summarized as follows: 

• You first configured the Transition settings and Peptide settings to include the correct 

transitions and modifications.  

• You inserted the peptide. 

• You imported the results. 

• You then started configuring the calibration curve, by configuring quantification settings. 

• You pasted the standard and analyte concentration information into the document grid.  

• You adjusted one of the peak boundaries and provided a reason for it.  

• Finally, you excluded four standards from the calibration curve, again providing a reason. 

Next, you will customize the audit log manually to show other columns: 

• In the top left corner of the Audit Log window, click Reports and choose Customize Report. 

• Check the Skyline Version and User columns in the left-hand list. 

• In the Report Name field, enter ‘Custom Columns’. 

The filled-out form should look like the following: 

 

• Click the OK button. 

The Audit Log should now look like the following, although you will have a different user name and you 

might be using a different Skyline Version. 
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Below is list of all of the columns you can select and their meaning: 

• Time Stamp: Time at which the change was made. 

• Undo Redo Message: The most specific single line message describing the entire document 

change. This message will also be displayed in Skyline’s toolbar when clicking on the arrows next 

to the Undo-Redo arrows. 

• Summary Message: Similar (and often the same) as the Undo Redo Message, but for certain 

messages shorter. 

• All Info Message(s): A list of messages that describe the document change in detail.  

• User: Identity of the user who made the change as authenticated by the local operating system.  

• Reason: The reason for the change, which can be set by editing the cell in the audit log grid after 

the change was made. (Optional) 

• Detailed Reason: A reason that can be set for each of the detailed “All Info messages”. 

(Optional) 

• Extra Info: additional information, usually large amount of data pasted into the document. 

(Optional) 

Panorama Upload 
To proceed with the rest of the tutorial you need an account established on PanoramaWeb or run your 

own instance of Panorama. 

Panorama is a web-based proteomics data sharing platform that supports uploading and viewing of 

Skyline files. To upload your Skyline document into Panorama: 

• Go to File menu and click Upload to Panorama….  
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If you did not use Panorama before the following dialog should appear: 

 

• Click Continue. 

The next dialog should ask you for the URL of the Panorama server you want to use and your 

credentials.  

• Enter the URL and your credentials and click OK. 

 

If the connection was successful, the next dialog should show you the Panorama server URL and the 

folders on the server available for upload.  

 

• Click on the + sign next to the URL to expand the list of folders if necessary. 

• Select the folder where you want to upload the document. 

• Click OK. 

• Click Yes in the next dialog to open the uploaded document overview in your browser. 
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Skyline automatically creates a zip folder containing all the files associated with your document and 

uploads it to the Panorama server. The browser page should open and looks like this: 

 

Detailed discussion of the Panorama functionality is beyond the scope of this tutorial. Please refer to 

https://panoramaweb.org/wiki/home/page.view?name=sharing_documents tutorial for more details. 

Note the ≡ symbol next to the number of document versions. This is a link that allows you to access the 
audit log information for the document. If you upload a document without a valid audit log this symbol 
will not be shown. 
 

• Hover your mouse over the ≡ character to observe the explanatory tooltip. 

• Click on the ≡ symbol. 
 

Now you should see the following page: 

 

  

https://panoramaweb.org/wiki/home/page.view?name=sharing_documents


19 
 

This is an audit log viewer very similar to the Audit Log grid in Skyline. For the sake of brevity, it 

shows UndoRedo messages only by default, but full details are available through the grid button on 

the left. It is very similar to Skyline’s Reports button and allows you to select, create, and customize 

grid views. By default, Panorama ships with the default view and AllMessagesView, but you are free 

to create your own. 

• Click on the Grid View button 

• Select AllMessagesView from the drop-down menu.  

 

Now your page should look like this: 

 

All the messages and message types in the audit log are now displayed. 

Conclusion 
This tutorial went through setting up an absolute abundance experiment to demonstrate how to use the 

audit log and how to upload it to Panorama. The audit log keeps tracks of all changes you make to your 

document and is fully customizable. It is a powerful tool to reproduce the state of a document from 
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scratch and can be useful when working on the same document with collaborators or when requesting 

troubleshooting help from the Skyline team. 


