Issue 819: Implement new option to synchronize integration

issues
Status:open
Assigned To:Kaipo
Type:Todo
Area:Skyline
Priority:2
Milestone:21.2
Opened:2021-06-21 by Brendan MacLean
Changed:2021-07-26 by Kaipo
Resolved:
Resolution:
Duplicates:802
Closed:
2021-06-21 Brendan MacLean
Title»Implement new option to synchronize integration
Assigned To»Nick Shulman
Type»Todo
Area»Skyline
Priority»2
Milestone»21.2
We are getting increasingly desperate and vocal requests for a way to apply the same integration to a set of replicates. We failed to make "Apply Peak to All" and "... Subsequent" good enough to frequently do what users want from this command.

One collaborator suggested a new option: "Synchronize Integration"

Suggesting just that when in this mode integration changes be applied verbatim to other replicates just as "Synchronize Zooming" works today, working on the x-axis without regard to the chromatograms. If the user wants some form of alignment, then they can use an aligned x-axis (e.g. to an iRT score, or another run when replicate-to-replicate alignment exists).

If we insert a form when this option is chosen, then we could add the ability to choose any subset of replicates with a checklist, and perhaps an option to synchronize immediately with a source replicate, or the best scoring peak in all replicates.

I get the sense that this would be a big deal feature.

https://skyline.ms/announcements/home/support/thread.view?rowId=51524

2021-06-21 Brendan MacLean
It would also have the impact of making "Apply Peak to All" and "Apply Peak to Subsequent" work in the same way. Skyline would imply apply the integration boundaries by x-axis values to all or subsequent peaks. Nothing fancier than that.

2021-06-21 Brendan MacLean
Notify»Will Thompson;Kaipo Tamura

2021-07-26 Brendan MacLean
Assigned ToNick Shulman»Kaipo
NotifyWill Thompson;Kaipo Tamura»Will Thompson

2021-07-26 Kaipo
Issue 802 marked as duplicate of this issue.