Issue 777: Training IMSDB hangs when raw data files are not present

Status:closed
Assigned To:Guest
Type:Defect
Area:Skyline
Priority:3
Milestone:20.2
Opened:2021-03-12 by Brendan MacLean
Changed:2021-11-12 by Brendan MacLean
Resolved:2021-11-12 by Brendan MacLean
Resolution:Not Repro
Closed:2021-11-12 by Brendan MacLean
2021-03-12 Brendan MacLean
Title»Training IMSDB hangs when raw data files are not present
Assigned To»Brian Pratt
Type»Defect
Area»Skyline
Priority»3
Milestone»20.2
I downloaded a file from PanoramaWeb and mistakenly thought it might be able to train an IMS library. So, I brought up that form, created an IMSDB and clicked the Use Results button. A LongWaitDlg popped up showing me the name of the first file, which I realized was not on my system, and then the progress just hung without giving me an error message.

2021-03-12 Brendan MacLean
I downloaded the raw data files and put them in the folder with the Skyline document, but still no message of any kind. It really seems like any error just causes the progress to hang until you cancel the operation, but you really are left with no idea what the code might be trying to do and failing. Did it find those raw data files I downloaded? Is it now erroring because there is no IMS data in them?

2021-11-12 Brendan MacLean
resolve as Not Repro
Statusopen»resolved
Assigned ToBrian Pratt»Brendan MacLean
Notify»Brian Pratt;Nick Shulman
I don't know. I just tried this again, and I got an error with 21.1.0.278. Something must have changed to fix this.

2021-11-12 Brendan MacLean
close
Statusresolved»closed
Assigned ToBrendan MacLean»Guest