Issue 762: enforce or infer setting ion mobilty units for explicit ion mobility values

issues
Status:resolved
Assigned To:Brian Pratt
Type:Defect
Area:Skyline
Priority:3
Milestone: 
Opened:2020-11-17 by Brian Pratt
Changed:2021-02-18 by Brian Pratt
Resolved:2021-02-18 by Brian Pratt
Resolution:Fixed
Closed:
2020-11-17 Brian Pratt
Title»enforce or infer setting ion mobilty units for explicit ion mobility values
Assigned To»Brian Pratt
Type»Defect
Area»Skyline
Priority»3
issue arose in https://skyline.ms/announcements/home/issues/exceptions/thread.view?rowId=49108

problem is the user set explicit IM values but neglected to set units, which causes problems exporting a TIMS-TOF method, per this email thread:

------------
Brian,

This user is running into a "Nullable object must have a value" when they try to export a method.
Their precursors have a "Explicit Ion Mobility" specified, but the "Explicit Ion Mobility Units" is "none".

Here is the original exception report:
https://skyline.ms/announcements/home/issues/exceptions/thread.view?rowId=49108
-- Nick

---------- Forwarded message ---------
From: Nick Shulman <nicksh@u.washington.edu>
Date: Tue, Nov 17, 2020 at 1:28 PM
Subject: Re: [EXTERNAL] Re: That error you ran into in Skyline
To: Vanderboom, Patrick M., M.S. <Vanderboom.Patrick@mayo.edu>


The reason that you are getting an error is that your precursors have a "Explicit Ion Mobility" specified, but the Explicit Ion Mobility Units is "none".
You can use the Document Grid to set the Explicit Ion Mobility Units on all of your precursors.

I believe the "units" can be one of the following values.
drift_time_msec
inverse_K0_Vsec_per_cm2
compensation_V

Thank you for reporting this bug. I will make sure it gets fixed in a future update of Skyline-Daily.
-- Nick

On Tue, Nov 17, 2020 at 1:12 PM Vanderboom, Patrick M., M.S. <Vanderboom.Patrick@mayo.edu> wrote:
Hi Nick,

No worries. The template is attached.

 

Best,

Pat

 

From: Nick Shulman [mailto:nicksh@u.washington.edu]
Sent: Tuesday, November 17, 2020 3:01 PM
To: Vanderboom, Patrick M., M.S.
Subject: [EXTERNAL] Re: That error you ran into in Skyline

 

Pat,

 

Thank you for sending this file.

Sorry about the slow reply. Your message ended up in my spam folder and I did not see it.

In order to reproduce your original bug, I think I am going to need the template file that you used when you did "File > Export > Method".

 

Thanks,

-- Nick

 

 

On Mon, Nov 9, 2020 at 2:37 PM Vanderboom, Patrick M., M.S. <Vanderboom.Patrick@mayo.edu> wrote:

Hi Nick,
Thanks for the prompt reply. Attached is the compressed skyline document.

 

Best,

Pat

 

From: Nick Shulman [mailto:nicksh@u.washington.edu]
Sent: Monday, November 9, 2020 2:59 PM
To: Vanderboom, Patrick M., M.S.
Subject: [EXTERNAL] That error you ran into in Skyline

 

Thank you for including your email address when you reported an error in Skyline.

I am not sure exactly what caused this error (something was null which was not supposed to be null), but if you send us your Skyline document we will probably be able to figure it out.

 

In Skyline you can use the menu item:

File > Share

to create a .zip file containing your Skyline document and supporting files including ion mobility libraries etc.

 

If that .zip file is too large to attach to an email message you can upload it here:

https://skyline.ms/files.url

 

Thanks for your help, and let me know if you have any other questions about Skyline.

-- Nick Shulman

MacCoss Lab, University of Washington

2021-02-18 Brian Pratt
resolve as Fixed
Statusopen»resolved
Fixed in commit 92a6a5ac605e6255ba3a5398fef04d267fe849fe on 1/19/2021