Issue 546: Unable to build spectral library

issues
Status:closed
Assigned To:Guest
Type:Defect
Area:Skyline
Priority:3
Milestone:4.1
Opened:2017-09-25 by rrao
Changed:2017-10-18 by Brendan MacLean
Resolved:2017-10-15 by Brendan MacLean
Resolution:Not Repro
Closed:2017-10-18 by Brendan MacLean
2017-09-25 rrao
Title»Unable to build spectral library
Assigned ToGuest»Brendan MacLean
Type»Defect
Area»Skyline
Priority»3
Milestone»4.1
I receive the following message when attempting to build a spectral library using a Proteome Discoverer result file.

System.IO.IOException: Error occurred running process.
   at pwiz.Common.SystemUtil.ProcessRunner.Run(ProcessStartInfo psi, String stdin, IProgressMonitor progress, IProgressStatus& status, TextWriter writer) in c:\proj\pwiz_x64\pwiz_tools\Shared\Common\SystemUtil\ProcessRunner.cs:line 139
   at pwiz.BiblioSpec.BlibBuild.BuildLibrary(LibraryBuildAction libraryBuildAction, IProgressMonitor progressMonitor, IProgressStatus& status, String[]& ambiguous) in c:\proj\pwiz_x64\pwiz_tools\Shared\BiblioSpec\BlibBuild.cs:line 171
   at pwiz.Skyline.Model.Lib.BiblioSpecLiteBuilder.BuildLibrary(IProgressMonitor progress) in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Lib\BiblioSpecLiteBuilder.cs:line 125

I'm encountering this problem in both the latest release and Skyline daily

Thanks,
Romesh

2017-10-15 Brendan MacLean
resolve as Not Repro
Statusopen»resolved
Assigned ToGuest»Brendan MacLean
Hi Romesh,
Sorry for missing this when it first came in. Some things you could try:
1. Can you build a library at all? Try the Targeted Method Editing tutorial, which will have you build a library. Does that work on your machine?
2. This can't be the entire message you receive. Try including a screenshot of the message or use ctrl-C when the message appears to copy its full text to the clipboard (not just the exception message).

If it turns out to be just your PD results, then we will need you to post the files you are building your library from. You can put them on http://skyline.ms/files.url

If you can't build any library at all, then this must be an installation issue, and you are encouraged to follow the directions for recovering from a broken installation at http://skyline.ms/install_recover.url

If after an installation recovery (or clean installation) you still cannot build any library, reactivate this issue with the new information on your situation.

Again, apologies for taking so long. Let us know if you solved this issue.

--Brendan

2017-10-18 Brendan MacLean
close
Statusresolved»closed
Assigned ToBrendan MacLean»Guest