Issue 268: Create UI to allow hiding/showing replicates

issues
Status:open
Assigned To:Nick Shulman
Type:Todo
Area:Skyline
Priority:3
Milestone: 
Opened:2013-11-12 by Brendan MacLean
Changed:2018-10-15 by Nick Shulman
Resolved:
Resolution:
Duplicates:230
Closed:
2013-11-12 Brendan MacLean
Title»Create UI to allow hiding/showing replicates
Assigned To»Brendan MacLean
Notify»Stephanie Kaspar
Type»Todo
Area»Skyline
Priority»3
Milestone»2.2
At times it would be nice to be able to remove imported replicates from the UI entirely, without having to remove their data from the document. To support this, we should have some sort of check-list UI that allows the user to check the replicates that get included in the UI and uncheck the ones that should be hidden.

2014-01-08 Brendan MacLean
Milestone2.2»2.6

2014-04-12 Brendan MacLean

2014-08-28 Brendan MacLean
Assigned ToBrendan MacLean»donmarsh@proteinms.net
Milestone2.6»3.1
Sorry, Stephanie. We didn't get to this again for the 2.6 release, but I promise it will be high priority now for the next winter release.

I am hearing more and more from people analyzing larger (100-300 run) data sets that are actually splitting them up into multiple documents to make them manageable. Hopefully this feature would help to improve that situation.

2014-08-28 Brendan MacLean
This makes bug 230 repetitive:
https://skyline.gs.washington.edu/labkey/issues/home/issues/details.view?issueId=230

We may want to add a way to choose replicates by replicate annotations, but there should be only one way to filter replicates to show.

2014-08-28 Brendan MacLean
Issue 230 marked as duplicate of this bug.
2015-06-24 Brendan MacLean
Assigned Todonmarsh@proteinms.net»Nick Shulman
Milestone3.1»3.2
Nick is working on ways to hide data in the UI based on some kind of "ignore" setting. He was also considering this case.

2018-10-15 Nick Shulman
Milestone3.2»