QuaSAR Quantitative Statistics

QuaSAR is a program that aids in the Quantitative Statistical Analysis of Reaction Monitoring
Experiments. It was designed to quickly and easily convert processed SRM/MRM-MS data into
calibration curves, determine limits of detection and quantification, calculate mean and coefficient of
variation for all transitions of each peptide in a set of samples, as well as determine the peptide analyte
concentration in unknown samples. The resulting output files, consisting of *.csv tables and *.pdf
figures, can be readily used for further statistical analyses or reported as output for reports or
publications.

In order to use QuaSAR with Skyline, it must be installed through the Skyline external tools framework.
Furthermore, QuaSAR requires the use of custom annotations in Skyline. This tutorial covers the
installation of QuaSAR, how to input data for custom annotations, and how to run the tool itself.

Getting Started

To start this tutorial, download the following ZIP file:

https://skyline.gs.washington.edu/tutorials/QuaSARTutorial.zip

Extract the files in it to a folder on your computer, like:
C:\Users\brendanx\Documents

This will create a new folder:
C:\Users\brendanx\Documents\QuaSARTutorial

The zip file contains the following files:

QuaSAR Tutorial.sky: A Skyline document containing sample data for QuaSAR.
QuaSAR Tutorial.skyd: Contains extracted chromatogram data for the Skyline document.
QuaSAR-1 0.zip: The QuaSAR external tool.

Open the provided file QuaSAR Tutorial.sky in Skyline.

Installing QuaSAR as an External Tool
The Skyline external tools framework supports the direct integration of statistical analysis tools that
process the data in a Skyline document.

To add QuaSAR as an external tool, perform the following steps:

e Onthe Tools menu, click External Tools to bring up the External Tools form.


https://skyline.gs.washington.edu/tutorials/QuaSARTutorial.zip

External Tcols ﬁ
Menu contents:
Add...
Custom
From File
Title:
Command:
Arguments: b
Initial directony: b
Input Report:
| oK || cancel || Ay

Note: Your External Tools menu may already contain some Tools

e C(Click the Add button, and select From File from the context menu.

e Navigate to the location of the QuaSAR-1 0.zip fileinthe folder you created and select it.
e C(Click the Open button.

Skyline will now guide you through the process of installing QuaSAR as an external tool. This may require
you to install the R statistical programming environment, as well as a number of R packages which are
used by QuaSAR to perform its statistical analysis. For example, if you do not have the appropriate
version of R installed, the following form will be displayed:



-

R Installer -

This tool requires the use of B 3.0.1 and the following
packages.

lbitops |
reshape
gtools
boot
gaplot2

nstal | | Cancel

L

Note: This form may look slightly different as the packages might
change and if you already have R 3.0.1 installed.

To complete the installation, performing the following steps:

e On the R Installer form, click Install.

e If you do not have the specified version of R installed on your machine, wait for R to download.
When the download is completed, you will be asked to install R onto your computer. Complete
the R installation process by working through the R installer wizard.

e Once the R installation is completed, Skyline will download and install the necessary R packages

for QuaSAR. When prompted to run the “SkylineProcessRunner”, click the Yes button to install
packages.

Once the installation is complete, the QuaSAR tool will appear in the External Tools form:



r -
External Tools ﬁ

Menu contents:

ers

Title: QuaSAR

Command: &(ProgramPath(R.3.0.1)) D

Arguments: £ "&(ToolDif\Gua5SAR-GF .R" —slave o-sa E]

Initial directory:  S{Document Dir) D E]

Input Repart:

[QUESAH Input v] Output to Immediate Window
| ok || Cancel

L

e Click the OK button on the External Tools form.

Annotating samples with concentration information

Skyline allows you to associate additional information with the replicates in the document by defining
custom annotations. When QuaSAR was installed, it should have defined three custom annotations:
SampleGroup, Concentration and IS Spike.

The Annotation Settings form will show the list of the annotations that have been defined.
To view the Annotation Settings form, perform the following step:
e On the Settings menu, click Annotations.

You must check the checkboxes in the list in order to be able to use these annotations in your current
Skyline document. The Annotation Settings form should look like the one shown below:



1ia Annotation Settings Iﬁ

Annotations are extra pieces of data which you can attach to elements in a Slyline document .
|Use this dialog to control which annotations are available in this document, as well as to define
new annotations.

SampleGroup Edit List...

Concentration
15 Spike

0K || cancel

b,

e Click the OK button.

Editing annotation values in Skyline is done using the Results Grid. To bring up the Results Grid do the
following:

e On the View menu, click Results Grid (Alt-2).

The Results Grid will show you chromatogram peak areas and other measured results for the currently
selected peptide, or transition. Select a protein to see only the replicate annotations.

Copy the values in the following tables and paste them into the results grid:

SampleGroup | Concentration | IS Spike
A 0 10
A 0 10
A 0 10
A 0 10
B 0.001 10
B 0.001 10
B 0.001 10
B 0.001 10
C 0.004 10
C 0.004 10
C 0.004 10
C 0.004 10
D 0.018 10
D 0.018 10
D 0.018 10
D 0.018 10




E 0.075 10
E 0.075 10
E 0.075 10
E 0.075 10
F 0.316 10
F 0.316 10
F 0.316 10
F 0.316 10
G 1.33 10
G 1.33 10
G 1.33 10
G 1.33 10
H 5.62 10
H 5.62 10
H 5.62 10
H 5.62 10
I 23.71 10
I 23.71 10
I 23.71 10
I 23.71 10
J 100 10
J 100 10
J 100 10
J 100 10

The completed grid should look like this:




Results Grid =)
E:Er:i:ate SampleGroup Concentration 15 Spike
91_5SiteBBB_AT_... |A 0 10
591_SiteBEB_AZ_... | A 0 10
91_SiteBBB_AJ_ (A 0 10
9-1_SiteB6B_A4_... | A 0 10
91_5iteBBB_B1_... |B 0.001 10
91_5iteBBB_B2_... B 0.001 10
591_SiteBBB_B3_... |B 0.001 10
9-1_SiteB6B_B4_... |B 0.001 10
91_5iteBBB_C1_... |C 0.004 10
91_SiteBBB_C2_... |C 0.004 10
51_SiteBBB_C3_. |C 0.004 10
9-1_Site56B_C4_... |C 0.004 10
91_5iteB6B_D1... |D 0.018 10
91_5iteBBB_D2.. |D 0.018 10
51_SiteBBB_D3.. |D 0018 10
91_5ite56B_D4.. |D 0.018 10
91_5iteB6B_E1_... |E 0.075 10
91_5iteBBB_EZ2_... |E 0.075 10
591_SiteBBB_E3_... |E 0.075 10
91_Site5BB_E4_.. |E 0.075 10
91_SiteB6B_F1_... |F 0.31&6 10
91_5iteBBB_F2_... |F 0.31& 10
91_5SiteBBB_F3_... |F 0.31& 10
91_Site5BB_F4_.. |F 0.316 10
91_5iteBBB_G1... |G 133 10
91_5iteBBB_G2.. |G 1.33 10
91_5iteBBB_G3.. |G 1.33 10
591_SiteBBB_G4.. |G 133 10
91_5ite56B_H1... |H 5.62 10
91_5iteBBB_H2.. |H 562 10
91_5iteBBB_H3... |H 5.62 10
51_SiteBBB_H4.. |H 562 10
91_Site56B_1_... |1 23.71 10
91_5iteB6B_12_... || 23.71 10
91_SiteBBB_13_... || 2371 10
51_Site56EB_14_... |1 2371 10
91_5ite56B_J1_... |J 100 10
91_SiteBBB_J2_... |J 100 10
91_5SiteBRB_J3_... |J 100 10

> 5-1_SiteBBB_J4_... |J 100

Record: -ﬂ]of-ﬁ] EI\Z/ Filter:




e Close the Results Grid in Skyline by clicking the red X in its upper right corner.

Using QuaSAR

To run a QuaSAR analysis, perform the following steps:

e On the Tools menu, click QuaSAR.

Skyline will begin exporting the QuaSAR input report. This may take a few minutes. You can track the
progress of the report export with the green progress bar in the bottom of the Skyline Window. Once
the report is exported, Skyline will display the QuaSAR form:

QuasAR

Title | 0

ok |

Basic | Plots | Additional Tools |

Generate
Calibration curves CV table
LOD/LOG table
[ LoD/LOG comparison

[7] Peak area plats

QOptiong
Standard present

[7] Use PAR for analysis

Aralyte:  [light Are -
Standard: [heawﬁu‘ea V]
nits: frnalAul

lUze Defaults

For this tutorial you will leave the options in their default settings. If you wish to learn more about the
many options provided by QuaSAR, you can read the documentation here.


ftp://ftp-genome.wi.mit.edu/distribution/genepattern/modules_public_server_doc/QuaSAR_GP_HelpDoc.pdf

e In the Title textbox enter ‘Tutorial’.
e Click the OK button on the QuaSAR form.

The QuaSAR tool will perform its analysis. The output from the tool run is shown in the Immediate

Window, the textbox docked at the bottom of the main Skyline window. When the tool is completed,

use the Widows explorer to navigate to the directory containing the QuaSAR Tutorial.sky file.

The directory should now contain a number of output files in .csv and .pdf formats generated by

QuaSAR, based on the data contained in the Skyline document.

Parameters

Name Location Description

Title Basic The title to be displayed on each calibration
plot.

Analyte Basic > Options User must specify the exact analyte column
header name as it appears in the input CSV
file. The defaultis “light Area”.

Standard Basic > Options User must specify the exact internal standard
column header name as it is appears in the
input CSV file. The default is "heavy Area".

CV table Basic > Generate If checked then generate CV (coefficient of

variation) table.

Calibration Curves

Basic > Generate

If checked then generate calibration curves.

LOD/LOQ table

Basic > Generate

If checked then generate LOD/LOQ table.

Peak area plots

Basic > Generate

If checked then generate peak area plots with
Peak Area units on the y-axis and analyte
concentration on the x-axis.

Use PAR for analysis

Basic > Options

If checked then use peak area ratio (PAR) for
analysis (instead of concentration) with PAR
on the y-axis and analyte concentration on the
X-axis.

linear scale

Plots

The maximum value for linear scale in Units.

Max calcurve log scale

Plots

The maximum value for log scale in Units.

Units

Basic > Options

Define units, the default is fmol/ul. The unit
will be a label on the output files.

Generate graphs as JPEGs Plots Generates and saves JPEGs to directory of the
.sky file.
Number of transitions to plot Plots Specifies number of transitions to plot.

Perform AuDIT

Additional Tools >
AuDIT

If "yes" then perform AuDIT for interference
detection.

AuDIT cv threshold

Additional Tools >
AuDIT

For AuDIT the threshold for coefficient of
variation below which transition is
guantification-worthy. Default is 0.2.

Perform endogenous
determination

Additional
Tools>Endogenous
estimation

If checked performs endogenous
determination when QuaSAR runs.




Endogenous confidence level Additional Default 0.95.
Tools>Endogenous
estimation

Output Files

If all options that generate an output are selected then upon successful completion QuaSAR will
generate the following output files:
1. Filename with suffix: -parameters-summary.csv
A CSV file containing all parameters used by user to generate results

2. Filename with suffix: —-calcurves.pdf
A PDF file with the calibration plots ordered by peptide sequence

3. Filename with suffix: —-calcurves.csv
A CSV file with associated calibration plot information

4. Filename with suffix: —calcurves-peakareas.pdf
A PDF file with the calibration plots using peak areas instead of concentrations and
ordered by peptide sequence

5. Filename with suffix: —-calcurves-peakareas.csv
A CSV file with associated calibration plot information using peak areas instead of
concentrations

6. Filename with suffix: -by_protein_calcurves.pdf
A PDF file with the calibration plots ordered by protein name

7. Filename with suffix: -by _proteins_calcurves-peakareas.pdf
A PDF file with the calibration plots using peak areas instead of concentrations and
ordered by protein name

8. Filename with suffix: ~-cvplot.pdf
A PDF file showing overall assay reproducibility by plotting CV vs. theoretical
concentration values.

9. Filename with suffix: ~-lodboxplot.pdf
A PDF file showing distribution of LOD values with a box-whiskers plot.

10. Filename with suffix: -lod-log-raw.csv
A CSV file with lod-loq raw values.

1. Filename with suffix: ~-1lod-log-final.csv

A CSV file with final lod-loq values, which is a subset of the raw file. The lowest LOD and
LOQ values are selected for a given peptide.
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2. Filename with suffix: —cvtable.csv
A CSV file with a CV table for all peptide/sample/transitions.

3. Filename with suffix: —cvtable-final.csv
A CSV file with the minimum CV reported in table for all peptide/sample/transitions

4. Filename with suffix: —audit.csv
A CSV file with the AuDIT results for all transitions.

5. Filename:Rplots.pdf

This is a system generated empty file and needs to be ignored by the user. In a future
release of QuaSAR this file will be removed.
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