ERROR: No spectra were found for the new library. proteomica2  2023-03-13 03:15
Dear all

I am having problems with Skyline daily. I have an DDA experiment acquired in Timstof which I want to study peptides label with NEM and d5NEM. After loading file data and searching, Skline is not able to build the library and return the next message:

ERROR: No spectra were found for the new library.

Command-line: C:\Users\Carlos\AppData\Local\Apps\2.0\41VM9PKA.2W2\L22PKGOR.GPN\skyl..tion_e4141a2a22107248_0016.0002_bdd2fb77bf0c781e\BlibBuild -s -A -H -o -c 0.95 -i Cys_NEM_D5NEM -S "C:\Users\Carlos\AppData\Local\Temp\tmp9C39.tmp" "E:\Proteomic-Projects\Ricardo_CysNEM\combined\txt\Cys_NEM-D5NEM.redundant.blib"
Working directory: E:\Proteomic-Projects\Ricardo_CysNEM
OK More Info
System.IO.IOException: ERROR: No spectra were found for the new library.

Command-line: C:\Users\Carlos\AppData\Local\Apps\2.0\41VM9PKA.2W2\L22PKGOR.GPN\skyl..tion_e4141a2a22107248_0016.0002_bdd2fb77bf0c781e\BlibBuild -s -A -H -o -c 0.95 -i Cys_NEM_D5NEM -S "C:\Users\Carlos\AppData\Local\Temp\tmp9C39.tmp" "E:\Proteomic-Projects\Ricardo_CysNEM\combined\txt\Cys_NEM-D5NEM.redundant.blib"
Working directory: E:\Proteomic-Projects\Ricardo_CysNEM
   at pwiz.Common.SystemUtil.ProcessRunner.Run(ProcessStartInfo psi, String stdin, IProgressMonitor progress, IProgressStatus& status, TextWriter writer, ProcessPriorityClass priorityClass) in C:\proj\pwiz\pwiz_tools\Shared\Common\SystemUtil\ProcessRunner.cs:line 161
   at pwiz.BiblioSpec.BlibBuild.BuildLibrary(LibraryBuildAction libraryBuildAction, IProgressMonitor progressMonitor, IProgressStatus& status, String& commandArgs, String& messageLog, String[]& ambiguous) in C:\proj\pwiz\pwiz_tools\Shared\BiblioSpec\BlibBuild.cs:line 428
   at pwiz.Skyline.Model.Lib.BiblioSpecLiteBuilder.BuildLibrary(IProgressMonitor progress) in C:\proj\pwiz\pwiz_tools\Skyline\Model\Lib\BiblioSpecLiteBuilder.cs:line 161
After that, Skyline starts to load data again and the software goes into loop.

Could it be a possible solution?

Thanks in advance.

Carlos Fuentes
Nick Shulman responded:  2023-03-13 10:14
The error "No spectra were found for the new library" usually means that BiblioSpec was not able to understand the spectrum identifiers in the peptide search results.
What type of peptide search results did you have?

Here is the page which lists the types of peptide search results which BiblioSpec understands:

If you like, you could zip up all of your peptide search results files and upload them here and we could try to figure out what is going on:
-- Nick
proteomica2 responded:  2023-03-14 04:45
Hi Nick

Many thanks for your answer. Attached, you can find the skyline┬┤s message after finishing the searching with Amanda.
I am sending a timstof data file (CeciliaFernandez_sol508-31-22_M1.d).


Nick Shulman responded:  2023-03-14 08:18
I did not realize that you had done an MSAmanda search in Skyline.
You might be getting that error message because the peptide search really did not find any peptides. There are certainly times when you might collect data on a mass spectrometer and then not be able to find any peptides in it.

If you would like us to check whether there was anything wrong with your MSAmanda search, we would need more information:
1. Screenshots of all the pages of the "File > Import > Peptide Search" wizard so that we know what settings you used.
2. The FASTA file that you provided to the Import Peptide Search wizard
3. The blank Skyline document that you were importing the peptide search into. You can use the menu item:
File > Share
create a .zip file containing your Skyline document.
4. The raw files that you were trying to search. The folder that you uploaded before seems to be missing files. I see that there is a "analysis.tdf_bin" file in there, but there is no "analysis.tdf" file so we cannot read it.

You can zip up all your files and upload them to the usual spot:

-- Nick
proteomica2 responded:  2023-03-17 02:12
Hi Nick

Apologize for delay. Problems with the instruments...
I am uploading info you requested to me. The file is CarlosFuentes_Cys-NEM-D5NEM.rar (It is bigger...)

We are keeping in touch.

Muchas gracias!!

Nick Shulman responded:  2023-03-17 15:17
Thank you for sending that 40GB archive.

I tried just searching a single one of the Bruker .d folders that you sent.
What I am seeing is that it spends an enormous amount of time showing the "Building Peptide Search Library" window and does not seem to make any progress at all. My guess would be that it's going to take about 12 hours to get through this one file, and in the end it's going to say "No spectra were found for the new library".

My guess about what is happening is that BiblioSpec does not understand the spectrum identifiers that it is reading from somewhere and is having to do a linear search through all of the spectra in the Bruker .d folder and never actually finds a matching spectrum.

Is this similar to the behavior that you saw? Did Skyline spend a ridiculous amount of time showing you the "Building Peptide Search Library" progress window after you pressed the "Finish" button on the "Import Peptide Search" wizard?

I will ask around and see if someone can figure out why BiblioSpec is doing this.
-- Nick
proteomica2 responded:  2023-03-20 03:40
Hi Nick

Many thanks.
I was exactly what happended it and I do not understand why. Skyline was spending many hours treating to build the library.

I am looking forward to hearing from you.

Have a good day!

Nick Shulman responded:  2023-03-20 14:46

Our BiblioSpec expert has come up with a fix for this. The bug had something to do with BiblioSpec not understanding "combined ion mobility spectra".

I was able to successfully search your data files with a fixed version of Skyline, and I am attaching the .blib file that I got, which might be helpful to you. (Let us know if you see anything suspicious in there).
If you wanted to use this .blib file in your Skyline document, one thing that you could do is File > Import > Peptide Search and click the radio button "Use existing".

This bug will probably be fixed in the next update of Skyline-daily which will probably be released out in a few weeks.
-- Nick
proteomica2 responded:  2023-03-21 00:01
Hi Nick

Thank you very much!! I gonna try it with the fixed version of Skyline. I will let you know about it.

Have a nice day

Nick Shulman responded:  2023-03-21 14:24
By the way, one way to work around this bug would be to use MSConvert to convert your .d folders to .mzML.
When you do "File > Import > Peptide Search", be sure to point Skyline at your .mzML files instead of your .d folders.
In MSConvertGUI, be sure to check the checkbox that says "Combine ion mobility spectra".
My understanding is that this bug is happening because the peptide search and BiblioSpec had different ideas about whether the ion mobility spectra were supposed to be combined, and that meant that the spectrum identifiers generated in the peptide search could not be understood by BiblioSpec. If you instead search mzML files where the ion mobility spectra have already been combined, then this mismatch cannot happen.
-- Nick
proteomica2 responded:  2023-03-21 23:55
Hi Nick,

Thank you very much. The .blib file works so fine!

To be honest, I'd just tried converting the files, but I don't know that I had to check Combine ion mobility spectra.

Thanks again!