Limit on number of runs? phains  2022-09-08
 

Hi all,

first off, I love Skyline and I'm a long time user. I really appreciate all the hard work for such a great (free!!) product.

This pertains to the latest version of Skyline with Sciex data.

I am currently using Skyline to assess some DIA runs. I use the term "some" lightly. I've loaded a smidge over 700 runs and they all seem to load okay. But when I go to review the data it is quite clear that I cannot view all the files. If I go to Manage Results, all the files are listed. If I remove a good number then I effectively remove the files I can browse freely. I assume I'm hitting some limit here. If this is the case, can you tell me what that number is, and if not, can you suggest what may be happening?

I, and others in our group, have seen similar issues when loading very large numbers of files in Skyline.

thanks,

Peter

 
 
Nick Shulman responded:  2022-09-08
There is not supposed to be any limit to the number of replicates that you can have in a Skyline document.

I am not sure that I understand what you mean when you say that you cannot view all the files.

One problem that Skyline has is that if any graph is too small to display the legend, the graph ends up being blank. If you see that all of your chromatogram graphs are blank, you can usually fix it by either right-clicking on one of the graphs and unchecking the "Legend" menu item. You can also use the "View > Arrange Graphs > Grouped" menu item so that Skyline will not try to display all of the chromatogram graphs at once.

Another thing that goes wrong when you have a lot of replicates is that the "View > Chromatograms" submenu has too many items on it to be usable. Instead of trying to use that menu, you should memorize that Ctrl + Up and Ctrl + Down move you between the replicates, and Ctrl + F4 closes one chromatogram window, and Ctrl + Shift + F4 closes all of the chromatogram windows.

If you send us your Skyline document we might be able to figure out what is going wrong.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. You can upload larger files here:
https://skyline.ms/files.url

It is usually very helpful for us to see documents which push the limits of Skyline's capabilities and we usually find several areas where the performance can be greatly improved by us making a small change to the code.
-- Nick
 
phains responded:  2022-09-08
Hi Nick,

I'm trying to use the View > Chromatograms. But, I was using it via the "down arrow" at the top right of the chromatogram window. There is < > v x, or stuff close to that. If I scroll, it runs out of puff and I can only see 200, for example, of the 700 files loaded. Playing with this more now, I'm guessing this is a tab display limit and what I'm actually looking at is the number of loaded tabs, not the files loaded?

I just discovered, that if I use the menu item, the scrolling does not run out of puff and I can go see all the files loaded. Using Ctrl + Up or Down works, but it's quite slow to move to the next chromatogram. It would be nice if I could pull up all the loaded files (like in Manage results) and then click on a file to get to that chromatogram. Suffice to say the current setup is tedious to move around with lots of files loaded. It's possible I've not worked out the best way to do this, so I'll play more.

Anyway, it seems you've answered my question.

Thanks for your help,

Peter
 
phains responded:  2022-09-08
I just rediscovered the replicates option on the top left. Seems it was hiding in plain sight...
 
Nick Shulman responded:  2022-09-09
Another way to navigate between runs is to use the Document Grid, and choose "Replicates" from the Report dropdown at the top of the Document Grid.
Each row of the Replicates report has something you can click on to select that replicate.

You can learn more about the Document Grid in the Custom Reports tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_custom_reports
-- Nick