Forward compatibility in Skyline versions

support
Forward compatibility in Skyline versions Liyan  2021-08-18
 

Hi Skyline team,

We are using Skyline for DIA. We have a few .sky documents complete with libraries and iRTdb that are used as master templates for any project with the same sample types. Most of these .sky templates were setup on version 19.1.0.193 (administrator installation)

We have a new project with over 200 files and thought to run the import on a new computer that has 21.1.0.146 installed. Unfortunately there is an issue with forward compatibility, our master templates are "broken" when opened on the new version and all imports fail. We have also tried to setup the templates from scratch on version 21 but this did not work either.

Our files were acquired on Thermo HFX. We have eliminated file corruption as the cause, as test imports on a few raw files with the .sky master templates work on other computers with version 19.

Will it be possible to give us access to the 19.1.0.193 installer file as a temporary solution?
Edit: I have found the link to the archive.

This is the error that we're getting on version 21.

At 2:46 pm:
Failed importing results file 'C:\Users\FPL\Documents\Liyan\to_import\20210722_Liyan_SFN_EvoSep_HCS001.raw'.

pwiz.Skyline.Model.Results.ChromCacheBuildException: Failed importing results file 'C:\Users\FPL\Documents\Liyan\to_import\20210722_Liyan_SFN_EvoSep_HCS001.raw'.
---> pwiz.Skyline.Util.AssumptionException
at pwiz.Skyline.Util.Assume.Fail(String error) in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Util\Util.cs:line 2055
at pwiz.Skyline.Model.Results.SpectrumFilterPair..ctor(PrecursorTextId precursorTextId, Color peptideColor, Int32 id, Nullable1 minTime, Nullable1 maxTime, Boolean highAccQ1, Boolean highAccQ3) in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Results\SpectrumFilterPair.cs:line 57
at pwiz.Skyline.Model.Results.SpectrumFilter..ctor(SrmDocument document, MsDataFileUri msDataFileUri, IFilterInstrumentInfo instrumentInfo, Nullable`1 maxObservedIonMobilityValue, IRetentionTimePredictor retentionTimePredictor, Boolean firstPass, GlobalChromatogramExtractor gce) in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Results\SpectrumFilter.cs:line 267
at pwiz.Skyline.Model.Results.SpectraChromDataProvider..ctor(MsDataFileImpl dataFile, ChromFileInfo fileInfo, SrmDocument document, IRetentionTimePredictor retentionTimePredictor, String cachePath, IProgressStatus status, Int32 startPercent, Int32 endPercent, IProgressMonitor loader) in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Results\SpectraChromDataProvider.cs:line 121
at pwiz.Skyline.Model.Results.ChromCacheBuilder.CreateSpectraChromProvider(MsDataFileImpl dataFile, ChromFileInfo fileInfo) in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 1264
at pwiz.Skyline.Model.Results.ChromCacheBuilder.BuildCache() in C:\proj\skyline_21_1_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 233
--- End of inner exception stack trace ---

 
 
Nick Shulman responded:  2021-08-19
Can you send us your Skyline document that is causing the problems?

The error that you are running into has something to do with the retention time range over which Skyline has been told to extract chromatograms for one of the peptides or molecules in the document. Somehow, Skyline has a start time but no end time, or perhaps an end time, but no start time. That is not supposed to be able to happen, which is what is causing the error.

If you send us your Skyline document, we will probably be able to fix it, and probably also fix Skyline.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including iRT database and extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
Nick Shulman responded:  2021-08-19
Thank you for sending your files.

I think the problem is that at:
Settings > Transition Settings > Instrument
the "Min time" value is set to 5, but the "Max Time" value is blank.

You can fix this problem by either changing "Min time" to blank, or putting in a value for "Max Time" (such as 500).

I am very surprised that we have not noticed this bug before. You are certainly supposed to be able to set only one of Min Time or Max Time on the Instrument Settings if you want. However, ever since Skyline 19.2 this would result in not being able to import results.

Thank you for reporting this bug. I will fix this bug in an upcoming release of Skyline-Daily.
-- Nick
 
Liyan responded:  2021-08-19
Hi Nick,

Thank you for the fix, importing works like a charm now!
 
Liyan responded:  2021-08-19
Hi Nick,

Unfortunately I'm back again. Removing the "min time = 5" filter worked for a test import on a standard-issue desktop (mine) running on Skyline v21 but did not work on the new computer running the same version. The team member who is analysing the 200 files is on a different campus - I am just trying to replicate his errors.

Could this is a problem with cache, that somehow the new computer somehow has got stuck in an error loop? He gets the message:

"The calculator human_serum_plasma_2021 requires all of its standard peptides in order to determine a regression."

The iRT peptides are definitely in there because we had checked the files on a simple .sky with iRT transitions standards immediately after acquisition.
 
Nick Shulman responded:  2021-08-19
That sounds like an unrelated error.

I believe that error means that the document is missing some of the iRT standard peptides.

You can see the iRT standard peptides by going to:
Settings > Peptide Settings > Calculator Button > Edit Current
The iRT standard peptides are shown in the upper grid in the Edit iRT Calculator dialog. My guess is that you will see some peptides in that list which are not in your document.

There are some steps that you can go through which will cause Skyline to offer to add the missing iRT peptides to your document. After you have done this, you will probably be able to import a result file without error.

If you do the following steps, Skyline will offer to add the missing iRT standard peptides to the document:
1. Go to Settings > Peptide Settings > Prediction
and change "Retention time predictor" to "none" and then press "OK" on the Peptide Settings dialog.
2. Go to Settings > Peptide Settings > Prediction again
and change "Retention time predictor" back to its original value, which was "Human_serum_plasma_2021" and then press OK on the Peptide Settings dialog again.

Skyline will then offer to add the missing iRT standard peptides to your document.

After you have done that, you will likely be able to import a raw file with "File > Import > Results".

If that does not fix the problem, then the problem might be something else.

If you are still having trouble, you should send me your Skyline document (File > Share to create a .zip file), as well as the raw file you are trying to import.
-- Nick
 
Liyan responded:  2021-08-20
Hi Nick,

Oddly the iRT peptides were already in the document. What worked was closing Skyline and re-building the document on the new computer from scratch again. I think we'll just leave it for now. Thank you again.