why some transitions are excluded in Transition Results report minyg98  2021-06-30
 

Hi, Skyline team.

I found out that some transitions are excluded in report file although they were shown in profiles.
Also, those excluded transitions don't show green dots in the list.
I attached a figure showing this problem.
How can I export all the transitions?

-Minyeong

 
 
Nick Shulman responded:  2021-06-30
Minyeong,

One thing that might have happened is that you added those transitions to your Skyline document after you had already extracted chromatograms.
When you add transitions to your document, you usually need to tell Skyline to extract all the chromatograms again by going to:
Edit > Manage Results > Reimport

Until you tell Skyline to extract chromatograms again, newly added transitions will be missing their chromatograms.

Other than that, I cannot think of a reason that things would look the way they do there.

If you send us your Skyline document and one of your raw files, I can take a look and figure out what is going on.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

You can upload that .zip file and your .raw files here:
https://skyline.ms/files.url

-- Nick
 
minyg98 responded:  2021-06-30
I uploaded the file.
You only need to check on replicate 2 because it's the only one reimported in the file.

Thank you for your help!

-Minyeong
 
Nick Shulman responded:  2021-07-01
Thank you for sending that .sky.zip file.

I think you just need to go to:
Edit > Manage Results
select all of the replicates and push the "Reimport" button.

It looks like you made a change to your settings which resulted in the b ions being added. Whenever you change settings like that you should reimport chromatograms using the Manage Results dialog.

(If you go to "View > Other Grids > Audit Log" you can see the changes that were done to the Skyline document).

If "Reimport" does not fix the problem for you, you should send me one of your raw files.
-- Nick
 
minyg98 responded:  2021-07-01
I clicked the Re-import button but it did not change anything.
But when I removed other replicates, there was a change.
All the excluded transitions were suddenly included.
I do not know what is going on but I think I solved the problem.

By the way, I have another question.
I attached an image, please check on it.
In the picture, I see the lines are cut off.
Why is this happening?

-Minyeong
 
Nick Shulman responded:  2021-07-01

The gaps in those chromatograms might be there because of the "Triggered Acquisition" being selected at:
Settings > Transition Settings > Instrument

When "Triggered acquisition" is enabled, Skyline tries to figure out which are the time intervals over which the mass spectrometer was not collecting data for your analyte of interest. If one section of the chromatogram has a lot more points in it than another section, Skyline might believe that this is a range over which the mass spectrometer was not acquiring data for your analyte, and Skyline will draw a gap in the chromatogram like you are seeing.

Here is another support request where someone else had chromatograms that looked like that:
https://skyline.ms/announcements/home/support/thread.view?rowId=48738
That support request has a description of how Skyline decides that a gap in the chromatogram should be displayed:

When "Triggered Acquisition" is selected, Skyline tries to guess how long of a gap between scans corresponds to a time when the mass spectrometer is not collecting data for your peptide of interest. In order to decide on a gap interval, Skyline looks at the median time between scans and multiplies that median time by ten, and that is the gap interval. If any scans are more than that interval apart, then Skyline breaks the chromatogram in between those scans.

If the rate of spectra being acquired varies a lot, then you might end up getting gaps in your chromatogram like you see there.

-- Nick

 
minyg98 responded:  2021-07-01

Thank you so much!!

Have a nice day

-Minyeong

 
minyg98 responded:  2021-07-01

Nick,

I have a question.
In the sentence "Skyline looks at the median time between scan …", what does the time mean exactly?

-Minyeong

 
Nick Shulman responded:  2021-07-01
A chromatogram is a list of retention time values and intensities.
The time between scans is the retention time of one point minus the retention time of the previous point on that chromatogram.
If you have a chromatogram with 100 points along it, then Skyline will calculate the 99 retention time differences between each point and the point right before it.
Then, Skyline takes the median of those 99 retention time differences and multiplies that median by 10.
Then, Skyline looks again at the 100 points along the chromatogram, and anywhere that the time difference between any neighboring points is greater than that 10x median time difference is plotted as a gap in the chromatogram graph.

If you want to check the math that Skyline is doing this correctly, you can see the list of retention times of any particular chromatogram in the document grid. The column that would show you that is "Raw Times" which can be found in the Customize Report dialog under:
Proteins > Peptides > Precursors > Transitions > Transition Results > Chromatogram > Raw Data

You can also copy the times and intensity numbers from the chromatogram graph using the chromatogram right-click menu item "Copy Data". Before you do "Copy Data", you should right-click on the chromatogram and make sure that "Transform > None" is selected, and also make sure that you are zoomed out to see the entire chromatogram, because "Copy Data" usually copies only the portion of the chromatogram that is visible.

-- Nick
 
minyg98 responded:  2021-07-01
Nick,

Thank you for the clear explanation!

I checked if there was a time difference greater than 10x median time difference, but it says there was not.
Could you please check on the attached file and see if I calculated it right?
It is on "sheet1".
Did I calculate wrong or is the reason there was blanks in the profile I attached earlier something else?

-Minyeong
 
Nick Shulman responded:  2021-07-01
If you want to know where Skyline is going to put the gaps, you have to look at the retention times of both the light and heavy chromatograms, and also all of the precursor charge states. Each chromatogram is treated as a separate thing in terms of figuring out what the median is, and where there are any gaps, but any gap which is found in any of those chromatograms applies to all of the chromatograms for that peptide in that replicate.

All of the transition chromatograms under a particular precursor will have the same set of retention times, but each precursor under the peptide will have a different set of retention times.

You should send me another copy of your Skyline document, since I think you have reimported some replicates (there are no chromatograms in the first document that you sent me which look like your screenshot).

Also, it would be helpful if you could send me at least one of your .raw files.
-- Nick