paired comparison in Skyline

support
paired comparison in Skyline zdarula  2021-01-15
 

Hi,
I have a SureQuant dataset for 50 paired normal-tumor tissue samples and I would like to ask your advice how to set up a paired comparison (like "nested experiment" in Proteome Discoverer). As the biological replicates are not independent I should have the tumor/normal ratio per sample pairs instead of annotating the samples into a normal (50 sample) vs tumor (50 sample) groups. Can I do this in Skyline? Thanks a lot.

A minor issue: unfortunately I set up the Skyline experiment on the peptide level and now that I want to assign these to proteins so as to get a protein-level fold-change I cannot do it without losing my corrected peak boundaries, e.g. skyline reintegrates peaks if I associate proteins to the peptides. Can I somehow bypass this?

Thanks a lot,
Zsuzsa

 
 
Nick Shulman responded:  2021-01-15
Skyline does not know how to do a paired comparison like that, but, if I understand your question correctly, the MSstats External Tool does.

When MSstats sees that the same "BioReplicate" appears in both of the two Conditions, MSstats assumes that this is a Time Course experiment where the same sample was measured at two times. In that case, each sample gets paired with its own control.
You can install the MSstats external tool by using the Skyline menu item:
Tools > Tool Store

If you want Skyline to group your peptides into proteins you can use the menu item:
Refine > Associate Proteins

-- Nick
 
zdarula responded:  2021-01-18
Dear Nick,
thanks for your prompt reply.
As for the association of peptides to proteins - my problem here is that if I use this command than Skyline reintegrates the peaks. We spent a lot of time to check integration for the 70 peptides we targeted in 100+ LC-MS/MS runs and it would be nice if we did not need to do it again. Is there a way to bypass new, default integration if we associate peptides to proteins?

Thanks again,
Zsuzsa
 
Nick Shulman responded:  2021-01-18
Zsuzsa,

I believe it was our intention that "Associate Proteins" would preserve manually adjusted peak boundaries, but I see that it does behave that way.
I will try to fix this, but it might be difficult to fix.

In the meantime you can work around this problem by exporting your peak boundaries to a .csv file before you do "Associate Proteins", and then import the peak boundaries file using "File > Import > Peak Boundaries".

In the Document Grid, there is a predefined report called "Peak Boundaries" which you can use for exporting the peak boundaries.
-- Nick
 
zdarula responded:  2021-01-18
Dear Nick,

We tried what you suggested but unfortunately, when importing peak boundaries we got the following error message.
I also attached the peak boundaries .csv file.

Thanks,
Zsuzsa

---------------------------
Skyline
---------------------------
Failed reading the file O:\dzs\2020\GyorffyB\skyline\2020dec\p1_Peak_Boundaries.csv.
Failed to find the necessary headers FileName, MinStartTime, MaxEndTime in the first line
---------------------------
OK More Info
---------------------------
System.IO.IOException: Failed to find the necessary headers FileName, MinStartTime, MaxEndTime in the first line ---> System.IO.IOException: Failed to find the necessary headers FileName, MinStartTime, MaxEndTime in the first line
   at pwiz.Skyline.Model.PeakBoundaryImporter.ReadFirstLine(String line, IList`1 allFieldNames, ICollection`1 requiredFields, Int32[]& fieldIndices, Int32& fieldsTotal) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Model\ImportPeakBoundaries.cs:line 548
   at pwiz.Skyline.Model.PeakBoundaryImporter.IsMinutesPeakBoundaries(TextReader reader) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Model\ImportPeakBoundaries.cs:line 167
   at pwiz.Skyline.Model.PeakBoundaryImporter.Import(String inputFile, IProgressMonitor progressMonitor, Int64 lineCount, Boolean removeMissing, Boolean changePeaks) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Model\ImportPeakBoundaries.cs:line 147
   at pwiz.Skyline.SkylineWindow.<>c__DisplayClass1067_0.<ImportPeakBoundaries>b__2(IProgressMonitor longWaitBroker) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\SkylineFiles.cs:line 1527
   at pwiz.Skyline.Controls.LongWaitDlg.RunWork(Action`1 performWork) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 254
   --- End of inner exception stack trace ---
   at pwiz.Skyline.Util.Helpers.WrapAndThrowException(Exception x) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Util\Util.cs:line 1942
   at pwiz.Skyline.Controls.LongWaitDlg.PerformWork(Control parent, Int32 delayMillis, Action`1 performWork) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 202
   at pwiz.Skyline.Controls.LongWaitDlg.PerformWork(Control parent, Int32 delayMillis, Action`1 performWork) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 140
   at pwiz.Skyline.SkylineWindow.ImportPeakBoundaries(String fileName, Int64 lineCount, String description) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\SkylineFiles.cs:line 1530
   at pwiz.Skyline.SkylineWindow.ImportPeakBoundariesFile(String peakBoundariesFile) in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\SkylineFiles.cs:line 1501
---------------------------
 
Nick Shulman responded:  2021-01-18
Zsuzsa,

It looks like you have modified the Peak Boundaries report from the way it is originally when Skyline was installed. Specifically, it looks like you might have checked the "Pivot Replicate Name" box in the Report Editor.

Attached is what the report definition is supposed to be.
You can import this .skyr file into Skyline by doing:
File > Export Report > Edit List > Import

If you would like or you have any other troubles, you can send us your Skyline document, in case there is anything else going wrong.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
zdarula responded:  2021-01-19
Dear Nick,

Indeed, the "Pivot Replicate Name" box was checked. Using the attached .skyr file solved the import peak boundaries isssue.

Thanks a lot,
Zsuzsa