Small molecule - custom report - cannot get light and heavy on same row MartijnvF  2020-03-27
 

Dear all,

I am working on getting my custom report to show both the areas of the light and heavy molecule on the same row in the report. However, I only get the areas on different rows, see attachment.

Cheers,
Martijn

 
 
Nick Shulman responded:  2020-03-27
Martijn,

The usual way to tell Skyline to put the light and heavy values on the same line is to check the checkbox that says "Pivot Isotope Label" on the Customize Report dialog.

I cannot tell which columns you are showing on your report, and whether you have told Skyline to pivot on the isotope label. Can you send me your report definition?
You can export the report definition to a .skyr file by using the Manage Reports dialog.
On the Document Grid, you can use the menu item "Manage Reports" on the Reports dropdown at the top of the Document Grid.
In the Manage Reports dialog, you can select your report of interest and use the "share" button to export the report definition to a .skyr file.

Can you send me that .skyr file?

It's also possible that the report behavior that you are seeing has something to do with your Skyline document, so you might as well send me your Skyline document too if that's not too much trouble.
In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If I get that .skyr file and .sky.zip files I will probably be able to figure out what is going on. If you cannot send those files, then it would be helpful if you could send me a screenshot of your "Customize Report" dialog.

-- Nick
 
MartijnvF responded:  2020-03-27
Hi Nick,

sorry, that i did not attach these documents right away. I did tick the box op of " Pivot Isotope Label" . See attachments for the requested documents.

Thank you!

Martijn
 
Nick Shulman responded:  2020-03-27
Martijn,

Thank you for sending those files.
There are a couple of things going wrong here.

1. Skyline has a bug where if you include the "Quantification" column in your report, then the pivoting will not work, and everything will appear on separate rows. This is because whenever Skyline compares two values from the Quantification column, Skyline always thinks that they are different, and must appear in separate rows. I will fix this in an upcoming release of Skyline-Daily.

2. Your report includes the "Area" column, which comes from the Transition Result. When Skyline is showing any columns from the Transition, and pivoting on the Isotope Label, Skyline has to figure out which light transition is the same as which heavy transition. In order to figure this out, Skyline looks at the value in a column called "Fragment Ion". This works great for peptides, since the fragment ion ends up being something like "y7". For small molecules, it ends up being something different (e.g. "Ion [166.050549/166.050549]") that in your case never is the same between light and heavy, so your light and heavy transitions end up on different rows. One way that you could work around this would be to give each of the transitions in your document a Name, but that's probably not worth the effort.
The other thing that you could do is remove the "Area" column from your report, and use the "Total Area" column instead.
When Skyline sees that you have no longer selected any columns from the "Transition", Skyline will stop looking at what appears in the "Fragment Ion" column. (There's another bug that as long as that "Pivot Isotope Label" thing is checked, Skyline won't notice that you've removed all the Transition columns, so you actually have to uncheck that checkbox and only recheck it after you have removed the Area column).

Here's what you should do to fix your report:
1. Edit Report
2. Uncheck "Pivot Isotope Label"
3. Remove the "Quantification" and "Area" columns.
4. Add the "Total Area" column (it's under "Molecule Lists > Molecules > Precursors > Precursor Results".
5. Check "Pivot Isotope Label".

Thank you for reporting these issues. I will try to fix them.

By the way, if you would like to do more complicated pivoting and would like more control over how rows are grouped, you should take a look at the Pivot Editor feature.
There is a PowerPoint showing how to use the Pivot Editor here:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=PivotEditor

-- Nick
 
MartijnvF responded:  2020-03-27
Hello Nick,

Thank you for the answer and clarification! Much appreciated.

Enjoy your weekend.

Cheers,
Martijn