Calibration Curve Errors for Light:Heavy Ratio bwidner  2019-10-04
 

Hello Again,

I have been using skyline for small molecules and prior to now I have made linear standard curves using the peak area. That has worked great. I just introduced isotopically labeled standards, and I am now having trouble getting the standard curves to appear for some molecules. Because it works for most molecules, I dont think it's a problem with my settings or Document Grid, etc. The problem is that the Calibration Curve plot will have data points on it, but it won't draw a line and lists NaN for Slope and R-Squared. I have tried everything I can think of to address this problem, and I can't solve it. It does seem to happen with the curve is fairly crappy.. When I just plot the peak area of the light compound for these, I get a curve as normal. Is it something to do with very low intensity heavy peaks?

I attached a photo of the problem, and I will upload the files to the file share thing momentarily.

Thanks!
Brittany

 
 
Nick Shulman responded:  2019-10-04
Thank you for sending that file.

The problem is that many of your external standards have a heavy peak area which really is zero. For this reason, the ratio to heavy is not-a-number, and that causes the slope etc. to also be not-a-number.

You can use the Document Grid to find the external standard replicates whose Normalized Area is NaN.
The Normalize Area column can be found in the Report Editor at:
Molecule Lists > Molecules > Molecule Results > Quantifiation > Normalized Area

The Molecule Results level also has a column called "Exclude from calibration".
You can use the Document Grid to find all of your external standards replicates where the Normalized Area is NaN, and you can exclude them from calibration, and then Skyline will come up with some value for the slope.

It looks like for some of your molecules the integration boundaries were manually chosen in areas of the chromatogram where there was no signal.
-- Nick