Building library for searching MS1 data using Spectrum Mill

support
Building library for searching MS1 data using Spectrum Mill carol_ball  2019-01-22
 

Skyline version 64bit 4.2.0
Spectrum Mill version B05.00
I created a pep.xml file of the valid peptide hits in Spectrum Mill
I then Opened Import Peptide DDA search results and put that pep.xml file in place
The software then gives the attached error - looking for a mzXML results file. If I pull the mzXML file from within the .d file Skyline will continue on but fails when it tries to use the mzXML as the result file. I can get it to work if I choose File-import result file. Why doesn't the wizard offer the .d files as the results file choice since the mzXML that I can pull out of Spectrum Mill isn't the file it actually needs?
In addition, the valid hits are all human as I used that as a filter in Spectrum Mill. When I import the database (swissprot.FASTA all species) that I used for searching instead of getting just the list of peptides that are in the pepXML I get LOTS of other peptides. It was my understanding that the pepXML file contains the sequences used to build the target list I'm not understanding how I can get many peptides in my list which are not in the pepXML?

 
 
Nick Shulman responded:  2019-01-22
Skyline uses another program called "BiblioSpec" to read peptide search results. BiblioSpec does not know how to read the same file formats as Skyline does. For this reason, it is best to put your .mzML files in the same folder as your .pepXML files. (We recommend using .mzML instead of .mzXML, since .mzML supports chromatograms, but both formats should work).

What do you mean that it fails when it tries to use the mzXML as the result file? Can you tell us what error you're seeing?

I am not sure what your other question is. Are you saying that you did "File > Import > FASTA", and Skyline gave you all of the tryptic peptides from the FASTA file, instead of the ones that were in your .pepXML files?
You can tell Skyline to only give you the peptides that are in the spectral library (which was built from the .pepXML files). That settings is at:
Settings > Peptide Settings > Library
If you have a library in your document, then there is a dropdown there "Pick peptides matching", and make sure that it is set to either "Library" or "Library and Filter", so that Skyline will only give you peptides that are in your library.

Another way to add library peptides to your document is to go to:
View > Spectral Libraries
and push the "Add All" button.

If you are adding peptides from the spectral library viewer, it is recommended that you first set up a background proteome by going to:
Settings > Peptide Settings > Digestion
A background proteome will enable Skyline to associate peptides with proteins.

By the way, the "Could not find spectrum" error message is poorly worded. It is using the "|" character to mean "or". It is saying that it was not able to find either "P01_AJS_8uL.mzML" or "P01_AJS_8uL.mzXML", and that it tried looking in the current directory, the parent of the current directory, and the parent of the parent of the current directory.

-- Nick
 
Brian Pratt responded:  2019-01-22
>> Why doesn't the wizard offer the .d files as the results file choice since the mzXML that I can pull out of Spectrum Mill isn't the file it actually needs?

SpectrumMill produces .mzXML files for use in library building, they aren't exact representations of the .d file. When using the Import wizard it's important to select only the .d files as your Result files - checking the "Exclude spectrum source files" box helps with this.