Importing error "Index was outside the bounds of the array"

Importing error "Index was outside the bounds of the array" rschoenh  2017-08-29 07:25

I have a set of wiff files that I'm trying to import into Skyline, and some are imported fine, while others give me an error message (pasted partially below). I used the same Analyst scheduled acquisition method for all files, and I can open up the wiff files in Analyst without a problem. I'm using Skyline version

Thanks so much in advance for your help!


At 7:13 AM:
Failed importing results file '(...path and file name...)'.
Index was outside the bounds of the array.
Brendan MacLean responded:  2017-08-29 07:35
Hi Regine,
Can you post a Skyline document (using File > Share to create a file) and a WIFF file that causes the error on

That will be the quickest way for us to reproduce and fix the problem.

Also, does the message box contain a "More Info" button that you could click and post the full contents of to this thread?

Thanks for the report. Sorry about the issue.

rschoenh responded:  2017-08-29 09:04
Hi Brendan,

thanks for your quick reply! I just uploaded the two files you suggested. I'm also pasting the "More Info" text below.


At 9:00 AM:
Failed importing results file '...path and file name...'.
Index was outside the bounds of the array.
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.PostChromDataSet(PeptideChromDataSets chromDataSet) in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 1276
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.Read(ChromDataProvider provider) in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 456
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.BuildCache() in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 270

Inner exceptions:
Exception type: System.IndexOutOfRangeException
Error message: Index was outside the bounds of the array.
Index was outside the bounds of the array.
   at pwiz.Common.Collections.ImmutableList`1.Impl.get_Item(Int32 index) in c:\proj\pwiz_x64\pwiz_tools\Shared\Common\Collections\ImmutableList.cs:line 252
   at pwiz.Skyline.Model.Results.ChromDataSet.TruncateMs1ForScheduledMs2() in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromDataSet.cs:line 1185
   at pwiz.Skyline.Model.Results.PeptideChromDataSets.EvenlySpaceTimes() in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\PeptideChromData.cs:line 274
   at pwiz.Skyline.Model.Results.PeptideChromDataSets.PickChromatogramPeaks() in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\PeptideChromData.cs:line 153
   at pwiz.Skyline.Model.Results.ChromCacheBuilder.ScoreWriteChromDataSets(PeptideChromDataSets chromDataSets, Int32 threadIndex) in c:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromCacheBuilder.cs:line 98
   at pwiz.Common.SystemUtil.ProducerConsumerWorker`2.Consume(Object threadIndex) in c:\proj\pwiz_x64\pwiz_tools\Shared\Common\SystemUtil\ProducerConsumerWorker.cs:line 181
rschoenh responded:  2017-09-07 11:34
Hi Brendan,

just wanted to see if you've had a chance to troubleshoot the issue that I reported above. Thanks so much!

Nick Shulman responded:  2017-09-07 12:02
This will be fixed in the next update of Skyline-Daily.
This happens if you have an SRM experiment with some chromatograms that have zero points in them.
rschoenh responded:  2017-09-07 12:45
Hi Nick,

excellent, thanks very much!

rschoenh responded:  2023-02-28 12:43
Hi Skyline Team,

funny thing, I got an error message today (see part of the error message text below) when importing a wiff file and when I searched your message board if someone else had already reported something similar, I saw that I had asked about this issue in 2017. :-) Apparently, this issue reared its head again after your most recent issues with importing wiff files. I thought I would reply to our string from back then. Thanks very much in advance for re-fixing this issue!


Error message text:

At 12:36 PM:
Failed importing results file ...
Index was outside the bounds of the array.
Nick Shulman responded:  2023-02-28 12:57
Can you post the full text of the error with all of the line numbers and stuff?
This error might be in the same place as the error you ran into many years ago, or it might be in a completely different part of the code base and just happens to have the same error message text.
-- Nick
rschoenh responded:  2023-02-28 13:24
Hi Nick,

hm, the error message was not very much more than what I pasted above, I had just deleted the file path from the message (I didn't see any line numbers). Instead, I'm attaching the zipped Skyline and wiff files to this message; hopefully that helps. Let me know what else I might provide.

Thank you!
Nick Shulman responded:  2023-02-28 14:01
Thank you for reporting this error.

When you see the error in the "Importing Results..." window, you can check the checkbox that says "More info" and then you will see all the line numbers and not just the "Index was outside the bounds of the array."

I believe this error only happens in Skyline-daily, and it is happening in the code for calculating the new "Shape similarity score". I will fix this bug soon.
-- Nick
rschoenh responded:  2023-03-01 12:38
Hi Nick,

I see, thank you very much!

rschoenh responded:  2023-03-07 08:31
Hi Nick,

this particular error unfortunately now came up for some sample runs for which we would need to look at the data sooner rather than later. Do you have an ETA for fixing this error, or, would you let us know how we can revert back to an older version of Skyline that didn't throw that error, if you think that would be a doable work-around for now?

Thank you!
Nick Shulman responded:  2023-03-07 14:19

Skyline version 22.2 does not have this bug in it. You can have both Skyline and Skyline-daily installed on your computer at the same time.

If you need to use Skyline-daily, here is a special build which is a preview of what the next official Skyline-daily is going to be like:

It is essentially the same as an "Unplugged" Skyline installer. You download it, unzip it, and run the "setup.exe" that is in there.
-- Nick
rschoenh responded:  2023-03-07 14:54
Hi Nick,

excellent, that worked. Thank you!

Have a great day,