Error message when loading in new result file

SProCoP
Error message when loading in new result file MWidya  2014-10-28
 
Hi,

I've just started exploring SProCop to analyse our QC samples and am having trouble getting it to work sometimes. I've successfully loaded and analysed a few test files, but as soon as I try using a different data set (using the same settings) or loading in a few new result files into a file that worked before I get an error message:

1>Error in dim(PA) = c(L, L2) :
1> dims [product 126] do not match the length of object [105]
1>Calls: tryCatch -> tryCatchList -> parse.cmdline
1>Execution halted
1>
1>Finished!
1>
 
Another error message I keep encountering is:

Error in plot.window(...) : need finite 'ylim' values
Calls: tryCatch ... parse.cmdline -> plot -> plot.default -> localWindow -> plot.window
Execution halted
Finished

It's probably something incredibly obvious that I'm missing, but could you point me in the right direction?

Thanks!
Kind regards,
Marcy
 
 
Michael responded:  2014-10-29
Hi Marcy -

 Thank you for your note. I think this is an error in that SPROCOP expects each peptide to only have one precursor. So if you have a two plus and a three plus charge state for a single peptide - it will throw this error. For finite ylim values - I am betting this is an NA problem. If you go to file export report Sprocop input preview than you can see if there are any NAs. We are very close (next few weeks) to updating this with new capabilities and fixing these problems. Please stay tuned. Also if this does not fix your problems could you send me your skyline document? - File - Share - and email me the zip. michaelbereman@ncsu.edu

Thank you
Michael
 
MWidya responded:  2014-11-04
Hi Michael,

Thanks for your reply. I've gotten passed most of the errors by indeed fixing some of the NA related problems and by having just one precursor, but for one file it's still not working.
I've emailed you the file, hopefully you can work out what I'm doing wrong?

Thanks,
Marcy