QuaSAR problem <2166>  2014-02-25
 
Hi,

We want to known how to calculate the LOD when heavy peptides are spiked in a matrix containing light peptides with unknown constant concentration.

In the panel QuaSAR, we want to use the option "none" in standard (because we don't know the concentration of light peptides)but we get an error message (joined ppt file)

Could you help us to use this option "none" and how to fill the IS spike column?

Best regards.

Luc
 
 
Susan Abbatiello responded:  2014-02-25
Hi Luc,
You need to use the annotation "IS Conc" in Skyline and fill it with the number 1 if your light peptide concentration is unknown. QuaSAR is halting because it is looking for this column. When you uncheck the option for "internal standard present" in the QuaSAR panel, then the LOD will be calculated in terms of peak area units. I hope that helps!
 
<2166> responded:  2014-02-25
Hi Susan,

thanks for your prompt answer.

I filled the IS Conc column with 1 as you said but got an error because IS Spike column is required.
I thus did the same with IS Spike column and got another error message (joined ppt file), only slightly different from the first.

Could you please tell me which columns are required in the results grid?

In case I wasn't clear in my last e-mail, here is the details of the experiment I did:
I made calibration curves the opposite way as usual: I took the matrix containing the endogenous light peptide and I added a growing concentration of the heavy peptide.
It works fine if I set Internal Standard as "Light area", but since I don't know the light peptide concentration, I would like to set "none" for standard and "heavy area" for analyte.

Thank you for your help.

Luc.
 
Susan Abbatiello responded:  2014-02-25
Hi Luc,

If you want QuaSAR to plot peak area ratio (PAR), then you need to provide it with something to use as an internal standard (to generate the peak area ratio). In your powerpoint slide, instead of using "none" for your standard, you have to use light area. I understand you don't want to use the light area because you don't know its concentration, so the other option would be to uncheck "use PAR for analysis".

My version of QuaSAR (1.1) has a checkbox above "Use PAR for analysis" that says "Standard present". You might need to download the latest version of QuaSAR on the Skyline website and update what you have (please let me know if you're using QuaSAR v1.1). If you leave this box unchecked, you may still need to indicate "light area" in the "standard", but it won't be used and your plots will be peak area vs concentration of your heavy and the LOD will be calculated in terms of peak area units.
 
<2166> responded:  2014-02-25
Still doesn't work with "none" and "use PAR" unchecked.

I aim to evaluate the LOD of the heavy peptide without considering the light one. Is it possible? Even with light peptide as standard? (what are the parameters to set to get this value?)

Furthermore, SkyLine ToolStore says that I have the latest version of QuaSAR(1.1), up to date. However, I can't see any "(Internal) Standard Present" box in my panel...

Thank you a lot, and sorry for the insistence.

Luc.
 
Susan Abbatiello responded:  2014-02-25
Hi Luc,

Can you upload your zipped Skyline file? If I can get it to work on my end, I can better suggest how to set up your QuaSAR parameters.

Thanks!
Sue
 
conundrum responded:  2014-03-01
Hi Susan,

I read with great interest this thread because I'm facing currently (my sequence just finished :) ) the same problem as Luc. I also had a constant complex/endogenous light background and did a serial dilution of a heavy peptides spike-in, bit QuaSar (a really nice external tool piece) ist not working.
I tried the different settings you discussed here, but I always get an error message (see attached .pptx)
I'm using Skyline 2.5 and QuaSar 1.1 (installed through the tool server) and the QuaSarTutorial files works perfectly.

I appreciate any help. Thank you very much and best
Fabian
 
Susan Abbatiello responded:  2014-03-01
Hi Fabian,
We're working on the problem. There is an issue in QuaSAR right now with processing data to generate plots and LOD data. We're working to resolve it.

Sorry for the inconvenience. We'll make sure this is updated when a new version of QuaSAR is available.
Best,
Sue
 
conundrum responded:  2014-03-02
Hi Susan,

thanks for the quick response. Do you know by any change how soon this will be?
Or if there is a work around (maybe a previous version of QuaSar)?

Thank you very much and best,
Fabian
 
Mani responded:  2014-03-03
Hello Luc and Fabian,

I have put the next revision of QuaSAR at http://www.broadinstitute.org/~manidr/QuaSAR-1_2.zip. This seems to work correctly with the dataset Luc provided, but this version is still being tested (and will be made available on the Tool Store after testing). Please try it out and let me know if you encounter any issues. Please remove the currently installed version and re-install this new zip file.

When running QuaSAR, uncheck "Standard Present", and check "Peak area plots". With these setting it worked for me with Skyline-daily (64-bit) 2.1.1.5169.

Best,
Mani
 
conundrum responded:  2014-03-04
Hello Mani,

thank you very much for this pre-release version of QuaSar. I deleted the QuaSar Version 1.1 from my tools and then added through the file you provided the new Version of QuaSar. It worked because also the window for the settings of QuaSar is different. It contains your mentioned "Standard Present" check-box.
To keep it simple I deleted from my almost 100 peptides all except 2 well measured heavy STD-peptides (ranging for testing right now from 1 to 150 fmol/ul). I still have the same settings for the Annotation as provided in my previous pptx.
In QuaSar 1.2 I can't check "Plot each peptide". Is this intentionally?
So I just used your recommend settings uncheck "Standard Present", and check "Peak area plots" but I still get an error message (see also pptx attached).

Interesting, if I delete the raw-file of the "background spike-in" (so meaning 0 fmol/ul, thus no spike-in of a heavy peptide standard). I get a different "error" message.

Is there something else critical for the selection of the peaks?

Thank you very much and all the best,
Fabian
 
Mani responded:  2014-03-04
Hello Fabian,

I'm not sure what is causing the error. If you can send us your data, we can take a look and see what could be wrong.
A couple of points:
1. Do you have replicates in the data? If there is only one replicate for each SampleGroup, the LOD calculation will not work (can't calculate standard deviation).
2. When you remove the 0 fmol/ul data, the error says that there is no data to calculate LOD (which is correct, since the program needs both 0 fmol/ul and one other concentration to calculate LOD)
3. The "plot each peptide" check box works fine on my installation of Skyline. Not sure what could be causing it to be greyed out on yours -- the Skyline team may have an answer. It is not supposed to be disabled.

Best,
Mani
 
conundrum responded:  2014-03-04
Dear Mani,

after taking care of your point 1. (added the replicates, checked the peaks) and 2. (left the 0 fmol/ul in the data set) but
the 3. the "plot each peptide" checkbox is still marked grey. But nonetheless it is working with the 2 peptides I have in my test data set. Tomorrow I'll try to expand it to my whole data set and try it.

Thank you very much for all the help.

Best
Fabian
 
conundrum responded:  2014-07-20
Dear Mani,

as I wrote in the last post, I tested QuaSAR and it was working fine; also with the bigger data set. I had to make another serial dilution and measured it. And so far QuaSAR runs still smoothly. Right now I'm not facing directly an issue with QuaSAR but I just want to make sure if I use it right.

As written in the last posts (Skyline 2.5. and QuaSAR 1.2) I have a constant complex light background and did a serial dilution of my heavy peptide standards (90 peptides in total). Now I wanted to calculated the LOD and LLOQ with QuaSAR and used the herein (in this request) described settings. "Analyte" was set to "Heavy peptide" and the "Standard" to "light Area". IS spike-in concentration was set to 1. The other settings are the standard ones (PAR is unchecked).
Everything runs smoothly and when I look at the lod-loq-final I get then concentration values (fmol/ul) since I checked "standard present".
Now my question is if these values represent my lod and loq from my heavy peptides?
I know if I uncheck "standard present" then the corresponding peak area will be there.

Thanks for any input.
 
Mani responded:  2014-07-24
Hello Fabian,

Yes the result will take into account your heavy peptides. Whether the actual LOD/LOQ value is correct depends on whether your constant light background (specified in the IS spike-in concentration) for that peptide is really 1 fmol/ul.

In the program, the concentration estimate for a peptide is calculated as: (analyte area / IS area) * IS spike-in concentration. In your case, this would be (heavy area / light area). As you can see, the units for the concentration estimate come from the IS spike-in concentration. If that is 1 fmol/ul, then your LOD/LOQ values will be correct on the fmol/ul scale.

I'm not sure if this answers your question. Please let me know if it doesn't.

Best,
Mani
 
conundrum responded:  2014-07-25
Dear Mani,

thank you very much for your response. Now I'm a bit confused since, as I understand your description, that I also need to know the absolute amount of my light background. But this is what I actually want to determine later with my known heavy peptide standard.
That's the reason I spiked-in my heavy peptide standard (fmol/ul) in a serial dilution in a constant unknown light background. To get the LOD and LOQ from my heavy peptide in order to know it for the light version.
But if I get it right I should not use 1 fmol/ul for the IS in Skyline but the actual heavy peptide concentration which I spiked-in. But this I used for the concentration column.
Thanks and best
Fabian
 
Susan Abbatiello responded:  2014-07-25
Hi Fabian,

If you don't already know the amount of endogenous (light) analyte in your sample, the exact LOD values will not be generated. You will be calculating an artifically low LOD if you use 1 fmol/uL if, in fact, the amount of light peptide is higher than this amount. There are ways to work around this, though. One thing you could do with the data you've collected is to plot just the heavy peptide response versus its concentration and ignore the light peak areas. Doing this will give you a response curve with the following equation:

Heavy peak area[peak area units] = slope[peak area units/fmol/uL]*concentration[fmol/uL] + y-intercept[peak area units]

I've indicated the units for each variable in [brackets].

You can then use the following equation from replicate "blank" measurements of your sample, which would include your sample matrix by itself (no heavy):

S(bl) = average S(bl) + 3*s(bl)
where "S(bl)" is the minimum signal required to define your LOD;
"average S(bl)" is the average signal of the heavy peptide in your blank samples (a minimum of 3 measurements is good;
and "s(bl)" is the standard deviation of your average heavy peptide measurements in your blank sample.

Once you define "S(bl)" above (which will have peak area units), you can divide this by the slope of your curve from above (which has peak area units/fmol/uL), and your resultant value will have fmol/uL units and be your LOD.

For your LOQ, you can replace the constant 3 with 10 or you can simply multiply your LOD value by ~3.3.

This portion of the calculation is somewhat manual, but doable. I believe you can get QuaSAR to calculate the slope and y-intercept for the "Peak Area vs concentration" plot so you don't have to do this. Each peptide will have its own slope and y-intercept as well as its own average blank peak area and associated standard deviation. This method of determining LOD is a basic one found in Analytical Chemistry textbooks and approximates the value pretty well. It doesn't use peak area ratio, but if you are unsure how much endogenous is in your sample, then it is a good way to go.

Alternately, if your light peptide signal is significant (ie, you can see the signal and it has a %CV lower than 15-20% and/or a signal-to-noise value greater than 10, you can determine the endogenous amount for your peptides for each heavy spike level...just use the equation Mani laid out above, but solve for the light:
Light amount (fmol/uL) = (light peak area/heavy peak area)* heavy spike amount (fmol/uL)
At higher heavy concentrations where the signal is appreciable, you should calculate the same light amount in each sample.

I hope that helps!
Best,
Sue
 
conundrum responded:  2014-07-25
Hi Sue,

thank you very much for the quick and detailed respond. But maybe we are talking at cross-purposes.
I don't want to know the endogenous light fmol/ug right now. I wanted to use QuaSAR to calculate the LOD of the heavy peptide which I spiked-in.
I know the exact amount of my heavy peptide standard which I use for the column "concentration" as in the given tutorial (and also in this post). I use the heavy peptide as "analyte" and the light one as "standard" (as it is in this case constant) as input for QuSAR. Or it this not possible?
 
I'll have on Monday more time to think more deeply about what you wrote and use it maybe for my purpose.
For sure I really appreciate your response as it helps me a lot to proceed with my thesis.

Thanks and best
Fabian
 
conundrum responded:  2014-07-30
Hi Sue,

I had time to think about your answer and realized that in my last response I wrote something what you had already written. Sorry for that.
But still another question, if I got you right now correctly, would it not be possible instead of using the 1 for the IS that I take the actual concentration (in fmol/ul) of my heavy peptide (e.g. 100 fmol/ul, 10 fmol/ul,...). Based on the equation from Mani (one response before): "(analyte area / IS area) * IS spike-in concentration. In your case, this would be (heavy area / light area)". Or am I wrong?

Thank you very much and best
Fabian