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Skyline Live Reports 
“Live Reports” is the name given to a group of windows available in Skyline which present information in 
rows and columns. There is a great deal of customizability in terms of which columns are displayed and 
how the rows are filtered. 

This tutorial will give an overview of several of these windows. 

Getting Started 
To start this tutorial, download the following ZIP file:  

https://skyline.ms/tutorials/LiveReports.zip 

Extract the files in it to a folder on your computer, like:  

C:\Users\brendanx\Documents  

This will create a new folder:  

C:\Users\brendanx\Documents\LiveReports 

To begin processing the data collected for the Differentiation phase of this method refinement study: 

• Open the “Rat_plasma.sky” file in the “LiveReports” folder. 

Enable Audit Logging 
The first thing to do in this document is to enable audit logging. The Audit Log in Skyline keeps track of 
all of the changes that have been made to the document. When you create a new document in Skyline, 
the audit log is usually enabled, but in this much older document, the Audit Log has not been enabled. 

• On the View menu, click Live Reports and then click Audit Log 

This brings up the Audit Log form 

https://skyline.ms/tutorials/LiveReports.zip
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• Click the Enable audit logging checkbox 

The Audit Log grid becomes populated with a set of entries which represent the difference between the 
current document and Skyline’s default blank document 

 

• Close the Audit Log window 

At the end of this tutorial we will return to the Audit Log and inspect its contents 

By inspecting the indicators at the bottom right corner of the Skyline window, you will see that the file 
you opened contains 48 proteins, 125 peptides and 722 transitions. 
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Showing the Document Grid 
• On the View menu, click Live Reports and then click Document Grid. 
• Click the Reports button in the top left corner of the Document Grid 

This shows the list of reports that are available to be shown in the Document Grid. 

 

The first five items in the list, Proteins, Peptides, Precursors, Transitions, and Replicates are the “built-
in” reports which cannot be modified. Each of these reports show essential information from basic units 
in the Skyline document. The set of columns that these reports have may change based on the state of 
the document. In particular, if there are any user-defined annotations, those annotations will be added 
to the appropriate built-in report. 

Below the built-in report are the user-defined reports which can be modified. Skyline ships with a small 
set of user-defined reports that are designed to be helpful. In addition, it is expected that Skyline users 
will define their own reports and share them with colleagues. 

• On the Reports menu in the Document Grid, choose Proteins if it is not already chosen 

This displays the built-in “Proteins” report, which shows the list of proteins in the document, in the same 
order that they appear in the Targets tree. 
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The first column in the report is displayed as a hyperlink, and clicking on text in those cells will navigate 
to the particular protein in Skyline. 

• Click on the fourth item in the “Protein” column (“NP_001012027”) 

This causes the fourth item in the Targets tree to be selected: 

 

The Status Bar at the bottom of the Skyline window also indicates that the fourth protein in the 
document is selected. 

 

The record navigator at the top of the Document Grid also indicates that the focus is in the fourth row. 

 

The Document Grid can be used to inspect many types of data. 

• Choose Replicates from the Reports dropdown at the top of the Document Grid 
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This document contains 42 Replicates. The names of the Replicates are all in three parts. The first letter 
of the replicate name is a “D” or “H” indicating whether the sample came from a diseased or a healthy 
rat. That is followed by an underscore, and then three digits which are the subject identifier of the rat. 
That is followed by “_REP” and then one more digit which identifies which technical replicate it is. 

Defining some Replicate Annotations 
Before using features such as “Group Comparisons”, it is necessary to tell Skyline more about these 
replicates. The way to do that is by defining some “Replicate Annotations”. 

• On the Settings menu, choose Document Settings 

 

• Click the Add button 

This brings up the “Define Annotation” dialog. 
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Annotations in Skyline must be given a unique name. There are three fundamental value types for 
annotations: text, numeric, and true/false. In addition, an annotation can be a “value list”, which is 
treated as a text annotation whose value is restricted to those in a specified list. 

• Fill in the form as follows so that the name of the Annotation is “Cohort”, the type is “Value 
List”, the values are Healthy and Diseased and the checkbox next to “Replicates” is checked. 
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• Press the OK button 

The new annotation now shows up in the Document Settings form 
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• Click the Add button 
• Fill in the form so that the name is “SubjectID”, the type is “Text” and the checkbox next to 

“Replicates” is checked 
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• Click the OK button 
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Now, two annotations have been defined and the checked checkbox next to each of them means that 
they are available in the current document. 

• Click the OK button 

The Document Grid which is displaying the “Replicates” report will show the new “Cohort” and 
“SubjectID” annotations which have been added to the document. If you click in a cell in the “Cohort” 
column you will see that it is a dropdown allowing you to choose the one of the two allowable values 
“Healthy” or “Diseased” (or blank). 

 

It certainly would be possible to fill in the values in the “Cohort” and “SubjectID” columns by either 
typing into those cells, or pasting a column of data into them. 
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Creating Result File Rules 
In this case, because the values of the annotations are so closely tied to the names of the result files, 
there is another feature “Result File Rules” which can be used to set the values. 

• On the Settings menu, click Document Settings 
• Click on the Result Files tab 
• Click the Add button 

This brings up the Rule Set Editor which allows you to specify ways of populating values in the Skyline 
document from values from the Result Files. 

• Click somewhere in the first row in the Rules list 
• Click the “…” button located to the right of the Rules list 

This brings up the Rule Editor 

 

• In the Pattern textbox, enter the letter D 
• In the Replacement textbox, enter the word Diseased 
• In the Target dropdown, choose Cohort 
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The Preview grid will show the effect that this rule will have. The File Name values in the first 21 
rows all do contain the letter D so that the Match checkbox is checked and the word Diseased is 
filled in for the Cohort 

If you move the scrollbar thumb down halfway you will see that the file names which start with “H” 
are not being matched. 
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• Press the OK button 

This brings you back to the Rule Set Editor where it is showing the results of that first rule 



14 
 

 

• Click somewhere in the second row of the Rules grid and then click the … button to the right 
of the grid 

• Fill in the Rule Editor with the letter H as the pattern, the word Healthy as Replacement and 
Cohort for Target 
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• Click OK 

This brings you back to the Rule Set Editor 
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• Click in the third row of the Rules grid, and then click the … button to the right of the grid 

The purpose of the final rule that we create is to set the SubjectID values to D102, H162, etc. by 
combining the first letter of the file name with the 3 digits that follow the first underscore. 

To accomplish this, the pattern that we are going to use is (.)_(…) The parentheses denote regular 
expression groups, which are parts of the matched expression which can be referred back to in the 
Replacement text with “$1” and “$2”. The period character (dot) will match any character, and the 
underscore character will only match an underscore 

• In the Pattern textbox, enter (.)_(…) 
• In the Replacement textbox, enter $1$2 
• In the Target dropdown, choose SubjectID. 

It should now look like this: 
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• Press the OK button 

This returns you to the Rule Set Editor which should now look like this: 
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• In the Name textbox enter “Cohort and SubjectID” 
• Press the OK button 

This returns you to the Document Settings form where the “Cohort and SubjectID” rule has been added 
and has a checkmark next to it. 

• Press the OK button in the Document Settings dialog 

The Cohort and SubjectID values in the Replicates report will be filled in from the file names. 

 

Creating a list of samples 
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• On the Settings menu, click Document Settings 
• Click on the Lists tab 
• Click the Add button 

This brings up the List Designer 

 

• In the List name textbox, enter “Samples” 
• In the first row of the grid, enter “SubjectID” in the Property Name column 
• In the second row of the grid, enter “Sex” in the Property Name column 
• In the third row of the grid, enter “Weight” in the Property Name column and choose Number 

in the Property Type column 
• In the fourth row of the grid, enter “Name” in the Property Name column 
• In the ID Property dropdown, choose “SubjectID” and in the Display Property dropdown choose 

Name 

The List Designer should now look like this: 
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• Press the Save button 
• Press the OK button in the Document Settings dialog 

This brings you back to the main Skyline window. 

• On the View menu choose Live Reports and then Lists and then Samples 

This brings up a grid which shows the list that we just defined. There are no rows in the list, but it has 
the four columns that we defined: SubjectID, Sex, Weight and Name 
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It would be possible to fill in values by typing into the grid, but we have already prepared a text file with 
data that can be used. 

You can navigate to that text file using the “File > Open Containing Folder” menu item in Skyline. 

• Click on the File menu and choose Open Containing Folder 

This will bring up the Windows Explorer on the folder containing the Skyline document. Find the file 
there called “SampleInfo.txt”. Double-click on that file in Windows Explorer. 

This will most likely bring up Notepad, a simple text editor. The first line of the text editor has the 
column names “SubjectID”, “Sex”, “Weight” and “Name”. 

• Select all the text in the document except for the first line and copy it to the clipboard. 

Go back to Skyline and make it so that the first column of the first row in the List: Samples is the current 
cell. 

 

• Paste the text from the clipboard (Ctrl+V) 

This should add 14 rows to the grid. 
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Changing annotation type 
 

• On the Settings menu choose Document Settings 
• On the Annotations tab of the Document Settings dialog, click the Edit List button 
• Click on SubjectID in the Define Annotations dialog 
• Click the Edit button 
• In the Type dropdown, choose Lookup: Samples 
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• Click the OK button on the Define Annotation dialog 
• Click the OK button on the Define Annotations dialog 

Currently there is a bug in Skyline-daily that prevents lookup annotations from working with Result File 
Rules. The following two steps will not be necessary in the future 

• Select the Result Files tab in the Document Settings dialog 
• Uncheck the checkbox next to Cohort and SubjectID 

After that has been done you can continue with: 

• Click the OK button in the Document Settings dialog 

Notice that in the Document Grid, the values displayed in the “SubjectID” column are now the names of 
rats from the Samples list. For each row where the SubjectID annotation has matched something in the 
ID Property column from the list, Skyline displays the value from the Display Property of the list. 
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Looking at results in the Document Grid 
• Choose Peptides in the Reports dropdown at the top of the Document Grid 
• Choose Customize Report in the Reports dropdown at the top of the Document Grid 

This brings up the Customize Report dialog where the columns from the Peptides report have been 
selected. 

• Click on the name “First Position” in the listbox on the right 
• While holding down the shift key, click on the name “Peptide Note” in that same listbox 

This causes all the column names between “First Position” and “Peptide Note” to become selected. 

• Click on the red X to the right of the column list 

This removes the selected columns from the column list, so that only “Peptide”, “Protein”, “Peptide 
Modified Sequence” and “Standard Type” remain. 

• In the column tree on the left, expand the item “Peptides” and then expand “Precursors” and 
then “Precursor Results” 

• Check the checkbox next to “Total Area” 
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This adds the “Total Area” column to the list of chosen columns. 

 

When a column is added to a report, it is usually inserted ahead of whatever column may be selected in 
the column list. If no column is selected in the column list then newly added columns are added to the 
end. 

We would prefer to have the “Total Area” column appear after “Standard Type” 

• Click the up arrow button to the right of the column list so that Standard Type moves before 
Total Area 

We would like to add another column to the report, and we would like that column to appear before 
Total Area 

• Click on Total Area in the column list on the right 
• In the tree view on the left, scroll all the way to the bottom 
• Click the checkbox next to Replicates in the tree view 

The Customize Report dialog should now look like this: 
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• Type “Peptide Areas” into the Report Name textbox 
• Press the OK button 

The Document Grid should now look like this: 
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This report has 42 rows for each peptide. 

Pivoting on Replicate Name 
 

• In the Reports dropdown at the top of the Document Grid choose Edit Report 

This brings up the Customize Report dialog again 
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• Click the Pivot Replicate Name checkbox 
• Press the OK button 

The Document Grid is now displaying one row per peptide. 

• Make the Document Grid window as wide as you can 

 

The “Replicate” and “Total Area” columns are repeated horizontally, showing values from the different 
replicates. 
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• Click on the first cell in the Peptide column where it says “CSLPRPWALTFSYGR”. This will select 
that peptide in the Targets tree 

• On the View menu choose Peak Areas and then Replicate Comparison 

This shows the peak areas for the currently selected peptide across all the replicates. The order of the 
replicates in the Peak Areas Replicate Comparison graph is the same as the horizontal order of the 
replicates in the Document Grid. You can visually verify that the Total Area values displayed in the 
Document Grid are the same as the values displayed in the Peak Areas Replicate Comparison graph. 

 

The “Normalized Area” column 
• On the Reports dropdown at the top of the Document Grid choose Edit Report 
• Click the binoculars button on the tool strip at the top of the Customize Report dialog 
• Type “Normalized Area” into the textbox in the Find Column dialog 
• Click Find Next 
• Click the Close button on the Find Column dialog 

The Normalized Area column is now selected in the column tree on the left 
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• Click the checkbox next to Normalized Area 
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• Click the OK button in the Customize Report dialog 

The Document Grid now shows the values from the “Normalized Area” column next to each of the 
“Total Area” values. 

 

The values shown in the “Total Area” columns are the same as the values in the “Normalized Area” 
columns although they are formatted differently. 
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Changing the format on a column 
It may be easier to see that the values if you change the format of one of the columns to be the same. 

• Right click on the column header where it says “D_102_REP1 Total Area” and choose Number 
Format 

• In the Choose Format dialog, choose Scientific 3.1416E+0 in the dropdown. 
• Press the OK button on the Choose Format dialog 

 

It is now much easier to see that the values in the “Total Area” and “Normalized Area” columns are 
the same. 

Notice that in the tenth row in the “D_102_REP2 Normalized Area” column there is a red 
exclamation mark next to the value. 

If you hover the mouse over the exclamation mark you will see a tooltip. 

 

In order to investigate that 

• Click on the blue underlined text in the first column of the tenth row in the grid 
(“TGTNLMDFLSR”). This will select that peptide in the Targets tre. 

• Click on one of the blue underlined “D_102_REP2” to select that replicate 
• Move the Document Grid and other windows out of the way so that you can see the 

chromatograms in the main window. 
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The red exclamation mark is warning that the integration boundaries of the chosen peak coincide with 
the edit of the time range of the acquired SRM chromatogram. This could be a problem when comparing 
peak areas between replicates, as replicates with truncated peaks will tend to have lower peak areas 
than non-truncated peaks. 

Sub-properties of the Normalized Area column 
• In the Reports dropdown at the top of the Document Grid choose Edit Report 
• Double click in the Normalized Area in the list on the right 

The Normalized Area in the tree on the left will become selected when the column is double clicked in 
the list box. 

• Click the plus button to the left of the Normalized Area node in the tree to expand it 

This reveals three additional columns which could be added to the report. 

• Click the checkbox next to Normalized Area Raw, Normalized Area Strict and Normalized Area 
Message 

• Click OK in the Customize Report dialog 
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• Make the Document Grid as wide as you can so that you can see the cell with the red 
exclamation mark 

 

The values in the Normalized Area Raw and Normalized Area Strict are generally the same as each 
other, except in the place where the Normalized Area value has a red exclamation mark and the 
Normalized Area Message value is not blank. In that spot, the value of “Normalized Area Strict” is 
“#N/A”. 

• In the Reports dropdown choose Edit Report 
• In the Customize Report dialog, uncheck the Pivot Replicate Name checkbox 
• Press OK in the Customize Report dialog 

This now shows a narrower view of the report with many fewer columns and more rows. 

Calculating the average of columns of data 
• On the tool strip at the top of the Document Grid, click the second button from the left ( ). 

That button has two sections. The right section of that button is an inverted triangle. You can 
either click on the left part of the button which will bring up the Pivot Editor, or you can click on 
the right part of the button which will drop down a menu and choose New Pivot 

This brings up the Pivot Editor 

• In the column list on the left, click once on Normalized Area Raw and then, while holding down 
the shift key on the keyboard, click on Normalized Area Strict so that both of those columns are 
selected. 

• In the dropdown in the middle at the bottom of the Pivot Editor dialog, where it currently says 
“Sum”, choose “Mean” 

• Click the Add Value >> button above that dropdown 
• Click the OK button 
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The Document Grid now shows only a single row where the two columns show the average value from 
the Normalized Area Raw and Normalized Area Strict. 

The average value in the Normalized Area Strict cell is a higher number than the value in the Normalized 
Area Raw cell. This is to be expected because truncated peaks tend to have smaller than expected areas 
and excluding them from a list would tend to result in a higher mean. 

Pivoting with row headers and column headers 
 

• Click on the inverted triangle in the right portion of the second button from the left on the 
toolstrip at the top of the Document Grid. 

• Hover the mouse over the Transforms item 

 

This shows a list of the operations which have been performed on the report. 

• Click on the No Transforms item 

This restores the Document Grid to the way that it looked before 
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• In the Reports dropdown at the top of the Document Grid choose Edit Report 
• Click the “+” button next to  “Replicates” at the bottom to expand it and then click the checkbox 

next to SampleID 

 

• Click the OK button in the Customize Report dialog 
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This adds the SampleID column to the report 

 

• Click the second button from the left on the tool strip at the top of the Document Grid to bring 
up the Pivot Editor 

 

• Click on the Peptide item in the list box on the left and then press the Add Row Header button 
• Click on the SampleID item in the list box on the left and press the Add Column Header button 
• Click on the Normalized Area Raw button on the left 
• Choose Coefficient of Variation in the dropdown below the Add Value button 
• Click on the Add Value button 

The Pivot Editor should now look like this: 
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The report now shows the Coefficients of Variations for each peptide between each rat’s technical 
replicates 

 

• Click on the column header which says “Drizzle CV Normalized Area Raw” and choose Sort 
Ascending 

• Click on the peptide SVVDIGLIK which is in the first column of the first row 
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The currently selected peptide now has the lowest CV for the rat named Drizzle of all of the peptides in 
the document. 

Look at the Peak Areas Replicate Comparison window 
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The very large bar at the left edge shows the relative intensities from the spectral library. The three bars 
immediately to the right of that belong to the rat named “Drizzle”. Their heights are very similar to each 
other. 

• In the Document Grid, click on the Drizzle CV Normalized Area Raw column and choose Sort 
Descending 

• The peptide AGSWQITMK now sorts to the top. Click on that peptide to select it in the Targets 
tree and look at the Peak Area Replicate Comparison graph 

 

The currently selected peptide has the most variation in peak areas across the replicates associated 
with the rat named Drizzle. There is a great deal of variation in the heights of the three bars at the 
left end of the graph. 

Changing the Normalization Method in the document 
 

The “Normalized Area” column shows areas normalized according to the normalization method 
specified on the Quantification tab at “Settings > Peptide Settings” 

• On the Settings menu choose Peptide Settings 
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• On the Peptide Settings dialog, choose Ratio to Global Standards in the Normalization 
method dropdown 

 

• Press OK on the Peptide Settings dialog 

The Normalized Area values are now the Total Area values divided by the area of the Global Standard 
peptide. 

• Click on the Drizzle CV Normalized Area Raw column header and choose Sort Ascending 
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The very first row shows “0%” as the CV for each of the samples. This is to be expected because this 
document has only one Global Standard normalization peptide. The area of that peptide normalized to 
itself will always be exactly 1, and therefore the CV of that value will always be zero. 

Adding a filter to a report definition 
• In the Reports dropdown choose Edit Report 
• Double click on Standard Type in the column list on the right so that it becomes selected in the 

tree 
• Click on the Filter tab 
• Click the Add button 
• In the dropdown in the Operation column choose “Is Blank” 

The Customize Report dialog should now look like this: 
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• Press the OK button 

The first row with the global standard peptide VVLSGSDATLAYSAFK has been removed 

Adding a Group Comparison 
• On the View menu choose Live Reports then Group Comparisons then Add 
• In the Edit Group Comparison dialog, set the following values: 

Name: Peptide Group Comparison 
Control group annotation: Cohort 
Control group value: Healthy 
Value to compare against: Diseased 
Identity annotation: Sample ID 
Normalization method: Default 

• Click OK on the Edit Group Comparison dialog 
• On the View menu choose Live Reports then Group Comparisons then Peptide Group 

Comparison 

This shows the Peptide Group Comparison grid 
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• Click the Bar Graph button at the top of the Group Comparison: Grid 

The bar graph plot shows the fold change values for each of the peptides that is displayed in the grid. 

• Click on the Fold Change Result column header and choose “Sort Ascending” 

 

The data is now sorted so that the peptides with the smallest fold change are displayed first and the 
peptides with the largest fold changes are displayed last. 

• Click on the first peptide in the grid (WWGQEITELAQGPGR) 
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• Look at the Peak Area Replicate Comparison graph 

 

This peptide clearly has lower abundance in the diseased replicates compared to the healthy replicates. 

• Right-click on the Adjusted P-Value column and choose “Filter” 
• Choose “Is Less Than” for the Filter Type and type “0.05” into the text box below that 

 

• Click OK on the dialog box 

The grid and the graph are now showing only the rows where the adjusted P-value is less than 0.05. 
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• Close the Peptide Group Comparison Bar Graph by clicking the gray X at the right edge of that 
window’s title bar. Do not click the red X above it because that will close both the grid and the 
bar graph 

Showing abundances with the group comparison results 
The group comparison grid can also show the per-replicate abundances which contributed to the fold 
change calculation 

• On the Reports dropdown at the top of the Peptide Group Comparison Grid choose Customize 
Report 

• Click the + button next to Replicate Abundances at the bottom of the tree in the Customize 
Report dialog to expand it 

• Check the checkbox next to Abundance 
• Type Replicate Abundances in the Report Name field 
• Click OK in the Customize Report dialog 

 

The grid now shows abundances for each peptide and replicate. The values shown in the cells are equal 
to the Normalized Area Strict values that were seen in the Document Grid, except that the values in the 
group comparison grid have been divided by the number of transitions in the peptide. 
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Showing a heat map with dendrograms 
• Click the inverted triangle to the right of the third button from the left on the tool strip at the 

top of the Peptide Group Comparison Grid window 
• Choose Show Heat Map from the drop down menu 

 

Skyline displays a heat map where the peptides and replicates have been reordered so that the 
dendrograms above and to the right of the graph can be drawn to indicate which rows and columns 
are most similar to each other 

Adding report definitions to the document 
• On the View menu choose Document Settings 
• Click the Reports tab in the Document Settings dialog 

This shows all the custom reports that Skyline knows about. These reports include the “Peptide Areas” 
which we created in the Document Grid and the “Replicate Abundances” report from the Group 
Comparison grid. There are also some small molecule reports which would only show up in the 
Document Grid if this were a small molecule or mixed mode document instead of a proteomics 
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document. 

 

• Check the checkbox next to Peptide Areas and Replicate Abundances 
• Click OK in the Document Settings dialog 

The Replicate Abundances and Peptide Areas report definitions are now part of this document. 

If you were to use the “File > Share” menu item to create a .sky.zip file containing this document and 
send that document to someone else, when they opened that document the “Peptide Areas” and 
“Replicate Abundances” report definitions from this document would be added to the list of reports in 
their Skyline instance. 

Inspecting the audit log 
• On the View menu choose Live Reports and then Audit Log 
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This shows in detail the operations that have modified this document. 

• In the Reports dropdown at the top of the Audit Log window choose Summary 

This shows a more concise list of things that have happened to the document with one row per 
operation. 
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Exporting a report 
• On the File menu choose Export and then Report 

 

This dialog allows exporting of reports from the Document Grid. The Peptide Areas that we designed in 
this tutorial is one of the choices. The “Replicate Abundances” report from the Group Comparison grid is 
not one of the choices because this dialog only allows exporting of Document Grid reports. 
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