Skyline Targeted Method Editing
This tutorial will cover many of the features available in the Skyline Targeted Mass Spec Environment for
creating new target lists for targeted analysis and instrument methods for Selected Reaction Monitoring
(SRM also referred to as Multiple Reaction Monitoring - MRM) mass spectrometers. The Skyline support
for creating documents from existing transition lists is covered in a separate tutorial.
In developing Skyline we aim to create a vendor-neutral platform for targeted mass spectrometry
investigation. From all Skyline documents, you will be able to export transition lists for SRM instruments
from Agilent, SCIEX, Shimadzu, Thermo-Scientific, and Waters. Skyline can also export native methods
for these instruments as well as methods and isolation lists for Parallel Reaction Monitoring (PRM)
which are not covered here.
One of the great benefits of exporting your methods from a Skyline document is that you are assured
the instrument output will import seamlessly for use in data analysis with Skyline, though this also is
covered in other tutorials.
Understanding how to create a targeted proteomics method in Skyline is a critical starting point,
however, a good reason to explore this tutorial.

Getting Started
To start this tutorial, download the following ZIP file:
https://skyline.ms/tutorials/MethodEdit.zip
Extract the files in it to a folder on your computer, like:
C:\Users\brendanx\Documents
This will create a new folder:
C:\Users\brendanx\Documents\MethodEdit
If you have been using Skyline prior to starting this tutorial, it is a good idea to revert Skyline to its
default settings. To do so:



Start Skyline.
On the Start Page, click Blank Document which looks like this:
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On the Settings menu, click Default.
Click No on the form asking if you want to save the current settings.

The document settings in this instance of Skyline have now been reset to the default.
Since this tutorial covers a proteomics topic, you can choose the proteomics interface by doing the
following:


Click the user interface control in the upper right-hand corner of the Skyline window, and click
Proteomics interface which looks like this:

Skyline is operating in proteomics mode which is displayed by the protein icon
hand corner of the Skyline window.

in the upper right-

You could start editing this blank document in a number of ways, but first you can give Skyline more
information about the proteins you will be working with. By giving Skyline this background information,
you allow Skyline to help you create information rich methods more quickly.

Creating a MS/MS Spectral Library
Since the method you will create in this tutorial will be designed to measure yeast proteins, you will first
create a MS/MS spectral library from part of a yeast data set downloaded from the Peptide Atlas on-line
data repository. You can do the same for any data set from Peptide Atlas, or you can just use the full
SpectraST libraries supplied by Peptide Atlas. There are 3 large public sources of spectral libraries all
supported by Skyline:



Peptide Atlas (http://www.peptideatlas.org/speclib/)
National Institute of Standards and Technology (NIST) (http://peptide.nist.gov/)
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The Global Proteome Machine (GPM) (ftp://ftp.thegpm.org/projects/xhunter/libs/)

You can also create new spectral libraries in Skyline using other publicly available data, or peptide search
results from your laboratory experiments. Skyline currently supports building libraries from the
following search result formats:






















ByOnic (mzIdentML, MGF)
Comet (sqt / ms2, pepXML / mzXML)
Mascot (DAT files)
MaxQuant Andromeda (msms.txt and modifications.xml)
Morpheus (pepXML/mzML or mzXML)
MSFragger (pepXML and mzML)
MSGF+ (mzIdentML, mzML or pepXML and mzXML)
Myrimatch/IDPicker (ipdXML and mzXML)
OMSSA (pepXML and mzXML)
PEAKS (pepXML and mzXML)
PeptideShaker (mzIdentML)
PRIDE XML
Protein Pilot (group or group.xml files)
Protein Prospector (pepXML and mzXML)
Proteome Discoverer (MSF and pdResult)
Scaffold (exported mzIndentML and MGF)
Spectrum Mill (exported pepXML and mzXML)
Trans Proteomic Pipline (pepXML and mzXML)
Waters PLGS MSe (final_fragment CSV)
X! Tandem (BioML XML)
Custom (SSL) (https://skyline.ms/blib-formats.url)

To start this tutorial, you can build your first BiblioSpec spectral library with Skyline by performing the
following steps:












On the Settings menu, click Peptide Settings.
Click on the Library tab.
Click on the Build button.
In the Name field of the Build Library form, enter “Yeast (Atlas)”.
Click the Browse button.
Navigate to the Library subfolder under the MethodEdit folder created earlier.
Click the Save button.
In the Cut-off score field, enter “0.95”as the minimum PeptideProphet score.
Click the Next button.
Click the Add Files button.
Navigate to the “Yeast_atlas” subfolder under the MethodEdit folder.
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Double-click the interact-prob.pep.xml file in this folder.
Click the Finish button.

You should see that Skyline has added the newly created “Yeast (Atlas)” library to the Libraries list in the
Library tab of the Peptide Settings form. The library build is performed as a background task, freeing
you to continue working. If you look at the Skyline status bar, you can see progress status for the library
build. This is a small data set, however, and the build will happen quickly. It may already have
completed by the time you read this. When it does, you will see a notification of completion slide up
from the lower left corner of the Skyline window.


In the Peptide Settings form, check the checkbox for “Yeast (Atlas)” to tell Skyline to use this
library in picking peptides and transitions.

The Library tab should now look like this:
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Creating a Background Proteome File:
You can also use FASTA sequence files to inform Skyline of the background matrix in which your
experiment will take place. In Skyline, this is called the Background Proteome. It can be as broad or as
narrow as you like, e.g. the entire organism FASTA for one or multiple organisms to 18 specific proteins
you plan to spike into an otherwise blank matrix, or anywhere in between.
For this tutorial, you will use the complete FASTA file for yeast, which you can do by performing the
following steps before clicking the OK button in the Peptide Settings form:










In the Peptide Settings form, click the Digestion tab.
From the Background proteome drop-list, choose <Add…>.
Click the Create button in the Edit Background Proteome form.
Navigate to the FASTA subfolder of the MethodEdit folder.
In the File name field, enter “Yeast”.
Click the Save button.
Click the Add File button.
Navigate to the FASTA subfolder of the MethodEdit folder.
Double-click the sgd_yeast.fasta file.

Skyline will scan the 5801 protein sequences in this file, create an index for peptide sequence lookup,
and save this to the file you created. The Background Proteome form should look like this:



Click the OK button.
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This takes you back to the Digestion tab of the Peptide Settings form, which should now look like this:

Skyline provides many editable lists like the two you just modified. The Enzyme list at the top of the
Digestion tab is another, and there are others on every tab of the Peptide Settings forms, which you can
explore later.


For now, click the OK button.

This commits these changes and returns you to the document in the main Skyline window.
Next you can begin adding proteins to the document to better understand how the new spectral library
impacts the peptide and transition choices Skyline makes.
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Pasting FASTA Sequences
The first method added to Skyline for specifying proteins of interest was the ability to paste full FASTA
sequence text directly into the document. To use this method, perform the following steps:







Use the Windows Notepad application to open the “Fasta.txt” file in the FASTA subfolder of the
MethodEdit folder.
On the Edit menu in Notepad, click Select All (ctrl-A).
On the Edit menu in Notepad, click Copy (ctrl-C).
Switch back to Skyline.
On the Edit menu, click Paste (ctrl-V).
Press the down arrow key until the first pasted peptide is selected.

This should leave Skyline looking something like this:



On the View menu, choose Ion Types, and then click B.

This makes Skyline highlight the b-ions for this peptide in purple in the spectrum graph. Here are the
steps to show precursor m/z and product m/z transitions Skyline has picked to monitor for this peptide:



Click on the + to the left of the peptide sequence displayed.
Press the down-arrow key to move the selection to the transition assigned “(rank 1)”.
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Skyline highlights ions in the graph as you select the corresponding transitions to present the following
view:

By default, Skyline has only chosen the 3 most intense charge 1 product y-ions as the transitions it will
measure for the charge 2 precursor. All this may be adjusted, however. To change the settings from
their default values, perform the following steps:






On the Settings menu, click Transition Settings.
Click the Filter tab.
In the Precursor charges field, change the “2” to “2, 3”.
In the Ion charges field, confirm the value is “1”.
In the Ion types field, change the “y” to “y, b”.
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The Transition Settings form should look like this:




Click the Library tab.
In the Pick field, change “3” to “5” product ions.
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The Transition Settings form should look like:



Click the OK button.
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The Skyline document tree should update to look like the following:

Skyline has added the rank 4 and rank 5 ions for the VDIIANDQGNR peptide, including its b5 ion. A new
peptide has been added as the first peptide in the YAL005C protein. By expanding it, you can see that it
is a peptide for which the new spectral library contains only a charge 3 peptide-spectrum match, while
the library clearly does not contain a charge 3 spectrum for the VDIIANDQGNR peptide. The library
peptide settings still direct Skyline to choose only precursors for which the spectral library contains a
matching spectrum. You can expand the LIDVDGKPQIQVEFK peptide to see an example of a peptide
where both charge 2 and charge 3 spectra were found in the spectral library.

Using a Public Spectral Library
The new spectral library contains a lot of matches for the YAL005C protein, but because it was built from
such a small data set many proteins show no peptides at all. Skyline is not, however, limited to using
just a single spectral library. You can, for example, add the publicly available library for Yeast from the
GPM. The yeast library from NIST is more extensive, but the smaller GPM library was chosen for this
tutorial. To add the GPM library included in the tutorial ZIP file, perform the following steps:







On the Settings menu, click Peptide Settings.
Click the Library tab.
Click the Edit List button.
Click the Add button in the Edit Libraries form.
In the Name field of the Edit Library form, enter “Yeast (GPM)”.
Click the Browse button.
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Navigate to the Library subfolder of the MethodEdit folder.
Double-click the “yeast_cmp_20.hlf” file.
Click the OK button in the Edit Library form.
Click the OK button in the Edit Libraries form.
In the Libraries list, check the newly created “Yeast (GPM)” item.

The Peptide Settings form should now look like the following:

Since Skyline can only choose a single spectrum to inform its product-ion decisions, and the value by
which to rank these matches remains blank in the Rank peptides by field, the libraries will be searched in
the order they appear in the list. Skyline will use the first spectrum match it finds. To see this in action:


Click the OK button.
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Once the library is loaded, Skyline updates the document to include a lot of new peptides. If you select
peptides and peptide precursors that were already present before the GPM library was added, you can
see that the spectrum chart title still attributes the spectra to the “Yeast (Atlas)” library. The spectrum
chart for new peptides and peptide precursors, however, displays “Yeast (GPM)” in the title.
NOTE: The GPM libraries unlike all other formats, store only the 20 most intense MS/MS peaks. You can
make your own judgment of how well you think the stored spectra actually match the spectra they claim
to, but you should do so with full knowledge of why so few peaks are displayed, compared with the
unfiltered spectra in other libraries.

Limiting Peptides per Protein
Some of the peptides now have quite a lot of peptide precursors to measure. You might really want to
measure them all before you start refining your document, a process covered in another tutorial. In this
tutorial, suppose you want to somehow limit the number of peptides you measure for each protein.
In the future, we hope to add predictive algorithms to Skyline that will allow this type of peptide ranking
without experimental data. At the moment, however, the only way to limit peptides per protein
without resorting to manually picking the peptides yourself is to use a ranking value supplied by a
spectral library. Unfortunately, the BiblioSpec library built in this tutorial and the public library from the
GPM do not share a comparable score. This means you will also have to uncheck one of the libraries to
use a ranking score.
Perform the following steps to limit the peptides per protein in the current document:







On the Settings menu, click Peptide Settings.
Uncheck the “Yeast (Atlas)” library. (The Library tab should still be active.)
From the Rank peptides by drop-list, choose Expect.
Check the Limit peptides per protein checkbox.
In the Peptides field, enter the number “3”.
Click the OK button.

You should have many fewer peptides now. You can now also get rid of the empty proteins:


On the Refine, click Remove Empty Proteins.

Now the tutorial returns to the background proteome file you created, and how it also can be used to
add information to the peptides and proteins you are working with as you edit your document.

Inserting a Protein List
Suppose you are working with a list of proteins. You may have the IDs used to identify the proteins in
your FASTA file, but you do not want to go through the FASTA file pasting each sequence one by one.
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Since you have set up a background proteome, all Skyline needs is a line-separated list of protein IDs
from the FASTA file you used to create the background proteome.
To add a list of new proteins to the current document perform the following steps:








Use the Windows Notepad application to open the “Protein List.txt” file in the FASTA subfolder
of the MethodEdit folder.
On the Edit menu in Notepad, click Select All (ctrl-A).
On the Edit menu in Notepad, click Copy (ctrl-C).
Switch back to Skyline.
Select the blank element at the end of the document.
On the Edit menu, choose Insert, and then click Proteins.
Press ctrl-V to paste from the clipboard.

Skyline adds the list of proteins to the Protein List grid, and assigns the Description and Sequence field
values found for the IDs in the background proteome. Because the background proteome lacks
accession numbers, preferred names, genes and species information, the columns will be empty. To see
more of the protein sequence, do the following:



Double-click the line between the “Sequence” and “Accession” column headers.
Click and drag the line between the “Description” and “Sequence” column headers.
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So that the form looks like:



Click the Insert button.

This will add these proteins to the end of the document. Many of them have no peptides matching
spectra in the GPM library, so follow these steps to remove empty proteins:


On the Refine menu, click Remove Empty Proteins.

Inserting a Peptide List
There are two ways to insert a list of peptides into a Skyline document, and they have the following
results:
1. A list of peptides separate from any protein information
2. Each peptide associated with a specific protein
To achieve the first result, perform the following steps:



Use the Windows Notepad application to open the “Peptide List.txt” file in the FASTA subfolder
of the MethodEdit folder.
On the Edit menu in Notepad, click Select All (ctrl-A).
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On the Edit menu in Notepad, click Copy (ctrl-C).
Switch back to Skyline.
Select the first protein in the document.
On the Edit menu, click Paste (ctrl-V).

Skyline adds the complete list of peptides to a single new peptide list element in the document, named
“peptides1”. You can rename the list now by simply typing the name you prefer.


Type “Primary Peptides” and press Enter.

The GPM library has spectra for all of the added peptides, which you can review by pressing the downarrow key to select each of the pasted peptides. The Skyline document should now look something like
this:

To insert the same list so that each peptide is associated with its respective protein in the background
proteome, you need to use the Insert Peptide List form. Perform the following steps to do this now:




First click the Undo button in the toolbar twice (ctrl-Z, ctrl-Z).
On the Edit menu, choose Insert, and click Peptides.
Press ctrl-V to paste from the clipboard.
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Skyline populates the protein fields for each peptide to present the form looking like this:



Click the Insert button to insert the peptides into the document.

The peptides have been added to the proteins by name instead of a single peptide list, as before.

Simple Refinement
At this point, you have added 70 peptides to the document without doing any confirmation further than
that the GPM yeast library contains a spectrum for each. To have a look at a peptide where the library
spectrum seems like a particularly poor match for what this document is trying to measure, do the
following:




On the Edit menu, click Find … (ctrl-F).
Enter “IPEE” in the Find what field.
Click the Find Next button.
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This spectrum shows only 1 matching y-ion and 1 matching b-ion, and looks like:

Measuring these two ions is unlikely to produce useful information about this peptide.
To remove all peptides for which the library spectrum failed to provide the desired 5 product ions,
perform the following steps:




On the Refine menu, click Advanced.
In the Min transitions per precursor field, enter the number “5”.
Click the OK button.

The status bar indicators at the bottom-right corner of the Skyline window show that the number of
peptides has been reduced from 70 to 64:

Checking Peptide Uniqueness
Another thing you might want to check is how unique the chosen peptides are to the proteins you are
trying to measure. Unfortunately, we have found that FASTA sequence files are frequently redundant
enough that it would be unwise to simply remove all peptides which are not unique to a single sequence
in the background proteome. Many peptides belong to multiple protein homologues of a single gene
model.
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Skyline does, however, offer a form for inspecting uniqueness of the peptides for each protein in the
document. Perform the following steps to review the last 2 proteins in the document you are editing:



Select the last protein in the document.
On the Edit menu, click Unique Peptides.

Skyline displays the Unique Peptides form with the following information:

A close review of these 6 proteins shows that some are similar to each other, but there is certainly
enough variation that this one peptide gives little confidence of measuring the protein of interest. You
can view the protein sequence for each protein by selecting its column in the grid view.



Close the Unique Peptides form, and press the Delete key to remove this protein from the
document.
Now repeat the same steps for the new last protein.

Skyline shows that the one peptide chosen for this protein also maps to multiple proteins, in this case 4,
but they are much more similar. You may want to keep this one.


Click the Cancel button.

Note: Since this tutorial was originally written a setting for enforcing peptide uniqueness has been
added to the Peptide Settings – Digestion tab, below the Background proteome field. It is labeled
Enforce peptide uniqueness by. You may want to explore how it impacts the peptides chosen in this
document.

Direct Document Editing
You have already seen that it is possible to delete items in the document using the delete key, as well as
to change the name of a peptide list by typing over the existing name. In this section, you will be
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introduced to a few more direct document editing features that allow you to quickly modify the
proteins, peptides, precursors and transitions you wish to measure.

Protein Name Auto-Completion
With a background proteome defined, you can get help in adding proteins and peptides simply by typing
on the blank element at the end of the document. To add a protein by name, do the following:



Select the blank element at the end of the document.
Type “ybl087”

Skyline will offer to complete this by adding a protein as shown below:



Press the Enter key to add the protein to your document.

Protein Description Auto-Completion
Skyline will also search the description text for the protein sequences from a FASTA file. To find and add
a protein based on its description, do the following:



Type “eft2”
Press the down-arrow key once to select the first protein listed, as shown:



Press the Enter key to add the protein to your document.

Peptide Sequence Auto-Completion
A third auto-completion option is to begin typing a peptide sequence, and Skyline will help identify the
peptide and the protein or proteins that contain it. To find and add a peptide by its sequence, do the
following:




Press Caps-Lock.
Type “IQGP”.
When Skyline shows the peptide IQGPNYVPGK, press the down-arrow key to select it.
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Press the Enter key.

The peptide is added to the document, but it is added to the existing protein YDR385W, just above the
final blank element. The added proteins should now look like:

Pop-up Pick-Lists
Once you have added proteins to your document, you can also use the Skyline pop-up pick-lists to
modify the peptides, precursors and product ions you will target. You can add another peptide to the
YBL087C protein by doing the following:




Move the mouse cursor over the YBL087C protein until a drop-arrow appears beside the name.
Move the mouse cursor over the drop arrow until the cursor image changes to a hand.
Click the left mouse button.

Skyline will show a pop-up pick-list that is initially filtered, and shows only the set of peptides it has
already added to the document. You could uncheck any of these to have the same effect as using the
Delete key to delete peptides from this protein. Instead, you can add a new peptide by doing the
following:



Click the button with the funnel image to get an unfiltered list.
Check the peptide with the suffix “(rank 6)”.

This should leave the pick-list looking like:
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Press the Enter key or click the button with the green check image to commit the change to your
document.

All items in the document that support sub-lists will display the same kind of pick-list. To change the
product ion transitions for a peptide precursor, do the following:






Expand the first peptide in the YBL087C protein (ISLGLP…) by clicking the + to the left of the
peptide sequence.
Move the mouse cursor over the 672.6716+++ precursor until a drop-arrow appears beside the
name.
Move the mouse cursor over the drop arrow until the cursor image changes to a hand.
Click the left mouse button.
Click the funnel icon to get an unfiltered list of possible product ions.

Suppose you had some reason to believe this particular precursor would be better measured with only
b-ions, and in fact you want to exchange the current 2 y-ions for 2 doubly charged b-ions. To do this,
perform the following steps:





Uncheck the two y-ions currently in view (y9 and y6).
Click on the button with the binoculars image to show the find field.
Type “b ++” (b-space-++) to filter the list to only items containing a b and ++.
Check the doubly charged b5 and b7 ions.
Note: This is just an example, and these ions were not found in the MS/MS spectrum.

The pick-list should now look like this:



Press the Enter key or click the button with the green check image to commit the change to your
document.
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Bigger Picture
Sometimes it helps to be able to see the information in your document in a broader context. You may
have noticed this already, as you moved the mouse over the document, but if not, hover the mouse
cursor now over some of the elements in the document tree, and Skyline will present data tips like the
ones shown below. In these tips, the selected element is highlighted in red, elements in the document
in blue, and bold is used for elements which match the filter but are not included in the document.

Drag and Drop
Finally, you can also use drag and drop to reorder certain elements in the document. In the document
you have created for this tutorial, only the proteins themselves may be reordered. The other elements
have inherent ordering, and cannot be moved. If, however, you create a peptide list with no protein
information, as you did above by pasting the list directly into the document, then you could also use
drag and drop to reorder the peptides within that list.


Use drag and drop now to reorder the proteins, and see that it works.
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Preparing to Measure
Of course, the end goal of all this document editing is to attempt to measure the peptides in the
document on a mass spectrometer. But, first you need to decide which mass spectrometer. Skyline
exports transition lists for triple quadrupole instruments from five manufacturers: Agilent, SCIEX,
Shimadzu, Thermo Scientific, and Waters. It can also now export native method files for all of these, but
some require instrument software and all require a method template to do this.
For this tutorial, you will export only one transition list for a SCIEX Q Trap. Before you do, you should
change some settings. To prepare your document for exporting a Q Trap transition list, do the following:








On the Settings menu, click Transition Settings.
Click the Prediction tab.
From the Collision energy drop-list, choose “SCIEX”.
Prom the Declustering potential drop-list, choose “SCIEX”.
Click the Instrument tab.
Change the Max m/z field to “1800”.
Click the OK button.

Before exporting your first transition list, first save your document to the MethodEdit folder by doing
the following:





On the File menu, click Save (ctrl-S).
Navigate to the MethodEdit folder.
In the File name field, enter “MethodEditTutorial”.
Click the Save button.

Next, you should note that the document created in this tutorial contains 355 transitions. If you already
had accurate measurements of when these peptides elute with the column you will be using, you might
be able to schedule them all in a single method, so that each is measured for only a small window of
time. Since you do not yet have these measurements, however, you will first need to measure over the
entire gradient, dividing the measurements into groups that can be measured throughout the entire
gradient for a run. The appropriate number to use will vary depending on the speed and sensitivity of
the instrument. The number can be many hundreds with modern triple quadrupole instruments, but this
tutorial was originally written for a SCIEX 4000 Q Trap on which 75 was thought to be appropriate.
With this information, you are ready to export a transition list for the SCIEX 4000 Q Trap. To do so,
perform the following steps:





On the File menu, choose Export, and then click Transition List.
Click the Multiple methods radio button.
Check the Ignore proteins checkbox.
In the Max transitions per sample injection field, enter “75”.
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This should leave the Export Transition List form looking like:





Click the OK button.
In the File name field, enter “Yeast_list”.
Click the Save button.

Switch to a Windows Explorer window, and navigate to the MethodEdit folder to see the transition list
files you just created. The contents of the MethodEdit folder should now look like:
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Open the first of the five new files, and you should find a transition list that looks like:

The columns are in the order: precursor m/z, product m/z, dwell time, extended peptide, declustering
potential, and collision energy. This should be enough to paste into the Analyst software method
creation user interface and create a method that you could use to run the instrument on a yeast sample
to attempt measuring these peptides.

Conclusion
There is certainly a lot more to learn about using the Skyline application for your targeted proteomics
experiments. You should, however, feel confident enough to begin creating your own real Skyline
documents. Hopefully these documents will help you get set up to measure peptides that test new
hypotheses quicker than you have before. Then you will want to import your instrument output files
back into Skyline for peak integration and results analysis. We think you will find that the context you
create in a Skyline document greatly simplifies understanding the instrument output. Just how to
perform these next steps, however, is covered in other instructional materials you can find on the
Skyline website.
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